Tech Stocking Stuffers: 18 awesome gifts under $50

Wireless does not work with integrated card on laptop

By Exonimus ยท 6 replies
Mar 13, 2008
  1. Hello everyone,

    One of my parents has recently purchased a new a laptop(a targa traveller 156x x2) specs are x2 tk-55 2 gig ram, etc.

    Anyway, the laptop has an integrated wireless card and came with vista home premium preinstalled. However, we cannot possibly get the thing to connect to our(or any, for that matter) wireless network. This is what I tried:
    -the regular way, entering network name,password etc etc. It gives an error message, but it says unknown error.
    -With a completely unhidden and unencrypted network, doesn't work
    -with a usb dongle, to make sure it's the card-> works perfectly, card doesn't
    -try xubuntu 7.10 live cd, and guess what? exactly the same problem. With the integrated card, I can see any wireless networks in range, try to connect, it asks me for a password, I give it, and nothing happens. Same story with unencrypted, it just doesn't connect. And again, if I use the USB dongle in xubuntu, it works perfectly.

    Does anyone have any idea as to what the problem might be? would installing XP possibly solve the problems?(this doesn't seem likely to me, since xubuntu linux gives exactly the same problems...) or could the card just be faulty?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    What you have described sounds most like a software error, rather than hardware, probably created in the setup stage.
    The usual trick is to remove all related software, edit the registry with a simple editor such as RegEdit or RegCleaner, then reboot and reinstall... after carefully examining the security on the master network... and WEP vs WPA setups.
    Or use software such as Network Magic.
    Be sure you have downloaded the latest drivers and firmware.
  3. jobeard

    jobeard TS Ambassador Posts: 10,869   +903

    wireless connection to what? your router (which one) or a hotspot.

    Update the firmware on the router and the wireless driver on the system.
  4. Exonimus

    Exonimus TS Rookie Topic Starter Posts: 77

    to router in my home. I already updated drivers to the latest version, and tried to use the manufacturers own network utility. Doesn't help either-> router is planet wrt-414.

    I'll give the: remove all related software a go, but there wasn't much because vista was already installed on the system, together with some pre-installed apps. But I'll give it a go none the less.

    edit: also updated the firmware, still nothing..

    Edit 2: I'll be damned. It works! wohooooo! the firmware update did it. Thanks a million, didn't think of that myself. :D :D
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Since the laptop is new, maybe you could just return it under warranty? The wifi card may be bad or the antenna leads may be disconnected or whatever.
  6. Exonimus

    Exonimus TS Rookie Topic Starter Posts: 77

    as said, the firmware update did it. I still wonder why, though. The updates page said something about DHCP updates, I guess that could have to do with it
  7. jobeard

    jobeard TS Ambassador Posts: 10,869   +903

    oh yea! if dhcp fouls out, then the TCP config is a mess :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...