1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP and Vista LAN issues for gaming - what's the source of the issue?

By chill78 ยท 6 replies
Aug 10, 2009
  1. Hello,

    I'm new to this board but I have spent ages looking for information that might help me to no avail. I apologise if I've missed it in my searching, and I know this problem seems to crop up a lot. But if you have any advice, I'd be most grateful.

    I have two laptops, one running Vista and one running XP. We're trying to play a game (we tried both Red Alert 2 and Battle for Middle-earth II, and we do have the most recent patches on both). We realised there was an issue when trying to play BFME II because we could see each other in the Lobby, and when one typed a message, it took about 10-15 seconds to show on the other's screen, and one could create a game, but when the other tried to join it, it would say "Failed: Connection Timed Out."

    So began our quest. This is what we have tried:

    1) Checking our IP addresses are in the same range.

    2) XP: latest update and installation of LLTD Responder

    3) Vista: latest update (SP2)

    4) both have tried with Windows Firewalls turned off (and on with exceptions including File & Printer sharing and the specific games).

    5) Turning off AVG.

    6) Vista: Network Discovery, File Sharing both on, with the network set to Private.

    7) XP: Network set to private.

    8) Both have workgroup name "WORKGROUP"

    9) Logging into our o2 (Thomson TG585 v7) router and opening ports 8808-65535 (as required for BFME II) - although I've done this according to step-by-step instructions, when I use various online port scanning sites, they all say that those ports are closed, so if this is the issue, I really need help in figuring out how to open the ports... I've logged in as SuperUser AND Administrator, made a manual entry of the port range from 8808-65535 set to be open on both my Vista machine and the XP machine, but this has made no difference. I know it's still saved because when I log back in, those ports are still there, but for all the good it does.

    10) Logged into the router and disabled the firewall. I know, a bit dodgy. I re-enabled it as it didn't do any good anyhow.

    11) Neither of us have an hidden firewalls that we might've missed that are running as I only run AVG anti-virus.

    12) Vista: password protected sharing is turned off though I don't see how this is relevant anyhow as we're not trying to share files but to play a game.

    On Vista, I can see the XP machine in the Network, and can access his public folders, but on the Wireless Connection Network Map, Vista is connected to the internet via the router, and his XP is down at the bottom saying it could not be placed on the map.

    We have also tried connecting directly to one another with an ethernet cable, and this made no difference whatsoever other than that we had an "unidentified" LAN with limited connectivity, but it didn't do any good from what I could see.

    We are using dynamic IP addresses, and I confess to not knowing much about IP addresses. I wouldn't think we'd need to set a static one to simply play a multi-player game (which, btw, yes we do each have our own version installed). We've tried connecting each laptop directly to the router with cables, directly to each other, and obviously preferably, just setting up a LAN through the wireless. No matter what combination of these things we've tried, I haven't seen a difference.

    One issue that I don't know if is normal or not is that when both machines are running the game, we both automatically lose WiFi connection until we shut down the game completely. Normal? I don't know. But it might help solve the issue.

    If you have any suggestions, please let me know! I'm pulling out my hair, and every tech-friendly person I've contacted that I know says "well, just make sure they both have the same workgroup name, and that Network Discovery is turned on," or "turn off your firewalls" as I suppose those are the most common mistakes, but we've tried that already.

    It would be immensely helpful if I could discover if the source of the issue is the Vista-XP communication is rubbish, or if it's our router which I'm told is pretty horrendous. Or if it's both. Or if it's the port thing, which I don't really understand either.

    Thanks for your time.
  2. chill78

    chill78 TS Rookie Topic Starter


    I guess I don't feel bad for not figuring it out - everyone I've talked to can only suggest the only standby "turn off your firewalls." Hmmmm.
  3. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 376   +8

    You may not have any luck figureing this out. This is a common issue throughout many games, I have a vista laptop with XP PC's and we cannot connect to play certain games.

    I have no idea the true cause of it but my I have a few suggestions: take the vista game, make sure it's running as administrator, then change the compatibility to run as XP.

    I personally think it might be one of two causes: Vista uses a new IPv6 and XP is on standard IPv4, I don't know how this could be the issue exactly, but IPv6 seems to have a lot of issue's, specially on older router models. Try turning off the IPv6 on your Vista machine. Go to your connections, right click the connection and go into the properties, there should be IPv6 and IPv4 checked, uncheck IPv6 and restart your Vista machine.

    My other theory would be that the router sees the two different machines on the same router and can't make a connection between the two for some reason, this goes back to the IPv6/IPv4 issue, but might be something else. Each has its own way of handling the information and transfering and using this information. We know the issue lies within the two computer's relaying information through the router, because computers play online (vista/XP) perfectly fine with no issues, but coming down to LAN connections its interuppted.

    Lastly there is a settings I just looked up on an XP machine that has a built in IP/TCP/UDP blocker in the TCP/IP settings. I wonder if this exists on the vista machine. I found this by going into the properties of my LAN connection, selecting Internet Protocol (TCP/IP), Properties, Advanced, Options, TCP/IP Filtering selected, Properties. See that this is on permit all for both.

    Please, if any of these things work or you find a successful fix, post back here. This is a big issue for people playing cross-O/S via LAN connection.
  4. jobeard

    jobeard TS Ambassador Posts: 13,018   +1,561

    That's a real problem and I have no idea why MS made IPv6 a default on Vista. The Internet backbone needs it, but not our LAN based systems.

    By all means, DISABLE IPv6 !
  5. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 376   +8

    Yeah, I don't understand why they made it a default, give the option, SURE, but make it a default and cause connection problems to most older router models, bad idea. lol. Disableing IPv6 can fix a few issues people may have with there connections (disconnects, loss of information, not being able to connect) So please if you know your router can't handle IPv6 then disable it.
  6. chill78

    chill78 TS Rookie Topic Starter

    Thank you very much for the suggestions and tips! I'm out of the country at the moment but when I'm back home I'm going to look into what you've said and post back any success!
  7. chill78

    chill78 TS Rookie Topic Starter

    Finally... after moving house and no longer being able to use our o2 router, and being back to a Virgin one - without fiddling with a single setting, we both fired of Battle for Middle Earth just to see and it worked immediately playing on the network.

    So, thanks for the tips folks. Turns out - don't use the stock routers o2 gives you ever because they're utter rubbish.

    Thank you!
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...