1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP Pro SP1 won't assign a drive letter to usb 2.0 flash drive

By waterskin ยท 31 replies
Dec 1, 2004
  1. It has no problem if I used a usb1.1 flash drive. However, when I tried a usb2.0 flash drive, there is no drive letter appearing in Windows Explorer.

    I am running XP Pro with SP1. My colleague has a PC with the same hardware configuration and I had no problem plugging the usb2.0 flash drive in his machine.

    Device manager did show the usb2.0 flash drive when I plugged it in the usb port.

    Any idea?
  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,248   +508

    For grins can you try changing the drive letter in device manager while it's plugged into a USB 2.0 port?
  3. waterskin

    waterskin TS Rookie Topic Starter

    How can I assign a drive letter in Device Manager?
  4. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,070

    Most of those style of drives have software to install.
    try uninstalling and re-installing.
  5. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 3,874

    It sounds like it is trying to share a drive letter with something else, like a virtual drive. I had this problem with my virtual drive I had setup to permanenely be G, well when I plug in my USB it should be G and it doesn't show up because that virtual drive was already taken up as a software drive, but not hardware. Check your virtual settings.

    :wave:Welcome to TechSpot:wave:
  6. BlueOcean

    BlueOcean TS Rookie

    what has worked

    Provided you have a USB 2 driver installed the issue we have seen is that the OS trys to assign the d: to both CDROM and Flash drive.

    Try right clicking the My Computer icon and select manage. Go down hte list to disk management and select your CD and right click, change drive letter to k or higher. This is a troubleshooting step. Restart your system and see if the flash drive appears. Depending on the number of drives you might want to try this with others, only do not change C.

    Also we have had problems with Dell laptops and external devices, check you vendor support.

    Good luck
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,545   +429

    You could also try and remove the USB Root Hub or USB Controllers in the device manager, and then rebooting. Windows should detect them again on restart. Its possible something got corrupted.
  8. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,070

    Sng.. reminded me, Real.... gave me some excellent help a while ago .
    Check out this thread. Especially the site he recommended for USB troubleshooter.
    Worked great
  9. waterskin

    waterskin TS Rookie Topic Starter

    Sorry I should have given more information to my problem.

    I had no problem using a USB1.1 flash drive plugging into the usb port of my PC. It came up with the drive letter G. BTW, my CD-ROW is drive F.

    However, after I bought this new USB2.0 flash drive, it didn't come up with the drive letter. My colleague's PC has the same configuration as mine, and I don't have problem using the USB2.0 flash drive in his PC.
  10. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,070

    You haven't stated what you did to load the drivers,software for the drive or if you have tried any of the troubleshooting tips mentioned to you.
    USB 2 is backward compatible to 1 , but it will run slower .
    Let us know how things work out.
  11. waterskin

    waterskin TS Rookie Topic Starter

    Thank you all for your idea and tips. Much appreciated.

    I finally got it working now. Poertner 1274 was right. Why didn't I get it was because I thought the usb drive will use the drive letter g? Before I bought this usb2.0 flash drive, I had a usb1.1 flash drive and it always got assigned the drive letter g. For this new usb2.0 drive, it got assigned the drive letter h. I had a network drive mapped to h and it could be the reason why I didn't see the drive letter for my usb2.0 flash drive. Now I un-mapped the network drive and I could see my usb2.0 flash drive in Windows Explorer.

    This forum is great.

  12. blaacksheep

    blaacksheep TS Rookie Posts: 69

    Here's a thought: Is USB 2.0 support enabled in your CMOS setup?
  13. LNCPapa

    LNCPapa TS Special Forces Posts: 4,248   +508

    Which is exactly why I initially said to try changing the drive letter.
  14. canvis

    canvis TS Rookie

    Hey thanks guys

    I had not previously been a member of your forum (I visit PCQandA) but I typed into a search engine "computer won't see SanDisk" and it lead me to your forum where I found the solution to my problem by re-mapping a network drive to a higher letter allowing the flash drive to use F.

    Just wanted to say Thanks!

  15. Imp

    Imp TS Rookie Posts: 18

    I think that you may have to install SP2 as SP1 does not support USB2.0, i have noticed whilst building new systems that there is an error with usb2.0 untill u install SP2 and then reinstall drivers to enable USB2.0 support
  16. waterskin

    waterskin TS Rookie Topic Starter

    When it was not working, I did try updating my XP SP1 to SP2. However, it was causing problem in Windows explorer and Internet explorer after I loaded SP2. The problem was it took long long time to open up My Computer and took long time to open new window link in IE. I was fed up so I removed SP2 from my PC.

    Now my PC is running SP1 and I have no problem using the USB 2.0 on my PC.
  17. jescando

    jescando TS Rookie

    cant get jumpdrive secure 2.0 to be recognized or create drive letter

    I am trying to follow your threads to see if i have a similar problem.

    I have a jumpdrive secure v2.0.

    I hooked it into a win2k machine and download files to it.

    Then i moved it over to a win xp pro sp1a machine. I tried to plug it in but no drive letter or recognition of its existance seems to happen.

    I did move my cd to drive letter l and m. One hard drive is c and the othe is f.

    Any other suggestions.
  18. waterskin

    waterskin TS Rookie Topic Starter

    When I was not able to see the jumpdrive in Windows Explorer, I went into Disk Management (Control Panel/Administrative Tools/Computer Management) and I was able to see the Jumpdrive in drive H. That's how I noticed that it was using the drive letter of one of my mapped drives.

    Good luck.

    p.s. Also check Device Manager to see whether you have Standard Enhanced PCI to USB Host Controller under Universal Serial Bus controllers or not?
  19. jescando

    jescando TS Rookie

    i tried both those things and i dont see the drive

    I have went back over the motherboard now and confirmed that i have my front panel wired to the usb 2.0 plug.

    I was told by lexar that i have to have some usbstor directory in my registry otherwise the driver wont exist.

    I dont know the drive light doesnt even turn on the jump drive 2.0 so i kind am wondering if the guy isnt right.

    I have tried everything including trying to download that version 3.0 beta.

    It says it doesnt see a card any where.

  20. blaacksheep

    blaacksheep TS Rookie Posts: 69

    It sounds like the front USB port isn't connected. Maybe you have the plug in the board backwards, or that connector is disabled in cmos. Did you try connecting your jump drive to a rear USB connector?
  21. jescando

    jescando TS Rookie

    tried that

    i checked all the connections and tried all ports thinking maybe only some of them would be even 2.0 compliant and some 1.1.

    The front port i wired directly into the 2.0 port on the main board.

    The cmos i enabled all 8 usb ports(4 in rear and 4 in front, then tried 6)

    Neither worked.

    Any time i plug the cartridge in it is as if its dead or something.

    I am going to try and retry the jumpdrive next week on my work machine.

    If it still works there i am at a loss to understand what to do now.

    My work machine of course is win2k not win xp pro.

  22. lstephe1

    lstephe1 TS Rookie

    Use Disk Manager to assign a drive letter.

    I have encountered this several times. It usually happened to me on systems with lots of network drive letters already assigned. The computer is looking to assign the next drive letter it would normally choose, but that letter is taken and for whatever reason it stops looking. Logically it should just go through to your lastdrive letter which is usually Z:, but it doesn't. Often, you have to manually assign it an unused drive letter. Right-click on 'My Computer' and select 'Manage'. Then under the 'storage' section, click on 'Disk Management'. It will list all of your local hard drives and CD/DVD Rom drives (it looks a lot like 'Partition Magic'). From there, you can manually assign that device to a drive letter you know to be unused. Then it will show up under 'My Computer'.
  23. StormBringer

    StormBringer TS Maniac Posts: 2,218

    I just want to play devil's advocate for a moment here. I see lots of replies blaming this on usb2.0 suppor, or lack there of. I have several of these usb key(jump drive, pen drive, whatever you want to call them) all of them are USB 2.0, several different sizes and manufacturers, and use them on several machines, some with USB 2.0, some with 1.1. I have yet to need to install any driver or software to get a drive letter or to use the drives(sans the "secure" feature of a couple of them) The only difference I've seen is that the drives are of course slower when using them in 1.1 ports.
    I've used these drives on front ports, rear ports, self powered hubs, bus powered hubs, laptops, desktops, Win2k(sp4), XP Home and XP Pro (no sp, sp1 and sp2), systems I've built, and branded systems.
  24. the1chad

    the1chad TS Rookie

    Jumpdrive Missing Resolved!!

    Hey, I followed the advice that I found about renaming cd drive letter except here at work it was our network drive (f) that was being taken by the jumpdrive. I remapped the network drive to (g) and then the jumpdrive was able to appear as (f)

  25. mushbrain

    mushbrain TS Rookie

    hi, i'm having a problem with my lexar jumpdrive secure. it is not appearing in 'my computer'. ii can see it in computer management > disk management. but it says it is an unknown partition. do i have to format this to assign a drive letter? i've right clicked it and all that is enabled is 'Delete Partition' and 'Help' :S.

    any help appritiated. feel free to email me. thanks.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...