XP Pro SP1 won't assign a drive letter to usb 2.0 flash drive

By waterskin ยท 31 replies
Dec 1, 2004
  1. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Just some basic info for anyone having these issues;
    Check the earlier posts-LNC,Poertner's advice works;
    -Windows(all flavours) can often become 'confused' with different types of 'removable' drives,Shares and periferals that require a Drive letter upon connection.
    Each time an item is connected then disconnected, drive letters dance around.
    I believe the biggest problem occurs between the Rom drives, mapped shares and these removable drives.
    Windows assigns drive letters to HDD's(partitions) first then Roms >removable items.
    To reduce confusion Change the drive letters to your Roms first,Some where in the latter half of the Alphabet(I use 'W' for writing drives V for DVD ,etc)
    Then follow the installation instructions for any removable drives then change those letters to leave some space between the Partitions and those drives.(eg. Middle of Alphabet)
    You should have less issues if you try this.
    Also Microsoft now offers a Free' USB Flash Drive Manager" (They know what goes on,then eventually they react) I have not used it my system seems to work fine with my setup. However go to "Microsoft/windows/partnerpack/desc/ufd.htm " ; and see what you think!It makes sense to me ,for what it is worth.
  2. Geo_dude

    Geo_dude TS Rookie

    I had this issue at work when I found this thread. The PC is locked down so I cant change anything or even bring up drive managaer. I had an external hard drive that connected fine but my USB 2.0 Lexar drive wouldn't mount.
    All of the drive letters are assigned (I assume to keep people from plugging in removeable drives.)
    After reading this thread, I plugged in both USB drives and rebooted my PC. Both drives where then mounted and I didn't have any more problems.
    Has this worked for anyone else?
  3. Swaine77

    Swaine77 TS Rookie

    same issue, no resolution

    I've got the same issue but no matter how many times I change drive letters in Disk Mgmt, I still can't get my thumb drives to show up in Windows Explorer automatically. I think it's a registry problem. I tried a registry fix that i found in another techspot post but it messed up my registry and I couldn't boot XP Home. Had to load a Restore Point. I have no virtual drives or network drives to my knowledge. I can use my thumb drives but i have to do the whole Disk Management thing every time, change drive letters, etc. Very annoying problem.
  4. dodge1997

    dodge1997 TS Rookie

    Lexar jumpdrive not assigned drive

    Don't laugh.. but I had the same with a Lexar jumpdrive... turned out the "neck" of the USB was not allowing the lexar drive to fully connect so it pushs it out. It works fine if I hold it snug and DON'T let is wiggle... ... of course I then have to stand on my head to get any files copied over! Ha! I'm now using a USB extension on the front port.
  5. gmapatches

    gmapatches TS Rookie

    I am new here. I was searching for help with my USB and I was led here. Seems other folks are having the same problem. I have another computer at work (IBM). Had a Dell and loved it but lease was up. I have a Dell at home. I have several USB flash drives and I interchange all of the time. They are each PNY 1 GB. I have two network drives assigned G and S. And E for Zip drive and D for DVD/CD. A for floppy and C of course. I have two front USB ports but the only way I can get the computer to recognize it is to start up with the USB plugged in and it takes over the G drive and tells me a network connection is not working. I would love to have the two USB drives assigned a letter that will recognize them when I plug them in and change to another USB drive. It is so frustrating. The Dell worked great and it is fine at home. Thanks for your help
  6. I have this problem all the time, as I use flash drives a lot in my job to load software and drivers onto multiple PCs. As with previous posters, I usually disconnect other removable drives and network drives then re-plug in the flash drive, it is usually then assigned the next driver letter after your CDROM drives and is visible in explorer. So for example if you have C:, D: as your HDDs/partitions and E: and F: as your DVD and CDRW, the flash drive will always be F: . You can then change your flash drive to something else such as G: and then re-enable your network drives and/or other removable drives. I'd imagine that the problem is the result of a bug. I believe this is the solution and doubt it is related to the actual USB at all.
  7. gmapatches

    gmapatches TS Rookie

    Thanks for replying so quickly. I am new at this posting stuff. I have already trick the disk management. I do not know how to manually assign a drive and I did not see any options telling me how.
    Can someone tell me how to manually assign drives to the two USB ports?

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...