XP wont assign drive letter to USB 2.0 HDD on USB 1.1 port

By TheJMan ยท 28 replies
Oct 12, 2003
  1. I have a USB 2.0 'enclosure' for 2.5" HDD with a 30GB Fujitsu MHT2030AT HDD.

    When I plug it into a system with USB 1.1 ports only, although the Mass Storage Device and the Fujitsu MHT2030AT USB Device appears in Device Manager, there is no extra Disk added to Disk Manager (so I can't partition/format it). The same arrangement on the same PC running Linux works fine (though, as expected, it runs at USB 1.1 speed)

    I am running Windows XP (SP1+) with ALL of the latest patches.

    I have also tested this on 2 other XP (fully up to date) and 2 Win2k (also fully up to date) systems with USB 1.1 ports and found the same problem in all cases.

    I'm leaning towards blaming the Updated USB 2.0 Windows drivers at the moment.

    Microsoft 'Knowledge' Base is of no assistance. I am rapidly running out of ideas. Apparently, this unit has been tested and works on USB 1.1 systems, BUT I'm not sure if it has been tested on XP with ALL patches.

    Has anyone else experienced this sort of problem? Any clues from the clue store?


  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    you are trying to use a USB 2.0 device in a USB 1.1 port? That is your problem. Get a USB 2.0 card. USB 2.0 ports will work with USB 1.1 devices, but USB 1.1 ports will not work with USB 2.0 devices.
  3. TheJMan

    TheJMan TS Rookie Topic Starter

    The USB-IDE device is said to be USB1.1 compliant. It was reported to have been tested on USB1.1 systems.


    I'd love to upgrade to USB2.0 but I have approximately 0 spare PCI slots on my system.
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    A new drive without a partition cannot be assigned a drive letter in Windows XP. You have to partition it first.

    You can do this in Start / Control Panel / Administrative Tools / Computer Management / Disk Management /

    I just happen to have a side-business selling external drives online, so I know how common this problem is with most people that put together their own external drives. www.drivefusion.com

    For this reason, I always partition and format my external drives for customers before I send them out so they don't complain. :)

    It's a common mistake, and hopefully this will solve your problem. If creating a new partition does not assign a letter to your drive, then the enclosure is probably defective.

    Another method of creating a partition is using Partition Magic or physically removing the drive from the enclsoure and installing it in your system.
  5. TheJMan

    TheJMan TS Rookie Topic Starter

    It IS partitioned and formatted - I did that on a Win2k box with USB2 ports.

    BUT - There is NO WAY for me to actually partition/format it on the USB 1.1 system because the DRIVE does not appear in Disk Manager (although it DOES appear in Device Manager)

    THAT'S the crux of the problem - PHYSICALLY, it seems to work - Windows is able to identify the drive (it gets the "Fujitsu MHT2030AT" id from the DISK itself) - which implies to me that it is actually capable of 'talking' to the disk itself.

    Logically, there's something stopping Windows from treating the disk as a disk - BUT, it does this WITHOUT issuing an ERROR or WARNING.
  6. TheJMan

    TheJMan TS Rookie Topic Starter

    This one's obviously too hard.

    Maybe it IS the USB-IDE enclosure that's stuffed (though tell that to Linux).

    I'm going to try another enclosure I think - send this one back to the distributor (who is not replying to my requests for help/info) and suggest rectal insertion.
  7. Justin

    Justin TS Rookie Posts: 942

    If I'm reading this correctly, in Disk Manager within MMC, the disk does not appear at all? Not even as a bad/unhealthy/damaged one? If it appears as a damaged partition, remember that NTFS partitions under one OS may have a drive letter assigned which NTFS would like to keep. If it can't assign that letter to itself it may not assign a letter at all. However, with Disk Manager you can assign a "non-appearing" partition a letter... IF that is the problem.
  8. filthy_mcnasty

    filthy_mcnasty TS Rookie Posts: 78

    you know, i had this EXACT same problem yesterday. yes, just yesterday. i found the problem to be
    a) the usb 2.0 drivers supplied by the manufacturer of my usb 2 port were crap, use the microsoft ones even though they say not to and it worked
    b) the hd itself was being a PITA. would only work in usb 1.1 ports even though it is a usb 2 drive.

    point being, check drivers but dont trust what they say and also might wanna see if your drive is still under warranty. i know the frustration you're going through. it looks like it's there in device manager but in my computer there's nothing. annoyance huh? post back if you need more help.
  9. grog

    grog TS Rookie Posts: 23

    I too was having that problem only it was with a USB 2 750 ZIP drive. Mine was working than I installed the software for it and the drive letter disapeared thus it wouldn't work. I tried finding a way to assign a drive letter but the computer would not see it.

    I than left the USB cord plugged in and unplugged the power cord to the drive waited a while. When I looked the drive letter was back. Good but when I went to us it again it was gone.

    I than remembered that it worked fine untill after installing the lattest software. So I uninstalled the Iomaga software and rebooted the computer and it's worked fine every sense.

    So this could be a driver problem and XP was asigning a better driver than the manufactor's software was. Or the software wouldn't work with the driver XP asigned.
  10. tmasri

    tmasri TS Rookie

    USB problem

    This problem got nothing to do with USB 2.0 or 1.1.

    I have had the same problem on a USB 1 enclosure along with a USB 1 connector.

    I have tried everything with no avail. When I insert the USB, WIN XP makes the beeping sound and I see the hard drive in Device Manager but XP does not allocate a drive letter to it.
    That Problem always seemed to happen right after I delete something from the hard drive (especially large files) and if it crashes, I get that recognition problem again.

    The only solution seems to connect the USB drive to win98SE. It usually works and I format the drive there and then I move it back to Xp where it is recognized.
  11. jlk62628

    jlk62628 TS Rookie

    You may need to check how many USB devices you've got plugged in. USB has two limits, power and bandwidth. If you are using too many USB devices at once you may run out of bandwidth on your bus or power to one or all of your devices. These failures can be intermittant or consistant. USB hubs do not increase the amount of power or bandwidth that you have available on your bus. They just spread it out to more devices. Devices that pull a lot of bandwidth are items like usb network cards, usb hard drives, wireless mice/keyboard devices, etc... Try taking other items off your usb ports and see what you get.

    For all I know you've already tried this. I also had a problem once with my external USB drive getting power to be detected properly and it was the drive, my manufacturer had to replace it.
  12. HBA_Whiteboy

    HBA_Whiteboy TS Rookie

    No Drive Letter Assigned to USB

    After purchasing a brand new USB 5.25 Enclosure I experienced this same problem. It can see it device manager but not in Disk Manager. I tried several different drives and found that it was only fast drives that had this problem UDMA33 work fine. So I changed the IDE cable and now the fast drives, even UDMA133, work Great! Brand New Non-Fuctioning Cable. Gotta Love it. :hotouch:
  13. justvisiting

    justvisiting TS Rookie

    Even though this thread is very old it appears that no one ever actually answered it. I came across this first while trying to fix the problem so for anyone else that is looking for an answer...

    For more information see this link: http://support.microsoft.com/default.aspx?scid=kb;en-us;297694

    The problem described in this thread is caused by the fact that a mapped (non local drive of one sort or another) is mapped as the next available drive and Windows XP doesn't bother to take that into account. The result is that the removable device you are trying to connect tries to map as the same drive letter as that non local drive and simply does not map at all.

    The work around is to change the mapped drive that is in the way to something further down the list. Then reconnect your removable and all should be well.
  14. Justatechhead

    Justatechhead TS Rookie

    Try this -from the MS site....

    To work around this issue if the new volume appears in Disk Management, specify a different drive letter for the new device or volume. To do this, follow these steps:
    1. Right-click My Computer, and then click Manage.

    2. Under Computer Management (Local), click Disk Management.

    3. In the list of drives in the right pane, right-click the new drive and then click Change Drive Letter and Path(s).

    4. Click Change, and in the drop-down box, select a drive letter for the new drive that is not assigned to a mapped network drive.

    5. Click OK, and then click OK again.
    Both the mapped network drives and the recently installed drive appear in Windows Explorer.
  15. amac

    amac TS Rookie

    this seems to be quite the common problem... i have the same issue.

    bought my 120GB esternal drive to back up all of my files off my laptop. good thing too, because shortly after my hard drive crashed. got a new hard drive and had to buy new windows (lost cd). anyhow, the workthrough listed above does not work for me because i, as it seems others have stated, cannot change any path letters etc. because the only place that my HD shows up is on the drivers list (with an ! mark on it). It does not show up in the disk management. this sucks because i got the darn thing to back up my files and both me and my sisters files are on the hard drive, (she replaced hers too), and it won't open up on either of our computers.

  16. Qu3ntin

    Qu3ntin TS Rookie Posts: 18


    Hey whats up guys.

    I googled the problem that i was having with my external hard drive and this thread seemed to relate the most to my problem. i know its been a long time since this thread has been active but i just figured i'd ressurect it because i used the steps above to try and fix my ex hd. So now i just finished formatting it, creating it as a partition but it wont let me assign a drive letter because it says that the device/volume isn't enabled. Any ideas?
  17. Qu3ntin

    Qu3ntin TS Rookie Posts: 18

    even now, after restarting, formating the hd again, making it a new partition, and uninstalling the drivers for the hd it still wont work. i know its there because it detects it and i can see it in both the safely remove hardware wizard and in the disk management. i just cant assign a drive letter so its not showing up in "My Computer"
  18. Qu3ntin

    Qu3ntin TS Rookie Posts: 18

    This is what im attempting to do btw, and cant because of the enable error, it just keeps telling me to restart
  19. rachel53usa

    rachel53usa TS Rookie

    I seem to be having exactly the same problem. The external hard-drive "bings" when connected so the computer obviously knows its there...also appears under "device manager", "disk drive" but NOT in "disk management". (also there in safely remove hardware)
    although the stuff written was along the right lines, i cant assign a drive letter because its not in the disk management section!!

    anymore advice?
  20. nocommente

    nocommente TS Rookie

  21. brandon dub

    brandon dub TS Rookie

    overlaying USB 1.0 with USB 2.0

    This must be a driver issue, although with over two years of dispondant indecision I cant be sure.

    I was brought here by keywords "usb 2.0 - 1.0"
    I have a mobo with 1.0 pins and have a 2.0 PC mount cable. Can I attatch this 2.0 cable to a 1.0 motherboard?

    I have yet to see any discouragement but I don't believe it could be that easy.
  22. Jano2001es

    Jano2001es TS Rookie

    Hi all.

    I was having the asme problem, and now is solved.

    The problem become because I was installed DAEMON TOOLS, and later I was reinstalled the Windows XP because a mainboard upgrade.

    You must delete the file "C:\WINDOWS\SYSTEM32\DRIVERS\SPTD.SYS"

    To do that you must start the Windows XP in safe mode command line.

    During the boot, there is a message at the bottom of the screen, saying something like: "Press Esc to disable SPTD". Ok press Esc when you see this message.

    In the DAMEON TOOLS web page, there exist a utility called "sptdinst_x86.exe". Download it to a simple folder, like "C:\TMP", and then execute "C:\TMP\sptdinst_x86.exe add". Then reboot the machine and the problem is solved.

    Kind regards.

  23. brandon dub

    brandon dub TS Rookie

    Well I bought a USB 2.0 PCI card and an external HDD enclosure for my problem.
    "Disc Management" seems to have some issues seeing the drive if it wasn't formatted properly first so:

    -use the manufacturers tools or Disc Management and
    -format from an IDE cable first (if you need to)
    -make sure you have all the right drivers installed
    -make sure your BIOS supports any of your hardware features
    -check if your drive was assigned a letter/name before (if it was "F:/maxtor" and now "f:/" is another drive it might confuse windows. you may need to navigate in regedit to:[HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices]
    and delete all entries like: "\DosDevices/A/B/C/D...":This resets how windows sees the hardware drive configuration. Not for most usb problems though)
  24. Tommy

    Tommy TS Rookie

    Jason, You are a HERO! - I have tried everything and then some, googled myself silly, and then I hit on your advice, tried it - and that was it.
    Thanks a million! Zillion!

    All the best - much luck - health - happiness!
  25. royorlev

    royorlev TS Rookie

    solution: a damaged virtual cd driver

    I think i have a solution for this problem.

    I had the same problem and looked around the internet for a solution, but nothing solved my problem. All the answers suggested testing the usb stick on another computer or using the disk management to assign a new drive letter, but these procedures didn't solve my problem.

    I had Daemon tools (virtual CD) previously installed on my system, and the installation was corrupted. I think it was after i repaired windows using the repair procedure from the original CD, which actually installs windows again over the existing one. After that Daemon Tools stopped working, disappeared from the "add/remove programs" list, but somehow stayed on the system and caused trouble...

    I think what was causing the problem is not Daemon tools itself (i used ver 4.0.3), but the ScsiPassThrough-driver (SPTD) that is installed with it (ver 1.25). Someohow it confuses windows with the drive letters. (according to daemon tools "SPTD is also used in some proprietary security, antivirus and monitoring applications...") so maybe you could have the same problem even if you don't have daemon tools installed. Anyway, you may want to try these steps anyway, they might solve your problem.

    i couldn't re-install daemon tools, since i got error when installing the sptd driver.

    How to fix the problem:

    1. download the stand-alone sptd driver from here: http://www.duplexsecure.com/downloads/SPTDinst-v135-x86.exe
    or here for 64bit:
    do not run the installation, but save it to the hard drive.

    2. start the computer in safe mode.

    3. click start->run... browse and select the installer from where you saved it, and add the word remove at the end of the line (so you will have something like (in my case i placed the installer on the desktop):
    "C:\Documents and Settings\User01\Desktop\sptdinst_x86.exe" remove
    and click ok.

    restart the computer normally.
    After i did this, i plugged in the usb stick and VIOLA! it works!

    You should be able to reinstall daemon tools if you wish to. If you still have problems with installing it, restart the computer again to safe mode and do the following:

    4. repeat step 3 but change the word "remove" to "add" like this:
    "C:\Documents and Settings\User01\Desktop\sptdinst_x86.exe" add
    and click ok.

    5. restart again normally and install daemon tools.

    I hope it helps...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...