XP Won't boot on my SATA HD

By wayfarer2169
Jul 15, 2007
  1. I am trying to install XP on a seagate SATA HD Using a Silicon Image sil 3512 PCI ATA card. I go through the f6 3rd party driver installation and everything works perfectly. However, once I restart my computer, all I get is the BSOD and an endless loop of restarts.

    My thinking is that windows uses the driver info long enough to copy the system onto the HD, but doesn't keep it around long enough to recognize the HD once it reboots.

    Any help would be greatly appreciated. By the way, I am using the latest drivers.


    HAMM-BONE TS Rookie

    me too

    i was given this computer with everything on it. It was working fine when i turned it off. when i tried to turn it on it wont stop rebooting, right before xp comes on.
  3. mailpup

    mailpup TS Special Forces Posts: 7,189   +471

    Wayfarer, I'm thinking that the PCI controller needs its driver installed before the SATA controller on the card can work. You can install the SATA PCI card's driver but you are missing a link in the chain. The PCI controller driver is usually installed after Windows is installed though. In your case I don't think you are getting to the Windows installation so far. I wonder if you can somehow install the PCI driver during the F6 process.

    Perhaps you can install Windows onto an IDE hard drive, install all motherboard drivers and then install the PCI card and driver and then install the new SATA hard drive, install Windows and drivers onto the new SATA drive and then remove the old IDE drive. I've never done this before so I'm not certain it will work but that's all I can think of at the moment.
  4. wayfarer2169

    wayfarer2169 TS Rookie Topic Starter

    The problem has been solved!!! Here's how... The Seagate HDD came with a utility disk. Every time I had been formatting the HDD, I was unplugging the IDE HDD first. The last time I did it, I left the IDE connected and the Seagate utility formatted the SATA HDD as a boot disk and copied the IDE contents onto it. It now works fine! Thanks to everyone who posted. Peace.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...