Tech Stocking Stuffers: 18 awesome gifts under $50

Yet Another Page Fault in Non-Paged Area

By apitman ยท 16 replies
Jan 31, 2008
  1. I have seen other people get answers from some very great helpful people for the PAGE_FAULT_IN_NONPAGED_AREA, STOP: 0x00000050 by uploading their minidump. If you are still out there helping, please he me. I have this error.

    I did a full memory test and it says the memory is fine, but who knows for sure.

    Most of the time it happens after I wake up from Hibernate and run Outlook and then VS 2005 and then load a project. Sometimes it doesn't, but when it does that is when it happens.

    Thanks so much for the help.

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Do you have any more minidumps? The one you gave said an 0x50 error but then points to ntkrnlp.exe and that is too generic for a definitive read.

    How long did you run MemTest?

    From on the 0x50 error:

    Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

    So as you can see your system crashes can be due to a myriad on things. Post more minidumps if you can.
  3. apitman

    apitman TS Rookie Topic Starter

    I can pretty much cause the crash by simply coming out of hibernate, loading Outlook and then Visual Studio and then my project. I can make some more, but am pretty sure they will show the same thing.

    Let me do it again and upload that one and you can take a look at it and see if it is the same.

    I ran the test for a while right after getting a crash. I assumed that if it was heat related or time related, doing it right after a crash should detect the memory problem if it was that.

    A couple of weeks ago I was installing a new piece of hardware and at some point during the whole thing when I rebooted windows it said it needed to do a chkdsk. When it did it found a whole bunch of files that were invalid. They were in \WINDOWS and system32 folders, so I would not be surprised if there are corrupt system files.

    I did a sfc.exe / scannow and it asked for the Windows CD, which I provided. I was hoping this would replace any of the bad system files.
  4. apitman

    apitman TS Rookie Topic Starter

    here is another dump

    I did find something a little different this time and am going to try to reproduce.

    Usually when I hibernate I disconnest my ethernet cable first. Then after coming out of hibernate I connect it back up. This last time when trying to reproduce the problem I left the ethernet connected and it didn't crash when I did the steps mentioned in the previous posting, so I disconnected the ethernet, hibernated, woke up, connected the ethernet and then did outlook and VS. That time it did crash.

    I am going to try to verify by doing the different steps multiple times and see if it is consistant.

    If it is then I will look for an updated ethernet driver. The weird thing is that I have been doing these steps for 2 years without a problem. It was only since last week that it started crashing with the same steps.
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Same error as before.
  6. apitman

    apitman TS Rookie Topic Starter

    I figured it would be. It is pretty consistant.

    So far it does seem to be related to disconnecting the ethernet, hibernating, waking up and then reconnecting the network. It may not be just the ethernet, however, because I have wireless at home and usually turn that on when I get home.

    Basically I disconnect whatever network I am connected to (wireless at home and ethernet at work), hibernate, go home or to work and then connect the network that I have there after waking up.

    Again, I have been doing this for 2 years now and it is just in the last week the crash has started.
  7. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    I find another problem at another forum has exactly the same symptom. Usually it crashes at vS 2005 and it still does not have solution. Your second minidump is crashed at VS2005 as well. Are you using dell?

    Mini013108-03.dmp BugCheck 10000050, {e3eb6000, 0, 899183de, 1}
    Owning Process 88dfcc08 Image: PTInsuranceImpo
    Probably caused by : ntkrnlpa.exe ( nt!PsCallImageNotifyRoutines+36 )

    Mini013108-04.dmp BugCheck 10000050, {e3dc2000, 0, 899233de, 1}
    Owning Process 885b4428 Image: devenv.exe <-- VS 2005
    Probably caused by : ntkrnlpa.exe ( nt!PsCallImageNotifyRoutines+36 )
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    I am wonder if you need to avoid hibernation? I have read of people experiencing what you are with hibernation.

    Very interesting there cpc2004.
  9. apitman

    apitman TS Rookie Topic Starter

    Thanks for everyone jumping in. Yes, I suspose I could avoid hibernate. Sadly it takes my computer 5 minutes too boot, so I really would miss it.

    The thing that drives me nuts is that it has been working fine for 2 years and now suddently a problem.

    I have uploaded another dmp file just in case it will shed more light (crashed again coming into work).

    A couple of more notes:

    I am using a Gateway, not dell.

    When I went to windows update there were 2 drivers updates (Finepoint pen update for tablet pc and network adapter). Both drivers are ones that I have already downloaded on this computer last year so I don't know why it needed them again.

    .NET 3.0 SP1 keeps trying to download even though I have told it to install. Tried 4 times in a row and it still wants to install again. I look in add/remove programs with show updates checked and sure enough it is NOT in the list. Don't know why it won't install right.

    Thanks again and help if you can. I wonder if suspend will cause the same problem?
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Another 0x50 error pointing to ntkrnlpa.exe as the cause which really isn't a help because it is too generic.

    If you haven't yet I would do the following:

    1. Run chkdsk.

    2. Harddrive diagnostics.

    3. Virus and malware scans.
  11. apitman

    apitman TS Rookie Topic Starter

    Yea, figured it would be the same, but I don't have the tools you guys have to know this. I really appreciate you looking at the files.

    1. chkdsk - already done several errors found
    2. Not sure what diagnostics to run...suggestions?
    3. some scans done, will get some software to do more extensive scans
  12. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Do you know what haddrive you have, i.e. Western Digital, Seagate, etc.? Almost all manufactures have free diagnostic tools. From what I understand WD's can be used on other drives not just their own but I am not 100% sure.

    If you go to TechSpot's Storage & networking forum they have a sticky entitled Drive diagnostic utilities compendium which contains links.
  13. apitman

    apitman TS Rookie Topic Starter

    I thought I had it fixed. I found that the .NET 3.0 SP1 kept wanting to install so I looked in add/remove programs and the SP1 was not installed. I decided to uninstall 3.0 and just install 3.5.

    I then used my computer like I always do day to day and went through the same Outlook, then VS2005 after coming out of hibernate and for 2 days it didn't crash. Then this morning it crashed again :-(.

    So I have been reinstalling stuff over the top including VS2005 and such. I even tried going back to a previous system restore. When I did that, however, all kinds of stuff quit working including VS2005. Don't know why, but that doesn't bode well for relying on system restore.

    Anyway, so I was reinstalling XNA Game Studio 2.0 and it crash when it was almost done. This is different because I had just rebooted. No hibernate involved.

    I have uploaded the minidumpin hopes that it is somehow different and will point to the right culprite now, but I won't hold my breath.

    BTW should I maybe turn on a full dump instead of just the minidump? Would that narrow things down at all?
  14. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Another 0x50 error citing ntkrnlpa.exe

    Another procees was listed in this minidump: devenv.exe

    devenv.exe is a process which belongs to the Microsoft Visual Studio, which is an application development suite from Microsoft. This program is a non-essential system process, but should not be terminated unless suspected to be causing problems.
  15. apitman

    apitman TS Rookie Topic Starter

    I may not have posted it above, but the whole crash thing is happening when I am running Visual Studio (normally). The only difference this time was that I was actually installing an add-on to Visual Studio (XNA 2.0) and Visual Studio itself was NOT running.

    Does this make any sense?
  16. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    It makes full sense if you have driver conflicts.
  17. apitman

    apitman TS Rookie Topic Starter

    Thank you for all the time you spend on this.

    So do you have any suggestions on what to do now? I have tried everything. Would a more full dump help?

    I am thinking about just getting another driver and starting over. I can't just wipe this one because I don't know what I would need to copy because I have stuff all over the driver and don't want to just copy everything because I might copy the problem as well.

    What do you think of Vista? This computer is about 2 years old and a 2.1 GHz with 2 GB of RAM. Thoughts?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...