ATI Radeon® Xpress 1150 256MB HyperMemory

By AlexK99 · 13 replies
Jan 2, 2007
  1. Hi there

    I recently bought an Inspiron 1501, with a ATI Radeon® Xpress 1150. My problem is that i cant seem to change the UMA framebuffer size to more than 16MB. I have tried using the ATI Catalyst control panel to increase the size, however once the laptop has been restarted the Framebuffer size remains on 16MB. Any idea why it does not let me change this?, and also, does having the Framebuffer size on 16MB mean that i am effectively running a 16MB graphics card?

    Any help appreciated :)
  2. tweakboy

    tweakboy TS Guru Posts: 467

    Your going into territories you need not to worry about,

    What exactly are you trying to get accomplished, ?
  3. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Yes, framebuffer set on 16MB basically means you are running on a 16MB graphics card. Try going into the BIOS to increase its size... if the GPU is integrated, that is the way to go.

    Tweakboy, he is trying to make his GPU have more memory capacity. In case you didn't know, that can often increase performance. And those aren't "Territories he need not worry about," as that is a relatively simple thing to do (no offense intended AlexK99, I am speaking as a PC builder :) ). Territories he need not worry about would be doing a VGA BIOS mod or something of the like.
  4. AlexK99

    AlexK99 TS Rookie Topic Starter

    :) Thanks Metal, I will try that :)

    how do I alter the framebuffer size in the BIOS?
  5. Dukesite

    Dukesite TS Rookie

    I cannot alter the framebuffer in my BIOS either. THERE IS NO OPTION! For some strange reason, they did not include an option in the bios to change it. I cannot find out why. If I change the UMA buffer size in the ATI Advanced properties, it has no effect. Please help anyone.
  6. AlexK99

    AlexK99 TS Rookie Topic Starter

    This is the exact same problem I am having. For some reason the graphics options on my BIOS have been removed, the ATI Catalyst controll pane has no effect either!
  7. AlexK99

    AlexK99 TS Rookie Topic Starter

    Please someone help!!!
  8. Dukesite

    Dukesite TS Rookie

    Fixed (mostly)

    Finally. I had just updated the BIOS in November, so I didn't think there was another one. I was wrong, the BIOS update in December 1.7.0 has solved this mystery. Although you still cannot change the UMA size in the BIOS settings, at least the Advanced properties of the ATI driver can modify it. Strangely, you can only change back and forth from 128 to 256 and back to 128, but that was all I was really looking for anyway. My lockups have stopped, and I can now set the video for Games or for MS Virtual PC as needed.

    Integrated video may not be the most desirable of video options, but for an inexpensive laptop, it really works very well (now that the video UMA change can be made).
  9. SBSB

    SBSB TS Rookie

    My BIOS version is 1.7 but I still have that problem. My guess would be that this is BIOS or/and Catalyst Control Panel programs bug. And I suspect it only applies to AMD dual core processors and possibly 1GB or more RAM of memory, correct me if I’m wrong.
    Below I post part of my message to the dell support team.

    ATI Radeon® Xpress 1150 video adapter (which came with my laptop) has ability to allocate up to 256MB of system memory. When I look at BIOS settings it reports that I’m having 768 MB of RAM, which is correct (I guess), since I have 1G of memory in total and as I suspect 256MB is allocated for video. Then, when I look at Microsoft’s System report under the Display options it reports 512MB of Adapter RAM (the interesting question is where another 256MB come from?). And then, when I look at Catalyst Control Panel program, which is came with the laptop (video card) to manage video settings it reports that UMA Frame Buffer is using 16MB (default), I think it’s because it does not have 512MB option in its combo box. In this program you suppose to be able to change the size of that buffer. But regardless of what settings I choose it does not change it. And the reason for that, as I think, that there is a defect (bug) in the BIOS software (which for some reason reports double memory size for video adapter) or/and in the Catalyst Control Panel program which could not interpret the buffer size correctly and as the result could not change it. In any instance it needs to be fixed.
  10. Dukesite

    Dukesite TS Rookie

    Try this

    You are running into the same brick wall I did. Download and install the 1.7 BIOS Update again (even if you already have it). When you do, the BIOS usually resets back to 128 MB of RAM instead of 256. I have far less problems when it is running in this mode (and, by the way, XP reports it as 256 in this mode). I run DOOM3, Half-Life: Episode 2, FEAR and others without a problem. If you use the ATI Control panel, you will have unexpected results. I have been fighting Dell for 2 months to no avail, so if you have any luck, let me know.
  11. Thantelius

    Thantelius TS Rookie

    It's very strange this flaw behaviour, once that the UMA value is changed in the original Catalyst, there's no way to choose a value bigger than 16 MB.

    I have found that executing the BIOS update this value is reseted to 128 MB, and installing the latest version of the Catalyst drivers posted by Dell, is a good combination to obtain a good performance, but when will be released a BIOS or a driver that allows to set this value to 256 MB?, my system has 2Gb of RAM and the video card shows a value of 512.
  12. blueDeath

    blueDeath TS Rookie

    i got a fix set uma and apply. it looks like it resets back, but when the system restarted. it sets to the new size
  13. wolfie00

    wolfie00 TS Rookie

    Maybe I can clear up a couple of things here. I just got an Inspiron 1501 with the ATI 1150 Radeon Xpress 1150 a few days ago, with 256Mb of hypermemory. I do not have the 16Mb problem, so whatever it was has been fixed in the newer BIOS revs.

    But as for "where another 256Mb came from" in the above quote, it came from the video system's on-chip memory! Hypermemory works by retaining only the most critical functions on the integrated memory, and "evicting" other functions onto system memory. In my case the total video memory is 256Mb, and is comprised of the integrated video subsystem containing 128Mb on-board video RAM, and it steals another 128Mb from system RAM to make up the 256Mb total. Thus I see 256Mb reported video memory in Catalyst, but Windows reports 896Mb system memory (I have 1 Gig) -- down by just 128Mb. It's not a bug in Catalyst or Windows or anything else -- this is how it's supposed to work!
  14. dutchfarley

    dutchfarley TS Rookie


    I must be completely clueless but I can't find where in the Catalyst Contol panel you can adjust the UMA value? I go to teh Advanced settings but can not find it. Any help would be appreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...