Battlefield 1942, file

By oscarp
Dec 31, 2008
  1. when i try to install Battlefield 1942 on my vista home premium laptop, i get through my first disk, it asks for my second disk, i open the drive and insert disk 2, it then goes for a bit. it then says cannot read file file. please try again later.

    can anyone help?
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    a message like "cannot read file file." can simply mean you need to clean that disc (and wipe horizontally, not circular) or the disk has gotten scratched

    but "please try again later." is odd.. or does this disk install also attempt to get updates over the internet when it;s running? do you know?

    try cleaning (per above) and disconnect your network cable before starting the install if the "try again later" should be implying it's attempting network access
  3. oscarp

    oscarp TS Rookie Topic Starter


    ok, i installed it, just plugged it in and tried to run it in administrator mode, it then worked. but once i get into the game i have no crosshairs when i have a gun out, only crosshairs with the knife and when i fly planes. But thanks for the help anyways. :approve:
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You're welcome.
    But maybe here's more info....

    You proved you can complete the software install from disk

    - But that's in part because (from my original guess) my instruction twas disconnect from internet first (probably why your first install got interrupted)

    So now you have software installed BUT is probably not current software so NEXT you need to have any updates applied. Look for an update function in game on your computer or go look at their website to see how to apply new updates
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...