1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD Vista Crash

By hinz ยท 37 replies
Dec 20, 2007
  1. Had two BSOD today but can't get windbg to work to see what the problem is.

    Could someone take a look at my minidumps


    Attached Files:

  2. hinz

    hinz TS Rookie Topic Starter


  3. Daveskater

    Daveskater Banned Posts: 1,687

    Please use the edit button if you wish to add new information when there are no new replies, and wait 24 hours before re-posting in your own thread to ask for more help. Our members are all over the world and can't reply in their sleep ;)

    Both your logs say this:

    Probably caused by: hardware

    So basically, we've narrowed it down to your RAM, Mobo, PSU, Graphics card Optical drive or Hard drive.

    However, it does have a BugCheck of 124, which is related to WHEA (Windows Hardware Error Aritcheture).

    Try updating your motherboard/chipset drivers and your video drivers to the latest versions from the manufacturer's website and the ATI/nVidia site, depedning on your card.

    What were you doing when the errors occurred?
  4. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Both dumps are crashed with bugcheck 124 and it is hardware problem.

    Mini122007-01.dmp BugCheck 124, {0, 854ccb00, b2000040, 800}
    Mini122007-02.dmp BugCheck 124, {0, 855662c8, b2000040, 800}

    Probably it is related to undetermined Level 0 cache memory error of the CPU. Refer this problem. Note the bugcheck code 9C at XP is similar to bugcheck code 124 at Vista.
  5. joshvito

    joshvito TS Rookie Posts: 18

    i am having bsod issues as well

    i get a bsod, at different times, doing light tasks. but there is little commonalities. using firefox, digsby, installing software.
    the machine is new.
    i have vista home 64bit
    i have attached my minidumps, any help is appreciated,
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    joshvito, for future considerations please start your own thread instead of resuurecting an old thread from a year ago. You'll find you'll get help quicker that way. :) That being said...

    All four minidumps state your errors 0x124: WHEA_UNCORRECTABLE_ERROR

    This is a difficult error to deal with because it means a serious hardware issue has occured but what is causing it is difficult to pin down. 3 minidumps were not much help because they listed core Windows drivers which are too general in nature.

    The other dump cited Rtlh64.sys and this is a RealTek driver for their ethernet/NIC cards.

    From my research people have corrected this BSOD by updating their drivers to video cards, sound cards, and NIC cards. Since your one minidump cites a RealTec driver try updating it.

    Others have found that they needed to do a Vista Repair or re-install.

    * Go with the simplest first and update the driver(s).

    *** Let us know of the results.
  7. joshvito

    joshvito TS Rookie Posts: 18

    just an update.
    i updated every driver i can think of, and i still get a bsod.
    wish i knew how to trigger one, then i could test the effectiveness of each driver faster.
    I'm wrestling with the video drivers now, ati catalyst is not being kind. i'm gonna attempt to use drivercleaner to get rid of all the pieces the ati uninstall utility missed. (i keep getting missing file errors when i uninstall)
    here are my machine specs.
    hitachi 1TB sata2 drive
    biostar ta790gx a2+
    amd phenom II x4 64 920
    g.skill ddr2-1066 2048MBx4
    ati radeon hd 4670
    i'll post again after i get the display drivers functioning
  8. joshvito

    joshvito TS Rookie Posts: 18

    drivers updated

    I uninstalled the drivers for my video card and reinstalled.
    so far, no bsod.
    i am afk for the next 7 hours or so, so i will be hoping when i return, that the drivers did the trick.
    I played unreal tournament three, and no bsod. however the game did end up crashing, and i get a weird sound/video jumble when i launch left for dead from steam.
    like I said earlier, i have no idea how to trigger the bsod, so i am in waiting mode.
    I'll update here in 24hrs or so if the drivers and the ati hotfix are successful in fixing the bsod issue.
    -thanks for all the help so far.
    sry about posting on the old thread:)
  9. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    The right move that you did was uninstalling and then making sure all old drivers were eliminated before reinstalling. Did you use a driver cleaner?

    As per what I posted earlier, this error can be caused by so many things. In your case it was video drivers. This post will add to the pool of knowledge.

    Thanks for getting back to us; much appreciated.
  10. joshvito

    joshvito TS Rookie Posts: 18

    the video card drivers didn't fix the bsod.
    after 12hours of up time, the system reported 3 bsod restarts.
    each one was the same 0x124 code.
    i used a driver cleaner on the video drivers, i am going to attempt the same process for the realtek nic and audio drivers.(i just did a plain update to these previously)
    I am wondering if this issue is related to the onboard video(ati radeon hd 3300).
    I can't find a driver on the ati site for it.
    also, i did a bios memory test, it took a couple hours and all the memory passed, does that rule out bad memory?
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    It wouldn't hurt to run memtest.

    As previously posted, the one driver cited was Realtek. They should have updated drivers for your system. I would do this first.

    As for your onboard graphics if you can find a graphics card that can fit your system (maybe a friend has an old one lying around), disable onboard via BIOS, and run with graphics card.

    *** This is the problem with this error. It is such a pain to pin down the cause.

    If updating Realtek doesn't work, attach minidumps.
  12. joshvito

    joshvito TS Rookie Posts: 18

    realtek drivers

    i have updated the realtek drivers.
    still getting bsod, i have attached the minidumps that occured after the driver updates.
    ran 2 memtests, both passed with no errors
    tried shutting off the onboard graphics in the bios. can't find a place to disable it?
    i am using a pci-e card as listed earlier.
    was using on board video as a hybrid crossfire setup, but removed the paddle card and only running off the stand alone card now.
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    For some reason my Alzip utility cannot access your files after I unzip. Is it possible to individually attach them individually or try to Zip the most recent 5 together?

    Also, I am wondering if your onboard hybrid crossfire configuration might not be your issue.
  14. joshvito

    joshvito TS Rookie Posts: 18

    here are last 5.
    the 2 newest occurred after i disconnected the hybrid crossfire.
  15. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Okay, four were the same 0x124 error and they all cited a core Windows OS driver which is too general to help us.

    The remaining minidump was 0x24 0x00000024: NTFS_FILE_SYSTEM

    A problem occurred within NTFS.SYS, the driver file that allows the system to read and write to NTFS file system drives. There may be a physical problem with the disk, or an Interrupt Request Packet (IRP) may be corrupted. Other common causes include heavy hard drive fragmentation, heavy file I/O, problems with some types of drive-mirroring software, or some antivirus software.

    ! Have you tried either a Windows repair, or running ChkDsk?

    Have you run a full harddrive diagnostics? Do this first.

    Also, I know you updated every driver you can think of but did you go to your motherboard manufacturer's website and update their drivers for your particular mobo? Do this second.
  16. joshvito

    joshvito TS Rookie Posts: 18

    drive tested ok

    I have completed all but one of the available tests for seagate tools.
    it passed all tests, but a bsod occurred during the last test, so i restarted it.
    Here are the results from the log file.
    Is this what you meant by a full diagnostic?
    I used the chipset drivers from the website for the mobo. I will reinstall these next.
    which ones were you referring to?
    do you think it could have to do with using my usb flash drive as a readybooster?
    lastly, i noticed that after the last bsod (the minidump is attached), my workspace and window positions all reverted to their defaults. Whereas, usually the programs open where i last closed them.
    thanks for all your help.!!
  17. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    0x124 error and USBPORT.sys is cited as the problem. This driver is a core Windows driver.

    When you go to Biostar's website make sure you download the drivers for your model motherboard.

    By the way, how long did you run memtest from before?
  18. joshvito

    joshvito TS Rookie Posts: 18

    i ran both memory tests until they completed.
    the bios one ran for like 2 hours, and the second windows one was quicker, bout 45mins.

    also, the last drive test passed.
  19. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Memtest has to run for at least 7 Passes (unless you did this and that is what you meant by being completed); 8 individual tests per Pass. I once ran it and didn't receive any errors until it was halfway through the 5th Pass.

    It looks like your harddrive is fine.
  20. joshvito

    joshvito TS Rookie Posts: 18

    it told me it was complete. hit esc to restart?
  21. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    I don't know! :eek: I've never had to do it. Try it and see. The worse that could happen is that you have to reboot and begin again. Let it run overnight and check it in the morning. It quite safe to do this. I once ran it for 24 hours straight. We're talking memtest, right?
  22. joshvito

    joshvito TS Rookie Posts: 18

    ran the memtest all night, no errors.
    i had it on advanced (all 9 tests), and i ran it infinite times.
    no errors. it completed 6 rounds of 9 tests.
    i sent an email to the mothorboard manufacturer's support, asking about processor compatability.
  23. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Ugh, I hate this error. As I said, it is a pain to deciper. You mentioned going to Biostar and updating the chipset drivers, etc. for your motherboard. Did you try that yet?
  24. joshvito

    joshvito TS Rookie Posts: 18

    those are the drivers i have installed now.
    i'm going to reinstall all again today.
    is it weird that there is no driver listed for usb with vista 64?
    also, is there a way to manually update the drivers instead of running the installer?
    if i could manually uninstall and manually reinstall, then i could be confident that the drivers actually installed. or can i check the driver owner and number somewhere?
    In the device manager, I have no idea where the chipset drivers are?!
    ps. I HATE this error too!
  25. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    A lot of people are experiencing issues with USB and 64x. When you contact Biostar get as specific and as brief as you can, but in particular mention your error code and the USB thing.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...