C-Media 6501 and 5.1 Surround not working

By HaLo2FrEeEk ยท 4 replies
Mar 25, 2009
  1. I have a Logitech x5400 5.1 surround system. It plugs in through 3 standard 3.5mm stereo plugs.

    My motherboard is an ASUS M2N-E SLI, and it has plugs for full 7.1 support.

    The audio chipset I'm using is integrated into the motherboard, it's a C-Media 6501 and my driver version is I'm using the version of the configuration panel. IT also says my Audio Controller is "Standard OpenHCD SB Host Controller."

    The problem I'm having is I can't set up surround sound. I recently reinstalled Vista Ultimate x64 (on my old installation I had this working,) and since then it hasn't wanted to work. Before I think I had my audio output set to 7.1 for some reason, but it worked through all 5 speakers and the sub and sounded great. Thing is I can't remember if I set it to 7.1 in the C-Media configuration panel or the default Windows sound configuration, I've tried both though and neither want to work.

    Please, if someone could help me get this working I'd be very thankful. If you need more information just let me know.
  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    How about uninstalling the device in Device Manager, restart Windows, let Windows reinstall the driver and see if that helps.

    BTW, you say, "The graphics chipset I'm using....." I think you mean audio.
  3. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    Windows won't automatically install the driver, AFAIK, I accidentally removed the driver when I was trying to get my line-in port working and restarted and the c-media entry in playback devices was completely gone. Both of them, because there is also a digital coaxial output as well.

    And yes, I meant audio chipset, my bad.
  4. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    So the driver isn't installed and you are not able to install it for some reason? If you accidentally deleted the driver but did not uninstall it, there might be parts of it left that are not letting you reinstall it. What about using Ccleaner to get rid of any registry entries and whatever else it can and see if that allows you to install the driver.
  5. HaLo2FrEeEk

    HaLo2FrEeEk TS Enthusiast Topic Starter Posts: 164

    I uninstalled the driver and restarted and it didn't help my problem with my line in, so I reinstalled it from the download I got from the ASUS website for my motherboard. It's installed right now, I just can't set it to output 5.1 surround.

    I've tried everything I can think of and it's really pissing me off. Part of the reason I bought this particular surroud sound system was because my computer has these 7.1 outputs and I spend a lot of time listening to music and watching movies on my computer, I wanted the real thing. I've tried every setting in the C-Media config panel. When I change to 7.1 surround in the Windows sound config it changes the C-Media to 8 channel input and no sound comes out, when I change to 7.1 output in the C-Media config, no sound comes out. When I change to 5.1 either way, it only uses the stereo speakers, from left and right. This is rediculous!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...