Cannot delete folder on desktop

By olefarte ยท 9 replies
Nov 26, 2004
  1. I have Diskeeper Home Edition and wanted to try out the Pro version, so I started a download of a trial version from Executive Software, after they sent me a link. It didn't finish downloading. So I tried again, and it said the link had expired. They sent me another mail saying if the download was unsuccesful to "click this link". I did. It didn't finish downloadiing either. Now I have two folders sittiing on my desktop that I cannot get rid of, that are empty. But, I did get it downloaded from another site, and installed.

    When I try to delete these two folders, I get an error message saying the folder is in use by another program or person. I have totally uninstalled Diskeeper, run a virus scan and rebooted numerous times including in safe mode, and, deleted the entire Diskeeper folder from Program files. Still can't delete them. I don't see anything in Task Manager that is relating to them, but I shut most every thing down anyway just to see. Still no go.

    How can I get rid of these folders, I don't want to look at them on my desktop from now on.
  2. Jay_kuby

    Jay_kuby TS Rookie

    Switch off your computer and turn it on again that might work.

    jay :D
  3. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Mmm strange one this!!

    Have you had a look in msconfig at both startup and services?

    I`m not saying this will help but it might.

    Regards Howard :confused:
  4. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Thanks for the replies guys. Jay_kuby, as I said, I rebooted several times. But anyway, after everything I tried, the answer was very simple, I just created a new file on the desktop and dragged the two files into it, and then deleted the new file. Simple as that. I still don't know why the two files wouldn't delete by themselves, but anyway, the problem is fixed.

    Again, thanks guys.
  5. Jay_kuby

    Jay_kuby TS Rookie

    im glad you sorted it out, good one.

    jay :grinthumb
  6. b2bomber81

    b2bomber81 TS Rookie Posts: 52

    The likely reason that this worked, is that a program was running in the background that was accessing these folders. Once you moved them, the program "lost contact" with the folders and stopped using them. Then again, it seems that it should have given you the same error when you tried to move them also - so who knows!

    But I've had this problem too. But it's usually with photos though, and usually it's when their in the Recycle Bin. Kind of strange! :haha:
  7. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Agreed, but I couldn't find it, and I sure tried, plus you would think a reboot would solve the problem. As I said, I was downloading Diskeeper and the download aborted. The funny part is, I thought that maybe if I downloaded it again, it would finish and then I could delete it. But no, the download stopped again, then I had two icons to deal with instead of one.

    Anyway, they are gone. Just one of those unexplained happenings I guess.
  8. elcu

    elcu TS Rookie

    Troublesome files can be deleted by booting into safe mode.
  9. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    As this problem is fixed I guess I don't really need to say this, but as I said in my first post, I did try that also and it didn't work.

    Anyway, thanks for all your replys guys, I usually need all the help I can get.
  10. blaacksheep

    blaacksheep TS Rookie Posts: 70


    I've had good results removing those type of files from a command window....

    Glad you solved your ploblem olefartre
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...