Cannot get past BIOS startup screen

By dknight06 ยท 4 replies
Nov 25, 2008
  1. I apologize in advance at how long this is, but at this point I'm kind of desperate for advice since my PC has been down for quite a while.


    Intel Celeron D 356 3.33GHZ

    MSI P6NGM-FD LGA 775 NVIDIA GeForce 7100 Micro ATX Intel Motherboard

    2x1gb DDR2 800 SDRAM

    Radeon 4850


    Hard Disk(s)
    Seagate 250gb 7200 RPM SATA

    Power Supply
    RAIDMAX HYBRID 2 RX-630SS 630W ATX12V V2.2/ EPS12V SLI Ready CrossFire Ready Modular Modular LED Power Supply

    MASSCOOL FD08025B1M3/4 80mm Case Fan

    Alright, here goes. Earlier in the month I got a new motherboard that I had to RMA, I wasn't sure where to put all the parts so most went into boxes but my CPU was stored in a zip-loc bag since I had no clue what to do with it.

    I've gotten the new motherboard and set it up (note: I did not reinstall any drivers or repair Windows since it was the same motherboard type and I already had drivers installed). The first time it booted up just fine and everything was working except for the fact that a brand new Radeon 4850 was getting no more than 25fps in games where it should be significantly higher. In addition when playing games, the system would freeze for a few seconds and then return to normal, also switching applications would take forever which is not an issue I've had with this RAM and Processor before.

    I decided to restart the machine to see if that would resolve anything. At that point it would not get past the BIOS screen. Once in a while if I hit <del> quick enough it would try to go to setup but would just hang at "USB Legacy Support is not enabled". The next day after work, I tried it again, using my old video card and it worked, then switched in the new card and it also worked. I took the time to run Memtest on all of my RAM, try each stick seperately, verified all fans worked and rebooted several times with no issue. The last reboot of the night after I put the case back together and stood it up brought back the same exact issue.

    I went to take the processor heatsink off and it was extremely hot to the touch despite the fact that all fans were working properly, I thought the issue may have been overheating, but tried it again this morning after leaving it off all night and I still cannot get past the BIOS startup screen without being able to get to BIOS setup. Help! :confused:
  2. EXCellR8

    EXCellR8 The Conservative Posts: 1,835

    Almost sounds like the romsip data has become corrupted or something. Have you tried clearing the CMOS by removing the battery? You should also make sure that your motherboard BIOS is the latest version and check the release notes for any added CPU compatibility enhancements. I had a motherboard and CPU do all kinds of weird stuff when the BIOS version didn't support the processor. The board is an RMA replacement so it could have an old BIOS version installed. You should consider flashing to the latest build if that's the case.

    Also, after clearing your CMOS, make sure that everything in BIOS is set up properly. Pay particular attention to voltages, clock speeds, and memory timings. All of these things should be set manually and not left on Auto.
  3. dknight06

    dknight06 TS Rookie Topic Starter

    Thank you, I will try to reset my CMOS and see if I can get to BIOS options to manually set everything once I get home.
  4. dknight06

    dknight06 TS Rookie Topic Starter

    Thanks again. The clear of the CMOS got me through, and I set everything in BIOS now to keep an eye on overheating and I should be good for now.
  5. anshuman

    anshuman TS Rookie

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...