Can't get into BIOS setup utility

By O negative ยท 30 replies
Mar 3, 2012
Post New Reply
  1. I am working on a Toshiba Satellite with Insyde H2O bios. It says to use F2 for setup and F12 for boot manager.

    I've tried all the function keys, as well as esc and del and they only get me to Windows Boot Manager. (This includes F2.)

    The machine has Vista that stops loading when it gets to the network drivers. Could a corrupt BIOS be the cause? If I download a new BIOS can I install it from the command prompt?

    If the BIOS is still OK are there other ways to get into setup?

    (Meanwhile F2 works just fine on my Dell Lattitude)
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try using a USB keyboard...

    "Could a corrupt BIOS be the cause?"

    I don't think you would get that far in the boot process if the bios were corrupt
  3. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    There might be a function key on/off button that you would have to press before F2 would work. There is on mine, just a thought.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Yes, the "Fn" key... if needed
  5. O negative

    O negative TS Rookie Topic Starter Posts: 19

    I held the Fn key and briefly pressed the F2 key. Now it is stalled on the Toshiba screen. This also happens when I just hold down the F2 key. Quite often the machine will just turn off after a few minutes being stalled at the Toshiba screen.

    Curiously, when I hold down the F1, esc, del, or other function keys the keyboard will load up and complain (long beep). When I hold down the F2 key it never does that, but if I instead wait a few seconds and just tap the F2 key it goes into the boot manager.

    If I do nothing it tries to boot Vista.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Do you have a Windows boot CD/DVD handy? If so, try booting the laptop with that...
  7. O negative

    O negative TS Rookie Topic Starter Posts: 19

    The machine did time out and shut down from the Toshiba screen.

    I do get a response from the F2 key, but not the correct one. Is there a keyboard check program that I can run from command prompt? Even though the key isn't dead maybe it is locked similar to caps lock so that it is giving the wrong signal.

    Bottom line is I need to change the boot sequence in BIOS. Firing up an OS is the next step AFTER that.

    I have a bootable USB that I confirmed is working on my Dell. (I had to change the boot order in my Dell BIOS to use it.) I need to get into the Toshiba BIOS somehow. Right now there are serious communication problems with this machine. The logical one to fix first is the communication with the BIOS.

    I've noticed that the most common BIOS problem posted to the web is a password problem.

    When a password has been set the setup utility screen will not appear until you type the correct password. I had presumed that a password prompt would appear if that was the case. I have never seen a password prompt (or username prompt) before Windows loads. Is it possible that there is no prompt and I am supposed to type it blind while the Toshiba screen is frozen?
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "Is it possible that there is no prompt and I am supposed to type it blind while the Toshiba screen is frozen?"...

    This sounds like pure nonsense! So what about booting with a bootable CD?
  9. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    Toshiba Satellite systems need only F2; no need for Fn
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I know jobeard,
    what about trying a USB keyboard?
  11. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    not absolutely sure, as KB+Mouse are directly accessed by the BIOS and USB devices come later.
    However, on my laptop, I have used a USB and/or Bluetooth mouse so would expect the KB to work too. But as we know, there's always the OMG surprise lerking in the background :)
  12. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I have been surprised that many laptops, both old and new will access bios with a USB keyboard... I have a Dell small-profile USB keyboard that works well with laptops
  13. O negative

    O negative TS Rookie Topic Starter Posts: 19

    Update: I've ruled out a keyboard problem. "F2" is a DOS command. When you hit F2 at the command prompt a window appears that asks "Enter char to copy to:" If your previous DOS command was "cd windows\system32" and you hit F2 and then "3" you will get "cd windows\system".

    The Toshiba performs this exactly like my Dell.

    That's settled. Now I can focus totally on the BIOS's hearing problem. I don't need to consider attaching other keyboards. (Or irrelevant OS stuff!)

  14. m4D

    m4D TS Rookie

    1) yeah, there can be no promt for passwd during entering, i've seen just blank screens with even no blinking cursor.
    2a) look for this particular nb user manual, bios section, if there are any other keys, that allow entering setup. the thing, that f2 works on one 'toshiba' doesn't mean it'll work on another.
    2b) it can be so, that bios was reflashed with another (or even custom) version, so std keys doesn't work anymore. try to find out which bios is flashed right now (ami, award, etc), that google for std-keys lists.
  15. O negative

    O negative TS Rookie Topic Starter Posts: 19

    I took the thing to Geek Squad and told them I was having trouble getting into the BIOS and asked what would be the charge for getting into it. She said no charge so I said go ahead. She powered up and started tapping the F2 key and got the same result I get when I hit the F2 key early: a frozen Toshiba screen. She said it was a bad CMOS battery. I asked, "Are you sure? I can run a bunch of things." She was confident. So I thanked her and took it home.

    I was still skeptical. The thing was keeping accurate time, could use the DVD drive and USB removable drives. So I took it apart and tested the battery (which is soldered in a Toshiba) and got 3.3V--plenty of volts.

    The Satellite manual doesn't even mention F2 for setting up/viewing the BIOS. The manual instructs the user to use Windows to do it. This is getting fun!
  16. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I'm afraid that the bios chip may be corrupt while the RTC (real-time clock) chip is functioning. These chips are on one IC
  17. CAMusing

    CAMusing TS Enthusiast Posts: 179

  18. O negative

    O negative TS Rookie Topic Starter Posts: 19

    I suddenly have more options:

    I tried to get at the BIOS using BootPriority.exe, but it said it needed Toshiba standard modules so I downloaded the Toshiba value added package for this particular model, copied it to the c:\ root and ran the install. It failed, supposedly because there was not enough room on the X:\ drive. There is only about 30Mb available there.

    So I tried something else. I yanked the hard drive and powered up. It tried to find an Ethernet cable twice then gave up and asked for a boot disk. Then I shut it down, stuck in a bootable USB stick and powered it back up. It tried twice to connect to a non-existent network again and then, voila!, Debian LDXE (Linux) desktop comes up. Sweeyt!

    Now maybe I can find an open-source freeware BIOS viewer/editor so I can change the boot order and see what else is going on with the BIOS settings. Anyone know of such an "app"?

    BTW: Thanks CAMusing for the very informative link. I haven't gotten that method (esc) to work yet, but it could lead to something.
  19. O negative

    O negative TS Rookie Topic Starter Posts: 19

    God, this Tosheeba just won't let me into her pants!!

    I tried before to install the value added package so I could run Bootpriority.exe and it said that the X:\ drive was too full. So, instead, I downloaded tsetup.exe, copied it to the C:\ root and when I try to run it from C:\ it says,"The system cannot find the file C:\tsetup.exe." I tried running it from the G:\ (USB) drive and it says the same thing except "G" instead of "C".

    It can find it when I delete it or copy it and it can find it when I open it with Notepad so obviously this is the wrong error code. This error code must be the default if there is no closer match in the list. (When I run it on my Dell it warns of an illegal operation and asks if I want to ignore which is what I would expect when run on the wrong machine. The Toshiba doesn't even try.)

    My guess is there is a security issue here. Toshiba says on some notepads that they only allow access to the BIOS via Windows, probably because there is a login for Vista. You can get to the command prompt without a password so maybe its not letting me into the BIOS from C:\ because of that. (Logging in is actually optional, but I get the same result if I log in: it can't "find" tsetup.)
  20. Luis Ramirez

    Luis Ramirez TS Rookie

    I have a similar problem. Did you ever solve it?
  21. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    So Luis, do you have a Toshiba laptop? Have you tried the things mentioned here?
  22. O negative

    O negative TS Rookie Topic Starter Posts: 19

    Sorry, no. I returned the machine to its owner. I haven't talked to him in months so I don't know what he did with it.

    Happily, I did fix my Dell machine, but it didn't have any BIOS issue, just a corrupt OS.
  23. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Okay Luis, thanks for the reply...:)
  24. apporwa

    apporwa TS Rookie

    I have the same problem with addition that my toshiba satellite shows HDD light off. HELP!!!
  25. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If the HDD light remains off at all times, it would be wise to check the hard drive for problems

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...