1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't get to BIOS/UEFI after upgrading CPU

By JohnFLite ยท 8 replies
Jan 19, 2017
Post New Reply
  1. I have a Biostar TZ77B mobo with an LGA 1155 socket, and I upgraded my ivy bridge i3-3220 to an i7-3770.

    Afterwards, I turn on my computer and after the Biostar T-series splash screen, I get an American Megatrends screen that tells me that a new CPU has been detected, and I need to reset the motherboard to its defaults. Except I can't get into the bios/uefi using the prescribed <delete> keypress no matter how many times I try it.

    Now, it must be said that the computer goes from this American Megatrends screen into Windows 10 and seems to work fine. It even registers the new cpu. Still, I try and try to reset to get into the bios/uefi to reset the mobo to the defaults.

    Well, after getting some advice, I pull out the CMOS battery, which I'm told will reset the mobo defaults. After waiting a bit, I put it back in, it clicks firmly into place, BUT I'm still getting the American Megatrends screen telling that I need to reset to the mobo's defaults--which pulling the batter was supposed to accomplish--AND now I get a "cmos fail" message. Ugh.

    I have to say, the computer still seems to work fine, it boots, loads the OS, etc., despite the problems.

    What can I do? I'm at a loss. Any help would be greatly appreciated.
     
  2. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +253

  3. JohnFLite

    JohnFLite TS Rookie Topic Starter

  4. JohnFLite

    JohnFLite TS Rookie Topic Starter

    Update: I do know why I can't get into uefi though the OS. System Information that my BIOS Mode is set to "legacy." My motherboard does have uefi, but quick research seems to indicate that it will take a reinstallation of my OS to change my BIOS Mode from "legacy" to "uefi." I'll admit, I'm reluctant to do that, since my computer does seem to be functioning properly. On the other hand, I would like to prevent any future problems that might arise from the fact that my mobo bios is not set to my new CPU.

    Argh. Anyone have any ideas?
     
  5. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +253

    When you took out the motherboard battery did you wait 20-30 mins before putting it back?
    Have you tried tapping other keys when trying to enter the BIOS. The required key can vary between different models from the same manufacturer?
    How about putting back the original cpu and then seeing if you have any luck resetting the BIOS to default settings? Alternatively, you could see if there is a BIOS update for the motherboard. Don't flash the BIOS unless you know beforehand that it will sort this problem. Often it's hard to find out why there is an update available so it's not something to be done lightly. If it goes wrong you are in a serious situation.
     
  6. JohnFLite

    JohnFLite TS Rookie Topic Starter

    Thanks for your help. My computer is keeping the date and time correct even when not hooked up to the internet, so the battery is clearly working. Good to know the "cmos fail" isn't about that. There are updates available, but I think my first move is to hook up this old keyboard I found that has a ps2 connection and see if the keypress route to the BIOS screen works with it. If not, It's on to installing the updates. Wish me luck!
     
  7. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +253

    The CMOS settings are often stored in some sort of flash memory so just taking out the motherboard battery and replacing it soon afterwards may not do anything. That's why I suggested removing the battery for longer. Holding in the power button for say a minute after the battery and all power have been removed might help too, but that's just a guess.

    Your motherboard has a switch or jumper to clear the BIOS settings. (See page 20) You have to be very careful that you don't rush into this and damage the motherboard though. Take full static protection precautions.

    https://www.manualslib.com/manual/482141/Biostar-Tz77b.html?page=20#manual

    http://www.howtogeek.com/131623/how-to-clear-your-computers-cmos-to-reset-bios-settings/

    Trying with the ps2 keyboard is a very good idea.
     
    Last edited: Jan 21, 2017
  8. JohnFLite

    JohnFLite TS Rookie Topic Starter

    The ps2 keyboard worked, and it is all resolved EXCEPT I have learned in the process that there are BIOS updates available to me. I will have to decide whether to install them or leave well enough alone. Anyway, thanks for your help!
     
  9. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +253

    Bios updates are something to keep well away from. If everything is working fine you would be taking a big risk for no gain. If it isn't broken don't try to fix it.
     
    mailpup likes this.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...