DMA Problems HELP!!

By Matt-man
Jun 3, 2005
  1. I have a rig that is now 3 months old but i am still to resolve my dvd playback issues i've had from the start.

    I have an AMD 64 3000+, 1024gb ram, ASUS K8N socket 754 MOBO, Liteon 1653S DVD-RW. When i try to playbac a DVD using power DVD 5.0 the film freezes and skips, and i cannot use the shuttle function or the progress bar to skip through the film. After several seconds of glitching if i check device manager the channel reverts back to PIO only despite having been on use DMA where available previously, and there is a warning box that says the settings have been downgraded.

    I have tried different IDE cables and have also tried it both connected to the primary ide slot (as slave) and as master on secondary ide slot but the problem continues.

    I do not get these problems when using Windows media player.

    Please can someone shed some light on this as i believe i have tried all obvious possibilities.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...