"Error loading OS" Please help!

By mburnz ยท 14 replies
Jan 19, 2008
  1. Today I decided to upgrade my pc and went out and bought a new mobo (asus p5k) with a new CPU (Intel Q6600). I decided to keep my old WD 120 gb hd and swap it over. Problem is, I can't get past the bios screen. Atm I have my hd and CD-Rom on the same IDE cable (due to one IDE port on the mobo). I have set the boot order with the cd rom first and HD second but to no avail. Either I get a Error Loading OS (When HD is first) OR my pc hangs with a blank screen and a blinking cursor when I set it to CD-ROM first, no matter what CD I have in the drive. Please help me before I throw the damn thing out the window!!! TIA!
  2. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    You need your Windows CD to boot or you need to format the drive because all of the old drivers are installed on the harddrive

    If you can't boot into recovery console using XP or Vista CD:

    What version BIOS came on it? its common that they send an old version

    Have you tried resetting CMOS? Will set everything back to default

    What size Power supply do you have? if this was a prebuilt machine that you are upgrading sometimes they put just enough power supply to cover what's in it
  3. mburnz

    mburnz TS Rookie Topic Starter

    I will get the BIOS # ASAP, I know its 1. something from July of 07. The power supply I am running is the standard one from a case that I picked up the same day. The guy threw the case in for me and said it would run it. It has the typical settings 115-230 I believe. Could it be that there is simply not enough juice to get it going?? I really hope so.
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    mburnz - the wattage of the PSU is important - check and make sure it is at least 350 watts.
    boot errors - are the drives SATA?
  5. mburnz

    mburnz TS Rookie Topic Starter

    Yeah I know that my PSU is not 350 as for the HD, its not SATA
  6. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Do you have a Windows install CD?

    It's not considered "good practice" to put the hard drive on the same cable as the CDrom. You should still be able to boot though. Just throwing that out there.
  7. mburnz

    mburnz TS Rookie Topic Starter

    Sorry, the VOLTAGE is 230 but the PSU says capacity of 375. I have them chained only because the mobo has one ide cable/input.
  8. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Do you have a windows install CD?
  9. dgower2

    dgower2 TS Maniac Posts: 238

    HAL Anyone?

    mburnz (and everyone else),

    You can't simply swap out a mobo, plug in a HDD from another computer, and expect it to boot/function correctly. There are mobo specific drivers and files loaded on the old hard drive that are not compatable with the new motherboard. See http://www.answers.com/topic/hardware-abstraction-layer for information about the HAL.

    It's universally highly recomended to do a clean OS install when changing motherboards. It's not impossible to make it work, but the process is usually complex. I think there's a guide in here regarding changing your mobo without doing a clean install.

    My advice is to upgrade your HDD to a fast SATA model (you might as well since you've upgraded the mobo and CPU), do a clean OS install on your new SATA, then plug the IDE drive in and you'll be able to access all the files on it.

    Hope this helps.
  10. pdyckman@comcas

    pdyckman@comcas TS Rookie Posts: 527

    I agree with the above post. You need to reformat your HDD with your OS to suit your new BIOS on the new mobo.
  11. mburnz

    mburnz TS Rookie Topic Starter

    what if I hooked up the HD to my old pc and did format C: via windows boot/start up disk upon start up? Will that erase any old info and allow me to transfer the hd?
  12. mburnz

    mburnz TS Rookie Topic Starter

    Update: I have, atm, just my cd-rom hooked up via ide cable and still getting the blank screen w cursor. Maybe that helps with anything.
  13. mburnz

    mburnz TS Rookie Topic Starter

    OH MY F'N ..... So I was able to fix the problem. Turns out it was a bad HDD cable that the ASUS mobo CAME WITH! I switched to an old cable and now its firing up!!!! ARGH the small things that can get ya. Thanks for all your help.
  14. captaincranky

    captaincranky TechSpot Addict Posts: 13,023   +2,556

    And I Agree With You, But......... or (Title 2) Don't try This at Home Kids.....

    You may appreciate this story (or not). I ruined an Intel G965WHMK in a BIOS updating mishap. Meanwhile,I had ordered a closeout Foxconn 945PAA7 from Newegg. Then:
    I plugged all my stuff into the Foxconn and turned it on.
    Windows booted telling me "Express BIOS update failed". (I knew that).
    Windows then said, "the hardware in your computer has changed significantly", (I knew that too) and gave me 3 days to reactivate it.
    Windows then offered to install all the drivers for the new board. I said sure, why not.
    As near as I can tell, Windows is functioning perfectly. I never touched the repair console.

    So, I called M$ on the phone and they reactivated my >> OEM<< copy of MCE2005 on a >>DIFFERENT MOTHERBOARD << without a problem.

    I found out, (too late) that the only program that didn't function correctly was the Zone Alarm Firewall, (free version). It was running with no GUI, preventing me from reactivating Windows online, updating Avast AV, and an updated Firefox from accessing the web. I uninstalled it and all my problems went away.

    A strange story that flies in the face of conventional wisdom, and most peoples experiences. Strange but true.

    I believe that because both boards were Intel chipsets, configured in pretty much the same way, may have been the only reason this worked out!

    HAL, wasn't he the computer in "2001 A Space Oddessy"?
  15. dgower2

    dgower2 TS Maniac Posts: 238

    Thanks for the reply with the solution mburnz!

    Thanks captaincranky for sharing your experience. It's so important that we/I remember that each scenario is unique and just because it worked/didn't work with scenario A, doesn't mean it will work/not work with scenario B. The power of public forums and consensus shown.

    This place is great!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...