External Hard drive wont show in 'My Computer"

By Qu3ntin ยท 11 replies
Mar 16, 2006
  1. Okay so,

    i bought a maxtor 160 gb hard drive in a comstar case. the hd functioned good for about a month then a little piece in the comstar case fell off and messed it all up, so i extracted the hd from the case and bought an IDE to USB connecter with it's own power source. now the hard drive 'was' filled with around 60 gigs of data and just a couple days ago, it stopped showing up in My Computer. after reading a fairly extensive thread in this board about this problem. i read that the problem might be that i didnt format/partition my hd. soooo, being quick to want to fix the problem, i went into my device manager. i unmade the drive a partition and attempted the partition wizard. i tried this, assigned it a letter that wasnt mapped. but it says that the device is not enabled, it then prompts me to restart my computer to fix this problem. This does not work. i restart and try to fix it but it doesnt. it detects that i have a maxtor hd in my 'safely remove hardware' wizard and it tells me its working properly... but it just doesnt show up. ive tried just about everything i can, i need to come to you guys for help now, any ideas?
  2. Qu3ntin

    Qu3ntin TS Rookie Topic Starter Posts: 18


    Bumpity bump bump
  3. Pablo

    Pablo TS Rookie Posts: 16

    first of all i think you're a little impatient

    second, i would suspect that the hd is dead...i have one that did the same thing...worked for a few years then all the sudden it wouldnt work. The bios would say its there, but when windows came up it dissappeared. I too have an ide-to-usb cable and same thing there. The computer would see the drive but it wouldnt show up in my compuer.
  4. Qu3ntin

    Qu3ntin TS Rookie Topic Starter Posts: 18

    thanks for the insight but that truely sucks. i really really hope its not dead. ive only had it since late december. any other suggestions before i call maxtor and get a new one :(
  5. Pablo

    Pablo TS Rookie Posts: 16

    personally i've had problems with maxtors....they are cheap but they fail on me too quick

    i have a 200 gb maxtor that i had bought...it hasnt failed, but i cant use it as a master any more...which kind of baffled me...it works even as a master, but windows wont boot from it

    on a side note seagate has bought out maxtor so things might be a little different as far as support and possibly even changes to the product itself
  6. Qu3ntin

    Qu3ntin TS Rookie Topic Starter Posts: 18

    yea, i called Maxtor when it initally crashed and they wanted to run tests on it, but i cant from my laptop, id have to hook it up to my PC and im not sure if im allowed to do that right now because of the living accomodations im in. but i will find out 2morrow and see if they can help me. its just such a freaking hassle dealing with them
  7. Qu3ntin

    Qu3ntin TS Rookie Topic Starter Posts: 18

    bump? anyone have any other possible ideas?
  8. nocommente

    nocommente TS Rookie

    Here is how I solved a similar problem.

    The goal: Retrieve data from an old hard drive. I mounted it in a USB external hard drive kit.

    The problem: The old drive is drive C. The current drive on my computer is C. There is a conflict and the old drive can't be accessed.

    The solution:

    1. I created a BartPE recovery disk. Don't worry, this is easy! Just go to here and follow the directions:


    2. Restart the computer with the BartPE disk. I had the USB drive plugged in and turned on before I restarted, to make sure it would be recognized.

    3. Select menu option: Go - System - Storage - Diskpart

    4. At diskpart prompt type: list volume

    5. Make note of volume number of the old drive. (It's the one without a drive letter!)

    6. At diskpart prompt type: select volume n
    n is the number you noted above. You have now selected the old hard drive!

    7. Type assign letter = L
    Now your old hard drive is drive L. THIS IS ONLY TEMPORARY.

    8. Select menu option: Go - Programs - A43 File management utility.

    9. Click on drive L. You should now see everything on your old hard drive. Select anything you want to backup, and click on: Edit - Copy to folder.

    You can now copy from your old hard drive. If your old drive has bad sectors, this will cause it to hang. I was forced to turn the computer off and start over every time this happened, but luckily none of the files it hung on were important.

    I hope this helps someone!
  9. Qu3ntin

    Qu3ntin TS Rookie Topic Starter Posts: 18

    well i attemtped to format it so im pretty sure that theres no data left on it... thanks though, im sure the post will help someone. i was more looking at getting the harddrive fixed. i cant seem to comprehend why it would be broken. if the computer still knows its a maxtor hard drive connected through usb... why wouldnt it be showing up?

    also the it functioned fine for a little while... and the letters of the drive were not conflicting in anyway. then it just stopped working one day. i didnt shake, move or rattle the hard drive. no power outages or lightning strikes. i just dont get it
  10. Qu3ntin

    Qu3ntin TS Rookie Topic Starter Posts: 18

    Didnt work

    Okay i attempted the BartPE Recovery disk and i was faily optimistic as at one point it showed that the hard drive was there, but once again it just didnt have a letter. so i successfully assigned it to the letter 'L' and then went into the A43 File management and i was so happy to see that the "local disk L" was there but once i clicked on it what do i find... that it says there is 0.0 kb taken up and 0.0 kbs were avalible. but it detects that the maxtor hd is there... and it shows up in the volume. but i just cant freaking access it for some god damn reason. am i better off just calling maxtor and getting the freaking thing replaced?
  11. nocommente

    nocommente TS Rookie

    It sounds like your drive might be broken. If it worked one day, then stopped working, that's suspicious.

    Is it still under warranty? If your data is gone and it's under warranty, I would say get it replaced.
  12. ubermensch

    ubermensch TS Rookie

    I don't normally join forums to comment on an 8 month old thread, but I had this exact same problem. After a week of fretting about it, taking the HD to friends who I thought could help, and searching teh interwebs, I finally came across this answer. nocommente, you probably won't see this (you haven't logged in in a while), but this was the exact advice that saved me. BartPE wasn't as easy as you made it seem (I had to use Autostream to make another disc (couldn't use my old WinXP disc alone), I had to download SP2 - that's a pretty hefty file, and then, after I burned my BartPE disc, I found out that I had to turn on a plugin that's turned off by defaut), but, after 6 hours of messing around, I was finally able to recover everything I wanted.

    If I was a female, I'd want to have your child. If you ARE a female, PM me.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...