External HDD not recognized

By rmdl51 ยท 4 replies
Mar 24, 2011
Post New Reply
  1. Hello, I have this problem: I recently bought an external enclosure that is USB powered I put in my HDD and when I plug it in on my computer it does nothing, the led just blinks once and that's it. I have checked on device manager disk management and nothing there.

    I know both the enclosure and the HDD are good because I test them on my friends computer and the HDD is recognized right away within seconds, my friend suggest me to use the rear ports instead of the front ones but still same result, what could be causing my system don't see this device, everything else I plug in it works fine, I tried to disable usb legacy I disable another setting called EHCI but still same result.

    any suggestions? Thanks in advance for the help.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    1) Are you hearing the Windows device connect/disconnect ding-dong sound when you plug/unplug the USB cable? (can take up to 30 seconds sometimes i found)

    2) When you say you checked Device Management, did you look under USB Devices and check if a USB Mass Storage Device appears/disappears as you plug/unplug the cable?

    A few other things you might try
    > Make sure you have the latest chipset drivers installed
    > See [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]

    You might also try connecting a self-powered USB hub to your computer (one with its own AC adapter) and connecting the drive to the self-powered hub. Or tryr a USB Y power cable to draw power from 2 USB ports for the device (like this one from Apricorn)
  3. rmdl51

    rmdl51 TS Maniac Topic Starter Posts: 244

    I don't hear any ding-dongs but the first time I plug it in I did hear them, both the connecting and disconnecting and gave me a message "USB device has malfunctioning" but I tried and tried more usb ports and nothing.

    This enclosure have the option to use power from another USB port, but this is only for 1.1 devices and I don't want to use two usb ports to make it work, it should be only one and I would like to address what is the problem since on my friends computer works fine with just the usb cable, if I plug the power cable it recognizes the drive ok, but I'm sure this is not normal, somehow I believe my usb ports are underpowered, but how do i solve that issue?

    here is the enclosure I'm talking about:

    I did look onto devices and shows nothing there, no yellow marks, or appear or dissapear anything, on the disk management no unassinged drives are there.

    I also tried this device on my father's laptop and it is also not recognized unless I use the power cable
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yea. Definitely sounds like a power issue with USB ports and/or your external needing more power then spec.

    I don't know about how to increase power on your USB ports. You might try opening a new topic with that subject. I did once read of a motherboard that offered a jumper option on USB power, if it might also be true for your MB.

    Otherwise, try a self-powered external hub. You can also find hubs that provide 1000mA ports for these types of problems. I have a Targus ACH81 USB hub. it has 7 ports. And 2 of its ports provide "over-spec" 1000mA. Its other ports provide the USB spec 500mA
  5. rmdl51

    rmdl51 TS Maniac Topic Starter Posts: 244

    Ok, I'm going to try the USB hub, but still I hope this is not a MB defect and it's just a setting, I'm also going to take a look at the MB manual and the board itself to see if it has a jumper like the one you mentioned, Thank you very much for your input

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...