External USB hard drive not recognised on Windows after plugging it into a Mac

ddonog115

TS Rookie
Hi

Thanks for any help in advance..

I own a WD MyBook 4TB hard drive, which I've used on Windows for the past 2 years. I got a macbook last week and hooked the drive into it, some error message came up so I figured it wouldn't work, however when I went to plug it back into my windows machine I got the "USB device not recognised" message, the laptop is windows 8. I then tried it on my fathers windows xp computer and it seemed to think it was a completely new hard drive..

I've done some googling on it but I just wanted to ask here incase I went formatting it by mistake or anything..any advice/help would be greatly appreciated.

Thanks
 

jobeard

TS Ambassador
Sounds like you made some procedural error, allowing the Mac to alter the partition - - bad choice.

Using Windows tools, examine the partition on that drive - - should show up as
somelabel (dl): size HTFS
Healthy
(other qualifiers)​

Try Control Panel ->Admin Tools->Computer Mgmt->Disk Mgmt
 

ddonog115

TS Rookie
Sounds like you made some procedural error, allowing the Mac to alter the partition - - bad choice.

Using Windows tools, examine the partition on that drive - - should show up as
somelabel (dl): size HTFS
Healthy
(other qualifiers)​

Try Control Panel ->Admin Tools->Computer Mgmt->Disk Mgmt
thanks for your reply..

I checked in the win xp machine in disk management and its not showing up..I'll try the windows 8 one later to see..would formatting it and then running a file recovery program be any good..?
 

jobeard

TS Ambassador
Reformatting is a kiss-of-death if you want to recover any data.

move it back to Mac and extract what you want first.

THEN come back to Windows and reformat as NTFS
 

ddonog115

TS Rookie
The mac didn't seem to be recognising it either, I only plugged it in when an error message came up..I'll post what the message was when I get home in a few hours and try it again..
 

SNGX1275

TS Forces Special
Can you hear the drive spinning up at all when you plug it in (both power and usb)? If it never worked on the Mac, and then didn't work on subsequent Windows, I don't think the Mac did anything to it and it was just an extreme coincidence that the drive failed at that time. What does Disk Utility in OS X say?
 

ddonog115

TS Rookie
Can you hear the drive spinning up at all when you plug it in (both power and usb)? If it never worked on the Mac, and then didn't work on subsequent Windows, I don't think the Mac did anything to it and it was just an extreme coincidence that the drive failed at that time. What does Disk Utility in OS X say?
Yea I can hear it spinning up until the error message comes up on either platform..
The error message on the mac is:

NTFS-3G could not mount /dev/disk1s2
at /Volumes/Untitled because the following problem occurred:

dyld: Library not loaded: /usr/local/lib/libfuse.2.dylib
Referenced from: /usr/local/bin/ntfs-3g
Reason: image not found

In Disk utility it says this..I took a screenshot..

http://i59.tinypic.com/nmd9c2.png

Thanks
 

SNGX1275

TS Forces Special
Click down on disk1s1 and then in the bottom left of that window there should be a blue underlined (like a link) mount point. Click that and see what happens.
 

ddonog115

TS Rookie
I tried that and it wouldn't let me mount it..however I removed fuse and the ntfs-3g apps from the laptop and it can read the hard drive again! thanks for all the help
 

zhxys

TS Rookie
Hi ddonog115,
how did you manage to recover it? I have the same problem that after inserting to mac my usb disk doesn't recoginized in windows any more. and I don't want my data lost. Could you tell bit more detail how did you get it back?
 

SNGX1275

TS Forces Special
I thought it was a lazy question too jobeard, but on re-reading I think the guy hijacked this thread with a similar but different problem. He should have made his own thread. It isn't the Mac that can't read the disk, its Windows.
 
G

Guest

I m also facing the same trouble
and I also did not install NTFS 3g please help