flashdisk plugged in, doesn't show in My Computer, can be "managed".. where'd it go?

By sgtfoo
Apr 16, 2006
  1. It's a 512 MB waterproof flashdisk. It worked prior to my update to WINXP SP2.

    Now it doesn't show in My Computer when I plug it into the USB2 hub like I usually do (It worked with WINXP sp1, and works on all other winXP spx computers in my house)

    I think it has to do with too many drive letters being used. I've seen articles on MicrosoftKDB about flashdisk trouble, but no resolutions.

    I've got 2 HDDs on C: and D:, floppy on A:, CDROM on E:, virtual drive on R:, and my external USB2 DVD-RW is on G:

    Typically, the USB2 flashdisk shows up on H:. IT doesn't show up anymore, but I can catch it thru "My Computer > right click > Manage > Disk Management.

    There's nothing wrong with the hub AFAIK and the flshdisk is fine too.
  2. sgtfoo

    sgtfoo TS Rookie Topic Starter

    Yes, I've read the other flashdisk posts.... I'm just hoping there was a solution for this... as it seems to be a trouble with the WINXP drive assignment.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...