Floppy not responding

By Phill_w ยท 4 replies
Mar 4, 2004
  1. Hi, another first post!
    Had the problem of a floppy not being recognised by my PC, click on floppy icon and the PC just waited till it timed out on the request. Tried to access under MSDOS (I am running win95SE), still no joy.
    Tried new floppy and cable, still no joy.

    Was about to upgrade whole PC, now have new mobo, case, graphics card etc. Only original bits are the CD drives 2xCDRW and the hard disks.

    Still no floppy response.
    Tried removing floppy drivers using system properties and rebooting, still no response.

    Tried everything obvious in the bios.... nowt doing!

    Have reinstalled WIN95SE, guess what, nothing?

    Have i managed to cause a fault on my (new) floppy from the old mobo which has blown something on the new mobo?
    Do I need to reformat my HDD (difficult without floppy drive!)
    Do I need to spend the rest of my life transferring stuff via CDR - a right pain.

    Any help MUCH appreciated
  2. Steverz

    Steverz TS Rookie Posts: 51

    Go into your Device Manager (right-click My Computer and Select Properties, then look for Device Manager).
    In Device Manager click on "Floppy Disk Drives" and look at Properties. At the bottom look for "Device Usage". Now, look to see if the value in the box is enabled or disabled.

    Now, since you have been inside the case, check on these. Make certain that your cable is oriented properly. On floppies, the red strip on the cable doesn't always go toward power like on hard drives or CD's since the industry never standardized that for floppies. Make certain any power or signal cables are attached properly. Is your IDE slot on the Motherboard defective. Of course, recheck the drivers you have already been working with. Last, if you can find a "known good" floppy, try that, which will tell you if your own floppy or IDE slot is defective.

    That's about all I can think of at this point. Maybe others can add to this.
  3. Phill_w

    Phill_w TS Rookie Topic Starter

    Thanks for prompt reply Steverz,

    floppy is known to be good, device is enabled in device manager (thats what i meant earlier! soz!)

    Just seems weird that the IDE slot on two boards is stuffed (maybe its just my luck).

    Does anyone know of anything that could be on the HDD causing it........ yuk! Virus???.

    Any bits of freebie software that might check IDE slot? or floppy drive?

    Cheers anyway
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Also, if you have 3 connector floppy drive then it matters which connector you use for A: and B:

    Also enable "floppy drive seek" in BIOS to make BIOS actually look for the thing and complain if sth is wrong. Make sure you have not enabled Mode 3 in BIOS.

    You do not have to reformat! Ans since it doesn't work in DOS it is not a driver issue.

    Set your boot order to floppy first in BIOS and see what happens when it tries to boot from it. If nothing happens you have a hardware problem.

    One more thing to check. Make sure the wires in the mini power connector are arranged correctly. When I bought the case+PSU for my rig (cheap chinese crap) I fried a floppy drive and almost went nuts getting another to work before I realised the power connector had 12V and 5V wires mixed up.
  5. abc123atmyhouse

    abc123atmyhouse TS Rookie

    Having the same problem right now. AND THIS IS REALLY PISSING ME OFF
    good luck wit urs
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...