Game Controller (usb device) not working properly

By jdl26 ยท 21 replies
Feb 12, 2007
  1. I am in desperate need of some assistance. I am having issues with getting my game controller to work. I have already tried Logitech Wingman and a ps2 usb adapter device and neither work properly. In the properties it says both are working properly but when went to test either one of them they didn't respond at all. The led lighs on the controllers are lite but when trying to test or use in game they don't respond. I have used the Logitech for years without any problem and brother test the ps2 without any problem so I know it has to be computer related. I had reformate hard driver and install xp professional student edition and since then neither work.

    I have tried everything i can think of. I tried different usb slot, no luck. I have no problem with print, camera and other usb devices. If i do vibration test on the ps2 controller that works without any problem. I belive I have the most up to date driver. I installed the cd that came with it. It's a Sector 7 usb to ps2 adaptor. I ran Crap Cleaner and fixed all issues. When I tried to calibrate the ps2/usb adaptor manually it locks up and say that not responsding due to issue with rundll32.exe.

    Any suggestion guys, please give me some ideas. Txs a million!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What is you computer? Give us the specs... Is the system more than 2 years old?
  3. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    It's more than 2yrs
    amd duron 1ghz process
    388mb memory
    40gb hard drive

    Again, ever since I had a friend of mine reformat my harddrive and add xp professional student version it hasn't worked properly. The led lights work, so there power but when went to test it out i passed vibration test no problem, but when press buttons or move axis doesn't do anything. I then try to calibrate it and do as the screen says but it freezes up and say not responding due to rundll32.exe issue.
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    Take out any unnecesary USB devices including your controllers.

    go to device manager and scroll all the way down to the USB devices. Uninstall/remove all entry relating to USB Hubs and controllers. Reboot your PC and let windows reinstall the drivers for you.

    After it installs, it will probably ask you to reboot your PC to complete it. do so. Install the Logitech wingman software if not done so and then plug in your controller.

    If the above doesn't remedy it, find out your motherboard model and make and download the latest drivers for it available from its website.
  5. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    Thank you for the suggestions n3051m. I tried that but was still unsucessful so I am going to try and get the latest drivers. If you wouldn't mind could you post a link to the latest driver for my board. I am not sure where to find it. Thanks bro.

    my specs;
    Socket A processor Motherboard
    cup: AMD Athlon/Athlon XP/Duron (K7) Socket A Processor 1.0GHz
  6. N3051M

    N3051M TS Evangelist Posts: 2,115

    sorry.. the info you've supplied doesn't give me much clue on your motherboard model..

    Download the Everest Home program as linked in my games guide (in signature) and use that to help you find the drivers.
  7. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

  8. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    Another question I was pondering was would reinstalling Windows XP possibly correct the issue.
  9. N3051M

    N3051M TS Evangelist Posts: 2,115

    the drivers from that website, download the chipset drivers..

    currently your joystick is using window's generic set of drivers, see if you can download your specific one from here:,crid=270,categoryid=126

    OS reinstall would probably fix it if it was a software based fault, but not if its a hardware based fault (or driver). Try using your joystick on another PC to verify its working properly.
  10. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    I already installed that driver from logitech, I have a WingMan Rumblepad. Again the issue is with both controllers, logitech and ps2 (using a usb/ps2 adaptor). I know it's not the controller because worked for years prior and the ps2 controllers worked on my brother's pc.
  11. mailpup

    mailpup TS Special Forces Posts: 7,185   +469

    Could the adapter be the problem? That is, maybe there is something wrong with it.
  12. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    I just bought the adapter about 2 wks ago. This issue is really stumping me at this point. Both device worked at one point and now they both indicate power, led light is on, and vibrating features works, but the buttons and axis don't. They haven't work since a friend of mine did a reformat and installed a different window xp version.

    Thanks for the suggestions but at this point what else can a guy do?
  13. sw123

    sw123 TS Rookie Posts: 595

    Try your old OS? This is a weird and confusing problem

    So you say you are trying to get a PC joystick to work in a PS2, or a PS2 joystick in a PC?
  14. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    I have two controllers, a logitech wingman rumblepad and ps2 controller that can be used by usb adaptor, the vibrating function responds when testing in properties but not the buttons and axis.

    I just reinstalled xp and still no luck. Is it possible that I may have a file that is conflicting with the controller(s) working properly? Maybe in windows/system32/drivers... I also unistalled all things usb in device manager and let the plug and play reinstall everything automatically, but still no moss. suggestions, anyone?
  15. N3051M

    N3051M TS Evangelist Posts: 2,115

    hmm.. usually window's generic set of drivers are sufficient for the joysticks.. if you have the cd for them, see if you can find some info about any special installation process..

    But first, since you've said that one is brand new and the other old, if you can get your hands on another PC try to confirm if they are actually working and picking up there, since if its working on one and not on your's then there's some hardware or configuration problem with your PC and if it doesn't work on the test pc, then its most likely a dud or broken somehow..

    try different USB ports (on the back, front etc)?
  16. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    Thanks guys! I have tried different usb ports. It's really weird what happen was that my buddy reformatted my harddriver and installed xp prof student version, I installed the logitech profiler/driver that I was always able to use with the Wingman Rumble pad. I went to properties and attempted to test but no response, vibrating works but nothing else. So I went to Radio Shack and bought ps2 to usb/adaptor and got home. Installed driver and tried to test it and nothing, exact same issue with Logitech, there's power, led light's on, vibrates but no other repsonse. I have looked for updated driver for both but still no luck. I am running out of ideas. I know the files go to windows/system32/drivers... is it possible that files are conflicting it? I have regular usb ports, no usb2.0, but still had no problem in the past. I even turned off window firewall but still no chance. What else can be attempted?
  17. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    hey all! I am down home for the weekend at my parents house. I just connected the adaptor (ps2 to usb) to my brother's pc and the controller worked without any issue. I didn't even have to install any drivers. I recongized as a new USB joystick and was then able to test and play in a game without no problem. I tried this on mine last week and nothing. I am going to look at the settings on his and try to compare it to mine. I know one difference is that he has usb 2.0 and I have the regular usb, but it should still work. What files should I copy, or configuration settings should I be looking at so when I get home I can setup mine up similar? Would coping files off his pc to and putting them on mine possibly resolve the issue, even though he has xp home and I have professional/student version? Sugestions?
  18. N3051M

    N3051M TS Evangelist Posts: 2,115

    Tell the truth.. i have no idea.. there is infinate amounts of variables between two computers, from usage to hardware to software..

    i doubt it.. might screw your pc if you decide to copy the system ones..

    if it bothers you that much, try and just backup and reinstall windows and start fresh, trying your joysticks when its fresh loaded (no software) then again after you install some more software or drivers untill you find if anything is causing the conflict..
  19. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    Doing a frest install of Windows seems like a lot of work to back everything up. Do you know of a quick way to do that? On my brothers pc I can just plug the device in the usb and then a pop display new hardware and from there can use without any problem. On mine I have a little icon but no pop up with the word New Hardware. So I know it's nothing to do with controller, not being block by firewall (tired with it off), according to Everett Program under input devices reads exact same on my brothers pc. So what else can it be? The only other thing I did notice was that in a folder c:\windows\system32\drivers and is that he has a lot more files then I do but I reinstalled Windows and did appear to be any missing files, could that be it?
  20. N3051M

    N3051M TS Evangelist Posts: 2,115

    not really, just having all your program cds and keys ready nearby.. although a Repair may be your last option before you do go and format your PC, since its similar to reinstalling windows, but leaving data intact. Refer to this:

    other than that you can try uninstalling the drivers for your gamepad and finding a utility that will clean out the old drivers so all you have to do is load new ones, maybe.. or try the Add new hardware wizard from the control panel. Besides those, i'm running out of ideas.
  21. jdl26

    jdl26 TS Rookie Topic Starter Posts: 35

    Thanks for all the post guys! But issues has not been resolved, finally! I gave my pc back to the one that reformatted my harddrive and he was able to correct the issue but reformatting again and installing a different windows xp pro version. He was able to copy a lot of file to his extra harddrive so I didn't loose too much. I am just glad to be rid of the that headache. It would be so much easier if I just invested in a new system but I want to run this one for as long as possible, going on 6years.
  22. N3051M

    N3051M TS Evangelist Posts: 2,115

    good to hear you've got it resolved :)

    i think its time you invest yourself in one of those external hdds for backing up your files with, especially since its good habit.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...