Gateway ML3109 drivers found

By aksd · 54 replies
Nov 18, 2007
  1. I bought this laptop a few months back from Bestbuy for the unbeatable price of $350.

    Has low specs but should that be what you need it's great

    Celeron M 1.6ghz
    512mb ddr2-667 4-4-4-12
    80gb seagate 5400rpm HDD
    ATI m200 w/out 1394
    Wireless/lan/56k modem
    3 USB ports
    SD card slot
    14" screen

    Not bad right? Wrong it's shipped with Vista basic. After struggling with Vista I knew it had to go. Xp is the next logical OS. Installed and next came the locating of drivers. I spent over a month with no sound, no wifi, and 2 or 3 unknown devices SMbus was one...When at last I found this site

    Thank you so much! yay!

    So now the struggle is over and should anyone else want to purchase this Bestbuy deal and having to worry about not finding the drivers for Xp...
    Here they are:

    Marvell 10/100 network:

    Realtek 8185L 802.11b/g network:

    High Definition Audio Bus driver (install only the Microsoft KB888111 executable):

    SigmaTel Audio:

    Agere HDA Modem:

    Omega ATI Radeon 200M graphics (third-party driver, select Radeon, then XP):

    EDIT:New download location USB2.0 and SMBus (unpacks drivers to C:\ATI, won’t install):
  2. jd300

    jd300 TS Rookie

    hi i bought this laptop for my wife and would love install xp on it , i tried and it locked up the laptop and i ordered the restore dvd from gateway could you give me more info on how to downgrade and correctly do it please?
  3. fastco

    fastco TS Booster Posts: 1,123

    Just boot off of a valid XP cd, Delete the current partition, create a new partition, do a full format then install XP.. Just follow the prompts on the screen it's very easy. Make sure you download the Drivers that aksd graciously provided so you don't run into the same headaches as him. Any problems just ask here of email me.
  4. aksd

    aksd TS Member Topic Starter Posts: 51

    I just popped in the XP cd deleted the partition and reformatted. That's it...other then the 1-2 month search for the drivers that lead to the great find above
  5. jd300

    jd300 TS Rookie

    i did as stated but i it would only let me into safe mode and randomly restarted ,do i have to flash the bios or something i just got lost in the process
  6. aksd

    aksd TS Member Topic Starter Posts: 51

    I really don't know. I have had no trouble with it. Installed like a champ...Maybe the install got goofed?
  7. rh1ann

    rh1ann TS Rookie

    I installed XP, got the drivers etc. One problem, I can't get the audio to work at all. Any suggestions?

    I found the folder for kb888111xpsp2.

    I clicked on it to begin the installation.

    After the installation, the 'Found new hardware' wizard comes up.
    I searched the location WDM_R173\WDM_R173\\WDM
    Nothing - couldn't find the necessary software.

    So, I try again.
    This time, I told it not to search.
    I selected the Sound, video and game controllers.
    The next screen you choose the manufacturer and the model.

    Which 2 do I choose?
  8. aksd

    aksd TS Member Topic Starter Posts: 51

    Did you start installing the drivers before or after updating to SP2? Both times I have installed XP on the system I started with only LAN then updated.

    Also I installed in this order:

    HD audio bus driver

    "installed XP, got the drivers etc. One problem, I can't get the audio to work at all. Any suggestions?

    I found the folder for kb888111xpsp2.

    I clicked on it to begin the installation."

    Cancel out of the new hardware found window and reboot. After install the Sigmatel driver...comes as a selfextracting rar which I found "setup.exe" in C:\cabs\D00737-001-001...depends where the files extracted to

    Hope this helps :) If not post back

  9. rh1ann

    rh1ann TS Rookie

    I am starting over from scratch.

    I had been installing in the order you had in the first post.

    If I read your last post correctly, it should be:

    Omega Drivers
    the KB888111

    I'll try this order. *crosses fingers*

    [and yes - I'm new to this sort of thing]
  10. aksd

    aksd TS Member Topic Starter Posts: 51

    ok cool. I don't remember which...I think only the LAN and Wireless I used the windows driver search. Extracted the drivers grabbed the sys and ini files, put them on desktop then pointed windows to desktop.

    The order with the drivers shouldn't be too important. Only with the HD audio bus and the sound driver as the sigmatel driver requires the HD audio be installed first.

    *crosses fingers for rh1ann*
  11. rh1ann

    rh1ann TS Rookie


    the latest saga:

    first the good news - I have sound!

    now the bad: I have no internet. Which is really confusing me because last night I did before I did the reinstall. So I am obviously screwing something up.

    I tried so many things last night that I have no idea what worked and what didn't.

    In the device manager, it says that the Marvell and Realtek [under network adapters] are fine - there's no big yellow thingy there.

    When I try to set up a network connection, both the Marvell and Realtek are disconnected. How do I get them connected?

    In the ATI setup for the SMBus - at the end of the installation, it said: setup did not find a driver compatible with your current hardware or operating system.
  12. aksd

    aksd TS Member Topic Starter Posts: 51

    Um...dissconnected you say? Try control panel>Network & internet>network connections>rightclick one and see if you can "enable"

    "USB2.0 and SMBus (unpacks drivers to C:\ATI, won’t install): "

    The driver package won't install by itself. You have to start the install to extract the files then goto the location it extracted (me it was C: ) and start the install there

  13. rh1ann

    rh1ann TS Rookie

    I actually think everything is working.

    I have sound .. and I have internet finally. The only problem is with my wireless at home - but that's a completely different issue.

    Dare I say it? It's working!

    Thank you so much for your help!
  14. aksd

    aksd TS Member Topic Starter Posts: 51

    Great news :)

    verify in the device manager there are no "unknowns"?

    Glad I could help
  15. rh1ann

    rh1ann TS Rookie

    No unknowns!


    Thank you so much!
  16. baiacces

    baiacces TS Rookie

    Hi everyone

    The driver package won't install by itself, so how can I install the package after I have found the location it extracted too. Thank you for you time.
  17. aksd

    aksd TS Member Topic Starter Posts: 51

    Yep, it is not supposed to install it self. So once you find the location it extraced to, mine was here "C:\7-11-igp_xp32_dd_ccc_wdm_sb_gart_enu_54435\Driver\SBDrv", click setup.exe located in "SBDrv"

    So run the driver you downloaded to extract the files.

    Go to: C:\7-11-igp_xp32_dd_ccc_wdm_sb_gart_enu_54435\Driver\SBDrv, or [location where they extraced for you]/Driver/SBDrv, and run setup.exe

    Anymore questions just post :)

    baiacces, welcome to Techspot!
  18. Get2008

    Get2008 TS Rookie

    Gateway ML3109 and Windows XP

    Can anyone help? I am working on a Gateway ML3109 for an elderly couple that live in my building as a favor.

    I reformeated and loaded windows XP SP2, I downloaded all thge drivers listed below.


    Both where very helpful and I have everything working but the wireless.

    I have the drivers outlied in the 2 posts above. They are installed and I had no errors. The device manager has only 1 bilg yellow ? mark on Pother devices, PCI Device.

    Under Network adapters its shows two items
    Marvell Yukon 88E8038 PCI-E Fast Ethernet Controller
    Realtek RTL8185 54M Wireless LAN Network Adapter

    Both show no red X's or Yellow ? marks. Both say they are working properly.

    I can get on the internet with cable conection, but not wirlessly?

    What am I doing wrong? I need some help, please!
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    see if this helps wrt to your Unknown Device problem

    and as to your wireless problem;
    - What make/model is the wireless access point/router you are trying to connect to?
    - Is your wireless adapter enabled? Control Panel ->Network Connections what is the Status shown? Do you see View available wireless networks listed in the window under Network Tasks?
  20. aksd

    aksd TS Member Topic Starter Posts: 51

    First is there a wireless icon (blue) by the touchpad? If the drivers are installed correctly and there aren't any other errors but still the wireless doesn't work. I would check that.

    If it isn't lit you need to enable the wireless. Function key + F2
  21. Get2008

    Get2008 TS Rookie

    It's a Linksys WRT54G

    Its a Linksys WRT54G. It was working fine with the laptop under Vista, But It had othe issues with Vista and Excel and print issues. I was asked to deload it with XP SP2.

    Yes the Laptop shows the blue wireless network icon just to the bottom left of the touch pad.
  22. Get2008

    Get2008 TS Rookie


    The wireless ICon is on, and I tried the Function key + F2

    It toggles the Icon On / Off... Its on!

    Still Nothing.
  23. aksd

    aksd TS Member Topic Starter Posts: 51

    What exactly does the wireless do? Can you search for networks?
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Confirm/check the wireless adapter
    1. Click Control Panel -> Network Connectons. You'll see a list of network connections on your computer. There should be one wireless connection listed.
    2. Right click on entry for your wireless connection and you'll get its context menu which should include an item View Available Wireless Networks. Left click to select that item
    3. You should get a window displaying all wireless networks detected. Do you get that window?
    You'll find quick install guide, manuals, top problems/solutions at the linksys support site for your router here
    My advice when setting up a wireless network, is always Start Simple! (i.e. start out by turning off all wireless encryption, MAC address filtering, etc.) Once you verify you can establish simple network connectivity to an unencrypted/unfiltered wireless network, then and only then start adding the various encryption and filtering options. Otherwise, you'll be struggling to localize and pinpoint just where your problem is

    If still having problems, post back
  25. pilot-leo

    pilot-leo TS Rookie

    Hey 'aksd' and 'to whom it may concern', I also own a Gateway ML3109 and I HATE VISTA and I would really like to have XP on my gateway but of course you know the problem........DRIVERS !!!

    I did everything you state read this entire thread about 100 times and well problems problems problems ;(

    I would extremely appreciate it if you add me to you MSN Messenger contact list so that you can help and I'm quite computer literate so dont worry, my email address is ''

    Thank you very much
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...