Geforce 9800 GT - Blue Screen of Death

By Maximus 13 ยท 8 replies
Jan 7, 2009
  1. I just replaced my Geforce 6600 256M with a Geforce 9800 512M, both manufactured by XFX. Prior to the upgrade everything worked fine and running the latest drivers. I replaced the card and kept the driver, assuming it would function properly. After installation everything seemed ok until I tried to run a CD, that's when everything slowed down and the drive ran without apparently reading any data, or at least it didn't do anything. When I tried to install Fallout 3 the system crashed to the infamous Blue screen of Death.

    I uninstalled and reinstalled the drivers three times now, to include shutting off AV and ensuring all fragments of the previous drivers were removed (used Driver Sweper and CCleaner). When I put in Fallout 3 the drive spins up and then the screen flashes blue with some text on it and the system reboots. I cant read the text before it reboots but I think I seen something about VGA, maybe. MS installed some update after the last driver reinstall and needed to restart, but instead I tried to install my game again and it tried to run instead of crashing but of course couldn't complete installation - but it proved that the problem wasn't the hardware specifically.... Since rebooting I tried to install again but it just blue screens, no idea why the hanging update would allow the drive to run and not any other time. Also, it plays audio and video just fine, just not data....

    The problem only occurs when I try to run something from the CDROM drive, but functions fine with browser graphics and such. I'm out of idea's here, any help would be appreciated.

    My system:
    CPU: Celeron 3.06Ghz
    Mobo: Intel PSN925D
    PSU: ABS Tagan BZ 700
    GPU: Geforce 9800 GT
    Latest Nvidia drivers, DirectX9.0c, Win XP SP3, CD/DVD ROM RW Memorex 8x 48x

    (Sorry no linky's, the site wont let me)
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your power supply may be too weak to support the new video card and everything else
  3. Maximus 13

    Maximus 13 TS Rookie Topic Starter

    Here's the specs on my PSU:

    Voltage AC Input 100-240V AC; 12/6A; 50/60Hz
    DC Output +3.3V +5V +12V1 +12V2 +12V3 +12V4 +12V5 +12V6 -12V 5VSB
    Max Amps 24A 24A 20A 20A 20A 20A N/A N/A 0.8A 3A
    Max Combined 140W 672W 9.6W 15W
    Max Combined 680W 20W
    Total Power 700W

    The link would make a lot more sense... you can get there by going to: tagan homepage, search under products => power supply => BZ 700 ... details under specifications
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    PS specs are one thing, weak or dieing power supplies are another. Try installing another supply and see if your troubles go away
  5. Maximus 13

    Maximus 13 TS Rookie Topic Starter

    Its only 6 months old, and ran fine with the Geforce 6600 - plus I dont have any spare PSU's lying around. Everything works fine except when I try to run the drive with a data CD, but a normal DVD movie plays fine which shouldn't happen if there's not enough energy.

    Any other suggestions?
  6. tweakboy

    tweakboy TS Guru Posts: 467

    So don't run the driver install from CD, Just download latest version from site. That would solve that wouldn't it? gl,
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    It is always better to do this, but in this case it may or may not work
  8. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Try putting a different power plug from the PSU into the optical drive. If the drive is on the same 12v rail as the video card, the card may be hogging all the power from the rail and leaving none for the drive to work properly.
  9. Maximus 13

    Maximus 13 TS Rookie Topic Starter

    I plugged in an independent cable from the PSU to the GPU with no changes. So I ran msconfig and turned off all the start-up items to see if it was a software conflict and sure enough, the disk ran! I went through the list of start-up programs a few at a time looking for the offender but never found it (was sure it would be Rivatuner or Adobe Gamma) but after returning msconfig to its original state, I noticed my AV (Zone Alarm) was shut down and couldn't be restarted properly. After reinstalling that, the problems have returned so I'm going to head over to their boards and see what they can do. If I find a solution, I'll post it here so others can benefit, thanks for all your help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...