Generic Host Process Win32 Services

By agentrv007 ยท 9 replies
Sep 8, 2003
  1. I have a Presario 700 laptop running Windows XP and am having problems with my audio. I've restored my computer and it works fine until I try and play music/film/clip from the internet and then a message pops up that says "Generic Host process for Win32 Services is experiencing a problem and must close. Sorry for the inconvenience." After that pops up I can't hear any audio at all. I try to play music on my Windows Media and it tells me: ""Cannot play back the audio stream: no audio hardware is available, or the hardware is not responding" and when I try my WinAmp it says: "A device has been used that is out of range for your system". Its been suggested that perhaps I have the MSBlast worm but my university made me run a disk checking for the worm and install a patch before connecting to the internet. So, could it be that it didn't work? What else could be going wrong?? I've posted this in the Audio section but no one was able to help.....thought this would be worth a try.
  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I have seen several references to not only msblast but other worms and viruses in relation to that error as well. Everything I've found pretty much points to a worm. If you are already patched for the RPC exploit, make sure you also have the latest virus updates for your AV software and do a full scan.
  3. Tuxedo717

    Tuxedo717 TS Rookie


    is there a solution to this yet? im having the exact same problem...if i leave the window with the error open i can still get sound but when i close it, its gone!
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Maybe (re)starting Windows Audio service and those it depends on could help.
  5. Tuxedo717

    Tuxedo717 TS Rookie


    it worked kinda! the message still always pops up once per boot, but once i reactivate service it works till i restart the computer lol...

    thanks, and as soon as anyone figure out how to make that shutting off in the first place....itd be awsome
  6. mole

    mole TS Rookie Posts: 22

    ya i have the same EXACT problem. its also annoyin cuz its not just sound. its the network and taskbar too.
    firstly, the network. i have my 2 pcs networked. 1 downstairs and 1 upstairs.
    the upstairs is mine and is the gateway (so this one has direct access to the internet). the downstairs one leeches off the upstairs one. so the upstairs one needs to be on for the downstairs to have the net. but i keep gettin that generic host win32 services error, the network goes down. the upstairs can use the net but the downstairs cant. so i have to restart pc, which is annoying.
    secondly, when i get this generic host error, its also the taskbar that is affected. (i think its called the taskbar.. im talkin about the bar at the bottom where u have "Start" etc.. :p). the taskbar seems to return to the win98 version (i use windows xp professional). so it looks as if im using windows 98.

    so 3 problems now right? audio, network and taskbar.
    i dont really mind about the taskbar but the other 2 are necessary.
    any help appreciated, thanks.
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Does it have an automatic restart with one minute grace period, or do you restart it manually?

    You can configure what happens when services fail. Some services have default option to restart the computer after one minute. I'd change it to restart the service instead.

    They can be configured using Control Panel -> Administrative Tools -> Services, right-click on service, select properties, then recovery tab.
    The network problem sounds like "Internet Connection Firewall / Internet Connection Sharing" service fails. The second problem is caused by "Themes" service failing.
  8. mole

    mole TS Rookie Posts: 22

    ok thanks alot i will try that. will keep u updated on wats goin on with my pc
    thanks alot for helping everyone :)
  9. ongmac

    ongmac TS Rookie

    Generic Host Process for Win32 Services Error

    I have a problem I had been having a "Generic Host Process for Win 32 Services" error for a couple of weeks (values are szAppName:svchost.exe, szAppVer:, szModName: unknown, szModVer:, offset: 00000000) and finally (I know, I know, I'm a lazy twit) ran a full scan with my Norton AV, which 'automatically deleted" Trojan.ByteVerify, which included beyond.class, blackbox.class, and VB.class being removed.

    Following the Norton AV removal of Trojan.ByteVerify, I ran currently updated versions of both Ad-Aware and Spybot that only found a few data miner cookies and the Spybot DSO exploit bug.

    I am running Windows XP ver. 5.1 (Build 2600.xpsp_sp2_rtm.040803-2158: Service Pack 2). I will append the HJT log below. I can see that Digital Line Detect and MS Broadband Networking links = ?, although the processes appear to load normally. The info on the Trojan seems to imply it is related to Sun Java somehow. Could you please check the HJT log and see if you could help me restore/recover back to normal, please? Thanks, Craig.

    Logfile of HijackThis v1.98.2
    Scan saved at 6:21:37 PM, on 2/22/2005
    Platform: Windows XP SP2 (WinNT 5.01.2600)
    MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

    Running processes:
    C:\Program Files\Common Files\Symantec Shared\ccSetMgr.exe
    C:\Program Files\Norton SystemWorks\Norton Antivirus\navapsvc.exe
    C:\Program Files\Norton SystemWorks\Norton Antivirus\SAVScan.exe
    C:\Program Files\Common Files\Symantec Shared\CCPD-LC\symlcsvc.exe
    C:\Program Files\Common Files\Symantec Shared\ccEvtMgr.exe
    C:\Program Files\Common Files\Symantec Shared\Security Center\SymWSC.exe
    C:\Program Files\Common Files\Symantec Shared\ccApp.exe
    C:\Program Files\Digital Line Detect\DLG.exe
    C:\Program Files\Microsoft Broadband Networking\MSBNTray.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Messenger\msmsgs.exe

    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Default_Page_URL =
    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar =*
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL =
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Bar =*
    R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page =
    R1 - HKCU\Software\Microsoft\Internet Explorer\SearchURL,(Default) =*
    O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 6.0\Reader\ActiveX\AcroIEHelper.dll
    O2 - BHO: (no name) - {53707962-6F74-2D53-2644-206D7942484F} - C:\PROGRA~1\SPYBOT~1\SDHelper.dll
    O2 - BHO: NAV Helper - {BDF3E430-B101-42AD-A544-FADC6B084872} - C:\Program Files\Norton SystemWorks\Norton Antivirus\NavShExt.dll
    O2 - BHO: (no name) - {FDD3B846-8D59-4ffb-8758-209B6AD74ACC} - C:\Program Files\Microsoft Money\System\mnyviewer.dll
    O3 - Toolbar: Norton AntiVirus - {42CDD1BF-3FFB-4238-8AD1-7859DF00B1D6} - C:\Program Files\Norton SystemWorks\Norton Antivirus\NavShExt.dll
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
    O4 - HKLM\..\Run: [ccApp] "C:\Program Files\Common Files\Symantec Shared\ccApp.exe"
    O4 - HKLM\..\Run: [Symantec NetDriver Monitor] C:\PROGRA~1\SYMNET~1\SNDMon.exe
    O4 - HKLM\..\Run: [UserFaultCheck] %systemroot%\system32\dumprep 0 -u
    O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
    O4 - HKCU\..\Run: [Microsoft Works Update Detection] C:\Program Files\Microsoft Works\WkDetect.exe
    O4 - Global Startup: Digital Line Detect.lnk = ?
    O4 - Global Startup: Microsoft Broadband Networking.lnk = ?
    O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office10\OSA.EXE
    O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~4\Office10\EXCEL.EXE/3000
    O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\WINDOWS\System32\msjava.dll
    O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\WINDOWS\System32\msjava.dll
    O9 - Extra button: Messenger - {4528BBE0-4E08-11D5-AD55-00010333D0AD} - (no file)
    O9 - Extra 'Tools' menuitem: Yahoo! Messenger - {4528BBE0-4E08-11D5-AD55-00010333D0AD} - (no file)
    O9 - Extra button: AIM - {AC9E2541-2814-11d5-BC6D-00B0D0A1DE45} - C:\Program Files\AIM95\aim.exe
    O9 - Extra button: ICQ 4 - {B863453A-26C3-4e1f-A54D-A2CD196348E9} - C:\Program Files\ICQLite\ICQLite.exe
    O9 - Extra 'Tools' menuitem: ICQ Lite - {B863453A-26C3-4e1f-A54D-A2CD196348E9} - C:\Program Files\ICQLite\ICQLite.exe
    O9 - Extra button: - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - C:\WINDOWS\System32\Shdocvw.dll
    O9 - Extra button: MoneySide - {E023F504-0C5A-4750-A1E7-A9046DEA8A21} - C:\Program Files\Microsoft Money\System\mnyviewer.dll
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O16 - DPF: {1B12E01E-C786-11D3-BEC3-00105AA9B6AE} (Ratings Class) -
    O16 - DPF: {2B323CD9-50E3-11D3-9466-00A0C9700498} -
    O16 - DPF: {4E888414-DB8F-11D1-9CD9-00C04F98436A} (Microsoft.WinRep) -
    O16 - DPF: {644E432F-49D3-41A1-8DD5-E099162EEEC5} (Symantec RuFSI Utility Class) -
    O16 - DPF: {74691800-C912-11D3-9B07-0020AFD7951A} (SimpServ Class) -
    O16 - DPF: {C2FCEF52-ACE9-11D3-BEBD-00105AA9B6AE} (Symantec RuFSI Registry Information Class) -
    O16 - DPF: {CE28D5D2-60CF-4C7D-9FE8-0F47A3308078} (ActiveDataInfo Class) -
    O16 - DPF: {D27CDB70-AE6D-11cf-96B8-444553540000} (Macromedia Flash Factory Object) -
    O16 - DPF: {D3A7982E-915D-4589-8ECE-249F70D0C941} (Launch Control) -
    O16 - DPF: {E77C0D62-882A-456F-AD8F-7C6C9569B8C7} (ActiveDataObj Class) -
    O16 - DPF: {F54C1137-5E34-4B95-95A5-BA56D4D8D743} (Secure Delivery) -
  10. erinking_xoxo

    erinking_xoxo TS Rookie

    Hello, I have been having the exact same problem. I thought that a virus i had previously had damaged some of my windows files so i ran through the entire windows, drivers, and application repair sequences and it fixed NOTHING. However, just today I ran the yahoo anti-spy program (i usually just use norton antivirus and ad-aware) and it found spyware that ad-aware didn't. Now its only been one day but my sound has been working fine and i haven't had the "Generic Host Process for Win32 Services" error pop up yet. I'm hoping its fixed for good. For everyone else here with this problem its worth a try. If the error does show up again i'll post to let you know this attempted fix was a dead end.

    Hope this helps!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...