help me! mobo no powerup

By zdc
Sep 27, 2007
  1. What's up guys? First time poster and I'm glad I found this site because from what I see you guys look pretty helpful and I'm completely stumped.

    Today I was rearranging my room which required me to move my PC. Naturally I shutdown, flipped the switch on the PSU, unplugged everything and moved it. After I hooked it back up it wouldn't power on. I've built multiple computers and I feel I have a pretty good grasp on how things work.

    This is what I've tried so far with results (please keep in mind that I'm at this point just trying to hook things up one by one to figure out what the problem is). btw my mobo is: Foxconn C51XEM2AA- 8EKRS2H AM2 NVIDIA nForce 590 SLI MCP ATX AMD

    Hooked up
    checked connections in PC
    unhooked sound card (SB fidelity gamer)
    unhooked harddrive (WD 300gb sata)
    unhooked cdburner
    unhooked videocard (BFG 7900GT 256MB)
    reset ram (2 sticks of DDR2-800 1GB)
    pulled mobo out of case
    reset CPU (AMD 64 X2 3800+) + reset ram again
    Tried different PSU (original in this pc: OCZ 600w -- other Aspire 550w) (I know the aspire works because I'm using it in my bros PC right now).

    Also, I like to keep my brother off my PC and because of that I have to type in a password on my keyboard rather than press the power button just to turn it on so...

    Tried different keyboard
    Reset CMOS
    Used screwdriver instead of power button on case
    Also I have a power and reset button on my actual motherboard itself so I tried both those and no go.

    Is there anything else I can try other than calling foxconn for a RMA? What else could it be?

    Also I would try different CPU and RAM but I don't have any to use for this particular PC.
  2. zdc

    zdc TS Rookie Topic Starter

    Yay! Nevermind guys, I fixed it.. Don't know why but everything worked perfectly after I removed the battery and started it without the battery in. I put the thing back in after that and it works perfectly....

    Can someone explain to me why it worked without the battery or why that even mattered?
  3. k.jacko

    k.jacko TS Rookie Posts: 493

    Well............I Can't! :eek:

    But i thought i'd post so you didn't feel lonely in your first thread! :D

    Although, i wonder if there was a short somewhere between the board and casem and the pressure you applied to remove the battery changed that somehow......paradoxically. ???
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...