LG 52x24x52 cdrw

By Dragon · 8 replies
Mar 22, 2004
  1. cd rom..

    i have a LG 52x24x52 cdrw, and i can't enable ultra dma..and it burns at like 10x and reads that slow too =( how can i fix this? btw my comp is a amd xp 2500+ and the board is asus a7n8x-x anyone pls?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You need to enable UDMA first in BIOS, then in IDE controller under Device Manager. IIRC there was some problem in win2k with UDMA and you had to enable it with a registry setting.
  3. Dragon

    Dragon TS Rookie Topic Starter Posts: 33

    oops sorry, i forgot to mention i have windows xp, but how do i enable it in bios?
  4. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,978   +15

    When your computer is booting [just as you turn it on], keep hiting the Delete/Del key until you see a big blue screen come up.

    You should see a bunch of submenus, look under all of then for an option to turn UDMA on. Besure not to change any other settings in there though, it can break your computer.
  5. Dragon

    Dragon TS Rookie Topic Starter Posts: 33

    i can't find anything to do with that there, perhaps it's the cable?
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    It's not the cable.

    In BIOS look under integrated peripherals -> IDE/ATA controller or something similar.
  7. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    You shouldn't have to enable it in the BIOS.. I don't think I've ever had to do that.. Because DMA is default. But, it is worth trying. :)

    I think you should uninstall your IDE Busmaster drivers. Go to Device Manager and IDE/ATAPI controllers. You should see Pimary and Secondary channels and then a third item.. Probably says Busmaster with some other stuff. Right click and uninstall this. Reboot your computer and let it redect your drives.

    DMA should be automatic, but you may have to turn it on manually.

    This should work. If it does not, please update your IDE drivers. Depending on what hardware you have, you'll probably end up going to www.viaarena.com , www.sis.com , or www.intel.com for the drivers.

    If this still doesn't work, you have some sort of other problem I'm not familiar with.
  8. Dragon

    Dragon TS Rookie Topic Starter Posts: 33

    thanks so much, i uninstalled the IDE/ATPI controllers, and it works now
  9. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Windows XP and 2000 will force your optical drives in PIO mode if it detects errors while copying a file.

    A bad CD might cause your drive(s) to run in PIO mode.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...