Lockups, completely stumped

By Nukey · 5 replies
Aug 16, 2010
Post New Reply
  1. Hi,

    I've worked with computers for a little while now but this issue I seem to be having has totally baffled me, and I'm having to run around frantically trying to find out what the problem is with. So I thought I'd check with a bunch of experts incase Ive missed anything.

    I initially built my computer back about a year and 8 months ago, and the system was running fine. Not a single peep out of it, I was really satisfied with what I had built. Anyway, more recently I thought I'd take the opportunity to upgrade my system and splash a bit of cash (you know how these things go... spend thousands, don't tell the other half??) ;) but anyway things didn't kind of go to plan.

    Initially I had my main system board, which was a Gigabyte EX58-UD5, and was running an i7 920 2.66GHz processor with 6GB of PC3 12800 OCZ RAM running in tri-channel. I thought it was time to upgrade my CPU, hard drives (one of them failed and made my RAID go a bit dicky), and graphics card.

    Previously my graphics card (which was an nVidia GTX 280) before the swapover started getting these weird scrolling colours going up the screen erratically, usually within a few minutes of running World of Warcraft, and occasionally just on the Windows desktop. Drivers made no difference at all, and it then got to the stage where even loading into Windows caused a problem, so I thought that it was obviously broken so would be a good opportunity to get a new card.

    Initially I had run stock sooling on everything. My case is a Coolermaster Cosmos and running stock fans on all of the hardware, as I (thought) that fiddling around with things that aren't initially paired with these devices would (potentially) cause problems.

    Ever since having my new shiny (and overpriced) CPU and graphics card (which is a Powercolor HD 5970 2GB ATI by the way), I have been getting these weird artifacts all over the screen and it's had me totally baffled.

    The problems started on the desktop. Windows would load and after a few minutes the artifacts would appear, and the screen would then go grey, go black then recover with a "The display driver ATIKMDAG has stopped responding and has recovered". At first I thought this was memory related, so I removed two of the three sticks. Still the same issue. I swapped the memory sticks over incase it was the first, still had problems.

    I uninstalled the latest drivers and reinstalled them to an earlier version, using display drivers which would allow "specalist" profiles to be created (I increased the 2D clock speed on the Windows desktop from 157MHz to 400MHz in case Windows wasn't getting enough). This was fine for me for a while, the lockups on the Windows desktop were gone. However, every time I loaded World of Warcraft, after a few minutes the whole thing would freeze; sometimes even the reset button wouldnt work on the case unless it was held down for 20 seconds.

    On both cards the temperatures seemed to be absolutely fine, CPU would run between 45-60 degrees and the graphics between 50-65 degrees. Nothing too major.

    Going back to these profiles, when I upgraded to the latest CCC drivers (version 10.7) the issue with the desktop crashing occured again, as well as the lockups when starting World of Warcraft. The odd thing is, if I loaded any other games like Dead Space or Metro 2033, the game would run perfectly well without any issues.

    At this point I thought ok... This might be my RAM that is going a little ropey here, so I took two of the sticks out and left just the one 2GB stick in there. This solved the issue for a little while, but then the crashing came back again. I tried one of the other sticks in there as well, and this was exactly the same. I also moved the graphics card into the other slot, however I still had problems.

    One thing to mention, when I upgraded to the latest 10.7 drivers, I started getting these STOP screens, "SYSTEM_SERVICE_EXCEPTION", 0x0000007E, in relation to ATIKMDAG. I restarted the machine using last known good configuration, and this worked again, I then removed all the Catalyst Control Center drivers, and reverted back to the standard Windows drivers. The blue screens continued.

    I restarted in Safe Mode and then navigated to the C:\Windows\System32\drivers folder and seleted the ATI drivers completely from the system and restarted in normal mode. This worked, however I was stuck with low resolutions, so I went to the Device Manager and manually reinstalled the drivers, which were pulled from the system's repository. This then appeared to work, I was then using standard Windows drivers for the 5970 HD, and had full correct resolution for my screen.

    And then...

    ...It crashed again, with artifacts. Only this time, I had the message "The display driver ATI Driver was not responding and successfully recovered". So it seems like the standard drivers arent working either.

    To be honest Im not sure if it's the memory that is causing an issue, because I have tested the memory and run diagnostics on it and appears to be fine. While both my GTX 280 and HD 5970 had graphics related issues which were different, both of them seem to behave erratically in one way or another, so Im doubting if it is the cards themselves causing an issue.

    Windows has been reinstalled as well, so I don't think it's the OS.

    I've never overclocked my machine and have only run it with standard cooling that it came with in the box (it should at least work, surely?)

    My power supply is a Corsair TX 650W.

    I have also included a couple of images as to what the artifacting looks like.

    Any ideas guys? Thanks for your help!

    [​IMG] [​IMG] [​IMG]
  2. Sharam

    Sharam TS Rookie Posts: 509

    What I know is that Artefacts are caused by Memory (video card memory) but freezes and crashes by the GPU.

    I would test the System memory, one stick at a time with Memtest but after I am certain the motherboard has the latest BIOS and it is setup according to the configuration, this could translate in to playing with voltages, for RAM, Chipset and the CPU as well as Memory timing. If these values are not set (which could differ with two identical configurations) Memtest might report faulty RAM when RAM is OK.

    OCZ has quite a bit of RMA going on on their support forum, good place to ask for help with settings ;)

    2 cards same symptoms, I lean towards RAM, BIOS settings and last but not least, power.
  3. Nukey

    Nukey TS Rookie Topic Starter Posts: 110

    Hey thanks for the quick reply!

    I initially ran the memory through mtest86 and this was ran overnight but this came back that the RAM was okay. Also I was a little unsure at the fact that there were issues on all three pieces of memory, when used on their own individually.

    Im thinking maybe graphics, or maybe systemboard, but I'm not sure. I'd probably be a bit dubious to look at changing memory timings and things as this could potentially make things worse.

    Problem is I dont have another machine I can test the other stuff in, otherwise Id stick each piece in there and see what was happening...

    I am using the latest BIOS as well to eliminate that potentially. Ive also tried the settings on normal, turbo and extreme in the BIOS but this made no difference on either setting.

    Im tempted to buy a new systemboard... but Im not sure :(
  4. Sharam

    Sharam TS Rookie Posts: 509

    I meant testing single modules at a time with Memtest, I've been surprised before!

    It is possible that you've had 2 bad cards in a row.

    Ever since DDR2 systems and more so with today’s system, slight change in chipset voltages and such make big difference with stability! I always adjust settings before I even start installing OS.

    I'm a little confused; the board was never changed right? And what did you upgrade to from the i7 920?

    I have to re-read this again, been up all day and night maybe I can see better then ;)

    I would visit the OCZ Forums; they do have stickies with RAM settings based on boards and CPU or even post in the GIGABYTE section.

    At the shop, things are easier since there are components to swap and get to the point quickly.
  5. Nukey

    Nukey TS Rookie Topic Starter Posts: 110

    Ah sorry about the CPU thing, I upgraded to the i7 975 3.33GHz :)

    Ill take a look at the voltages tonight and see if they are what they should be, and try what you suggested! Maybe all three pieces of RAM are dead, and also those OCZ forums look quite interesting too. I'll take a look and report back.


    EDIT: Im looking at the OCZ forums and they seem to talk about overclocking the settings, maybe this will take longer than I first thought ;)
  6. Sharam

    Sharam TS Rookie Posts: 509

    RAM could be faulty but not dead!

    If you can, post the exact model of your OCZ.

    Reading this again, it seems as if I'm saying it is your RAM, I was just trying to say, in order to be certain, modules should be tested one by one in memtest.

    That Forum is the best for getting proper settings.

    Keep us posted.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...