Logitech download assist troubleshooting

By circusboy01 ยท 11 replies
Mar 22, 2015
Post New Reply
  1. I must have done something. But I don't remember what, or when. But these things don't show up for no reason.
    About 3 weeks ago these two things started showing up at start up.
    problem starting C:\windows|system32\LOGILDA.DLL The specific module could not be found
    ( lots of 0s) followed by814B2E in module 'Itr.exe'.read of address ( lots of 0s) followed by2D8
    Exception EAccess Violation in module Itr.exe at (or possibly et or ct)
    Sloppy hand writing, and I don't want to restart my computer to see it again, and have to type this all over.
    Naturally if you tell me I have to I will.
    I left them on so long because they don't seem to be causing any problems other than irritation.
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    This is easily found with a google search - it is to do with Logitech download assist, and seems to be installed by updating win 8 to 8.1

    "I just called Logitech corporate office and they helped me disable the file without uninstalling it which could disable other files on the computer. Here is what he told me to do. It's a simple fix.

    Go to either your start up and search box or go to run

    Type in msconfig.

    In the System Configuration window click on the start up tab.

    Open Task Manager or if it in in the current window under start up you will see the LogiLDA name and then click disable.

    Restart up windows and when it comes up your error message shouldn't show up"
  3. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 799   +16

    I'm using Windows 7 not 8,. Would the instructions still be the same? I dont want to cause myself any more problems because I did something that was strictly for 8, and not 7
    Last edited: Mar 22, 2015
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Last edited: Mar 23, 2015
  5. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 799   +16

    looked in Program Data in Local Disk C Found Logitec. Took me toKHAL which took me to Battery
    Battery and cache took me to a bunch of letters and numbers. Devices took me to HPP20 device.
    In other words I don't have a clue what I have on my PC to do with Logitec :0)
  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Try this. Click the windows Start button. Key into the search box 'msconfig' (without the quotes of course). Select the 'services' tab and click to select the 'hide all miscrosoft services' box. If you can then upload a snapshot of the resulting window, we might be able to tell what logitech service is started. Which you could then stop.

    It might also be worth clicking the 'startup' tab, then click the header 'date disabled' so the list is sorted with disabled startup items last (if there are any !). Again an upload of that window will be useful, although you may have to do several snapshots to see all startup items.
  7. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 799   +16

    I Just realized My wireless keyboard and mouse are Logitech,and I have Logitech download helper.
    Now we have been talking about Logitec. Hopefully that's just an abbreviated version of Logitech. Or maybe I just forgot the h when I wrote my first post.
    I think I can do,just fine, without Logitech download helper. What are the chances that it would be safe just to find, and delete it?
    About your last instructions. If snapshot is the same as screen shot. I don't know how to do that. :
    Last edited: Mar 24, 2015
  8. nickc

    nickc TechSpot Paladin Posts: 923   +11

    U're computer wold run just fine without download helper. and u would never know it is gone.But go into the Control Panel and uninstall it.
  9. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 799   +16

    Gbhall I owe you an apology In my last post I talked about if Logitech had an H or not, and that I had discovered that I had Logitech Download Helper. Just like I never even read your first post. It's just that I hadn't read it in a while. Believe me. I didn't ignore the post.

    II tried to follow your instructions from your first post
    Typed misconfig in Run clicked * enter git the bonk sound that I get when the two messages we are talking about pop up. Said "windows cannot find misconfig make sure it's spelled correctly" What am I doing wrong?
    *The button might not have said enter. It might have said OK or something like that. But. I did click on the button that was lit up after I typed in config.
  10. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Probably you as a user is not a member of administrators. Try this. After keying msconfig (in the search box, not under run) you should see a pop-up pale blue box alongside saying msconfig.exe. The next thing to do is hover your mouse over that msconfig.exe box, right click your mouse button and in the selection that then pops up, choose the third option Run as administrator. The required form described in post#2 above should then appear with no further action.

    If this does not work for you, you need to find a more experienced friend to do this little job for you.
  11. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 799   +16

    Hi. I haven't forgotten that you were trying to help me. Sorry about the slow response. tried your msconfig instructions. But it didn't take me to task manager. I'm sure I probably did something wrong
    So I just typed task mgr in the start search window, and found it that way.. Thoroughly went through the whole thing and didn't find logit DA
  12. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Task manager is not what I asked you to look at. That would merely show if the Logitech helper was loaded and we already know that it is not loading and that is why you see your problem message.

    The reason you need to see the content of msconfig is to find out where it is supposed to load - as a startup item or a service - and hence you can stop it trying to load.

    Please find an experienced friend who can follow the instruction given in post #10 above, and also refer to post#6

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...