1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Mass Controller Driver

By tnred ยท 11 replies
Apr 30, 2003
  1. Hello All:
    Does anyone know how to load a Mass Storage Controller Driver for a Maxtor 40 hd?

    Any help would be greatly appreciated.

    Asus 1.7 MHZ Athalon Processor
    Win2000 os. :)
  2. Nic

    Nic TechSpot Paladin Posts: 1,549

    The 'Mass Storage Controller' isn't refering to your hard drive, but to the device it is connected to (hence 'controller').

    Have you installed all drivers for your controllers (mainboard drivers, usb drivers, scsi drivers, etc.)?
  3. tnred

    tnred TS Rookie Topic Starter

    Thanks for responding! :)

    I have installed those drivers, but I guess it is possible that they didn't take. I could try it again. If that dosen't work, do you have any other suggestions?
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    What exactly is happening that you have to install your Mass Storage/Controller drivers? Is there one of those of those yellow exclamation points in device manager?

    I ask this, because many times Windows 2000 will just bluescreen on bootup if it does not recognize your Mass Storage Controller and your system drive is connected to the controller . (which it probably should be).

    I was thinking it may be possible you do not need drivers - If it is working at all - Then you should be doing okay. If you cannot get your drivers installed, then give us the name / model of your Mass Storage Controller and someone here might know of a fix or an unsupported driver that will work.
  5. tnred

    tnred TS Rookie Topic Starter

    Well I have the system up and running and everything is running fine, but I just have the yellow exclamation mark up in the device manager.

    It is a Maxtor40 gb hd, Model number MX6L040J2
    on an Asus a7N266-c

    What is bazarr is that I have done this before on a similar box, and didn't have one problem out of it. It is no big deal, but judt by personal preference I like to update all the drivers and load all the drivers that win2k is asking for!!! KnowwhatImean!! haha :D

    So, if you or anyone have a idea, I would greatly appreciate it. This is one chic that like to learn as much as she can. Studing to take my A+ too, so hopefully..... anyways, i have babbled enough.
    Thanks for your help!!:wave:

    Btw, as a newbi on this forum, I would like to thank everyone this forum has been an enjoyable experience!
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    firstly, try removing the device (I mean from device manager, not physically) rebooting and seeing if its redetected properly.

    You might wanna swing by the web site of your motherboard's manufacturer, or even go to windowsupdate.microsoft.com for a possible motherboard chipset or IDE controller driver update.

    Also, ensure that you have S.M.A.R.T and UDMA enabled in your BIOS. Without these things, a lot of strange things can sometimes happen.
  7. tnred

    tnred TS Rookie Topic Starter

    Thanks, but I have tried everything you suggested before I posted this,and I could not find anything. Good possibility I just missed it, but I will search again:)

  8. Nic

    Nic TechSpot Paladin Posts: 1,549

    I had a similar problem with another device only recently and I couldn't get the configuration to fix itself despite trying everything. It seems that Windows XP (in my case) just wasn't interested. The problem eventually went away all by itself - during a reboot! :confused:
  9. tnred

    tnred TS Rookie Topic Starter

    Nic, I will dink around with it a little more later this morning, and i will let you guys know if i find a resolution. Thanks for all your help.
  10. Zak McKracken

    Zak McKracken TS Rookie

    Similar Problem

    I have a digital camera (Fujifilm FinePix 2400Z) that connects to my computer via USB and is recognized as a USB mass storage device. While using Win98 (first edition) I had no problems at all - after installing the drivers.
    When I upgraded to Win2k pro and connected the camera, the system asked for drivers (shouldn't Win2k naturally support USB mass storage??), I inserted the driver CD and after installation and reboot there apeared a "USB mass storage controller" device in my device manager with a yellow exclamation mark to it; and my camera isn't recognized. Since I still have my old system on my secondary hard drive, I know that the camera is working alright.

    I tried de- and reinstalling the drivers (also tried to install drivers from the Win2k CD), but Win2k keeps asking for a certain file that cannot be found anywhere but on the driver CD - I suspect that somehow the wrong .inf file got stuck somewhere and delivers false information ... but I tried removing all .inf files that looked suspicious, to no avail :dead:

    could someone help me?? Kinda sucks if you need to keep your old OS just to be able to access your pictures... :confused:
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Have you tried installing the driver downloadable from Fujifilm homepage? It may be newer and more functional then the one you have on your CD.
  12. Zak McKracken

    Zak McKracken TS Rookie


    Works now!
    Downloaded the new drivers from fujifilm.de - they would install but not work correctly! But when I tried to install them via the Device Manager I got the information which .inf file Windows was using for the wrong drivers. I moved it somewhere else, renamed it, installed the correct drivers - that's it!
    Funny, though, that windows wouldn't recognize the right drivers as long as there was another (older!) .inf file around.

    Thanks a lot!

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...