Maxtor is either detected in Bios or during IDE scan, but not in both

By artnik ยท 4 replies
Sep 20, 2006
  1. I have Asus MB and Maxtor HDD. A friend of mine got his system infected with more than a hundred different viruses, so i voluntered to reinstal his OS, but he needed his folders to be saved. I removed his Maxtor and connected it to my computer via USB copied necessary files and formatted the drive. the stupidest thing ever started when I tried to install fresh WinXP: During IDE scan Neither one of the drives was found( HDD+2DVDRoms) I checked everything again and rebooted in to the BIOS and a miracle: all drives were on their corresponding places! Too early to celebrate: as soon as I reboot machine IDE scan doesn't find any drive and a happy message, no master HDD detected appeares. I googled this issue and found out that my jumper setting might be messed up, so I tried diffferen jumper settting, even disconnected DVDRMS- nothing (as it supposed to be, I didn't touch jumper during my USB operations). I tried differnt cable -nothing, as soon as I changed the IDE slot on the MB the IDE scan perfectly found Maxtor as a master and the DVDs as primary slave and secondary master respectively, BUT it didn't want to boot from my copy of WinXP. I rebooted into the BIOS again just to check if I accidently changed settings on DVDs, when messing up with setting trying to find my HDD. AND WHAT I SAW no master no slave nothing absolutelly nothing. I thought that I, somehow, ruined HDD, but as soon as I connected it to my computer it was perfectly fine. I tried one of my HDDs on the system with the same result. I am rather positive that MB is fine.( after all operations I setted BIOS to default settings) I have some sort of theory, but unable to prove it: did anybody herd of any virus changing BIOS? I didn't. Assumption is made for reason that during scan Avast found more than a hundred viruses.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    I dont quite get your post, I think old age means I lose the plot the more I read, but I think you may be getting confused a bit.

    First, in many BIOS's you have the option to "Autodetect" the HD's and to set them as fixed.

    So if set to Autodetect the HD's will show in the IDE detection screen , but wont be listed in BIOS, and if you set them up in BIOS then only those set to Autodetect will show up in the IDE detection part of the POST, you with me still ???

    Now remove all the drives and make sure the BIOS is set to "autodetect" the drives.

    Add the HD that will house the OS and boot up the PC, check the HD shows as the Primary Master in the POST IDE detection.

    As for the DVD's add only one for now, until XP is installed, some DVD's\CD's can conflict and cause a failure to boot from DVD\CD, again make sure the chosen DVD is atapi compatible (if not it wont work as a bootable DVD) and that it is set to Master on the Secondary Channel.

    Should you have any queries please submit them in triplicate signed by both your parents and counter signed by your grandparents, all comments are my own ideas and may conflict with others.

  3. artnik

    artnik TS Rookie Topic Starter

    Already tried: the POST IDE detection will see, but bios wount, just as you said. I would assume that my WinXP copy is bad, but i have anothe one that does the same thing. THAT IS STRANGE
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Take out the drives (all of them) Remove the CMOS battery and also clear out the jumper on the MOBO if there is one on there, don't forget to unplug the system. Wait 30 mins. Then attach the HD to Primary Master and set it to master jumper. Do not use CS. Then add your CD or DVD as Secondary Master. Go into the BIOS and change the clock settings an etc.. Reimage or install a new copy of Windows XP Pro. This should work now, I've done it this way many of times.
  5. artnik

    artnik TS Rookie Topic Starter

    Thanks, for advise, but I've just reflashed BIOS. think your idea would work too. anyways thanks everybody. ( Also I have a feeling, that IDE controller might be a little messed up)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...