MMC Snap-In problems

By ComputerGuy55 · 5 replies
Aug 25, 2009
  1. Ok so heres my problem: I try and open Event Viewer, and it tells me "MMC Could not create snap-in" And I went to Run>MMC and tried to add it back, and it wouldn't let me, got the error "MMC cannot initialize snap-in Name: Event Viewer CLSID: ####################### (mix of letters/numbers)

    I'm wondering if there is a way to fix this problem and replace the .dll's and other accosiated files. Would re-installing SP3 fix this?
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    That mixture of letters and numbers if the CLSID – class identifier; (Stored in the registry at HKEY_CLASSES_ROOT\CLSID) It could be that the registry is damaged.

    Check the third post (Tuesday, April 14, 2009 5:47 PM) on TechNet.

    It may be that you will need to run the system File Checker- do you have the Windows CD?
  3. ComputerGuy55

    ComputerGuy55 TS Maniac Topic Starter Posts: 380   +8

    I know partly what it is, just didn't feel like copying it all because it was on another screen, and it is information that is not sapposed to be posted for other users to see, correct?

    I checked that site and I could do it that way, but I'm working on this persons computer and it's not only logs that I want to see, its the device manager (You can go to My Comoputer>Properties>Hardware>Device Manager) But the Manager is helpful in many many ways other then that, also Defrag doesn't work. So somewhere along the line, windows broke. I tried doing SFC /scannow and it did not seem to have an effect on these. Just wanted to know if there was a way to replace the .dll that you use to do the snap-ins manually, because I can add them back in, but the original file's seem to be missing. I'll check the backup .dll folder in the system32 folder.
  4. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    I don't know what information you're referring to that
    Shortcut to the Device Manager: Start> Run> type in devmgmt.msc> OK
  5. ComputerGuy55

    ComputerGuy55 TS Maniac Topic Starter Posts: 380   +8

    the CLSID, your ID isn't sapposed to be posted in public forums anyways. But it's ok I just reloaded. All his backup .dll files were missing, programs wouldn't run, a bunch of Admin programs no longer ran so.
  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Thank you for letting us know that you have resolved the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...