Motherboard will not post bios

By joejoe
May 15, 2013
Post New Reply
  1. Hello all, I built my own PC 4 years ago.

    Intel Core i7 920 CPU
    Gigabyte GA-EX58-UD4 Intel X58 ATX Motherboard
    G.Skill F3-10666CL9T-6GBNQ 3 x 2GB DDR3 1333 RAM
    GeForce GTX 295 Video
    Western Digital WD6400AAKS 640GB 7200RPM SATA 3.0Gb/s Hard Drive
    Corsair 1000HX Modular PSU
    Thermalright Ultra-120 Extreme 1366 RT

    Everything went fine until recently. I noticed when I would restart it wouldn't load back up. I had to shut it down and restart it again, but it would always work the second time. Now it happened again and it isn't starting at all. I mean the power runs and the fans spin and the lights on the mobo and videocard both seem positive, but I cannot get anything on the screen. I have to shut it down by holding down the power button.

    I have tried the clear bios button, I have tried using only 1 stick of RAM and swapping them around, and I put in a new CMOS battery. None of them did the trick, it still just turns on and hangs with no output. There are no beeps at any point.

    What can I do next?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "There are no beeps at any point"... Has to be a power supply or motherboard failure

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...