My first ever linux problem: no sound

By Spike ยท 9 replies
Jan 19, 2004
  1. well, I have a fe really, but only one that bothers me a lot.

    I'm running mandrake 9.2, with a C-Media 8738 sound card. Linux recognises the card, uses a generic cmedia pci driver, but no sound. volume is up all the way on all the availiable channels on Alsa, and on the taskbar. No sound.

    Given that I live for music, this is horrible! I need help!
  2. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Darn!!! Now I have another horrible problem!

    Turns out that I cannot boot back into the mandrake gui. Last thing I did in linux (and the only thing with the software itself!) was to install procs from the mandrake disks. Last thing I did to the pc itself was to enable O/B sound and disable LAN in the bios, as this was causing a hang in the xp bootup process.

    Now when I boot, I get a text based screen where I log in, which (using the 'root' example) is followed by a "[root @localhost root] $" prompt.

    Please, how do I properly exit this screen to shut down the PC, and ultimately, how do I get back to the GUI of mandrake?
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You can shutdown with "poweroff" command, reboot with "reboot".

    In case you have booted into a non-X runlevel, you can get GUI by running "telinit 5". If You have managed to break X, then run "startx" after "telinit 5" and see what errors you get.
  4. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168


    I managed to get A gui back with startx, bringing me into KDE. Sadly, exiting KDE brings me back to the prompt, and when I type telinit 5 and hit enter, i'm told that the command doesn't exist. As for the sound, I still have no idea. Now the onboard ac97 codec is detected and installed, but no sound. Do I have to manually configure the module?
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Your problem lies in the software above kernel. There are different sound daemons for KDE and GNOME. Look in KDE sound controls, see if sound works in GNOME, can you play stuff with XMMS using different output plugins.

    You have to use "/sbin/telinit" or "/usr/sbin/telinit" then.
  6. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Sound doesn't work in either KDE or Gnome, or any of the others. The only sound controls I have foound are the mixers and player in the default sound 'folder' on the proc menu, and the only other place I have found to do with sound is the sound config and module config in the hardware list (Hardrake is it?)

    Is there something I'm missing. If not, could you please take me through it a step or two at a time or something. I'm completely lost on this now, and I didn't have much of a clue before!
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Are you sure the sound card driver you have is for ALSA and not OSS? You can change the sound system used in the KDE control panel. And you can switch between different output systems in XMMS also. On my RedHat the integrated sound worked only with OSS (when I had 2.4 kernel).

    Also, there is an option in the sound settings that tells KDE whether to load souns daemon automatically. If you managed to untick that then you'd have to load it manually. I can't remember right now if KDE used esd or artsd :(

    Have you managed to get your machine to boot into graphical interface? You may have different services loading for the text mode session and GUI and maybe some sound components don't get loaded.
  8. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Yea. It's booting into the GUI now. Some how, after installing a few things from the mandrake disks, the option to boot into gui got unchecked, but that's checked again now.

    Both sound cards I've tried using (c-media, and the ac97 onboard) are supported by a driver, and are compatable with alsa. The sound won't operate in any interface, I cand find any sound services in the computer control panel (is that the computer config, with the hardware list etc?). Both alsa and each card runs on init level 3 (???), but aside from that, I don't understand the konsole readouts with the 'classic' troubleshooter it gives me from sndconfig ---> help.
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    So what are the readouts?

    And something being "compatible" with ALSA doesn't mean it actually works. Try switching to OSS and see if it helps.

    I trust you are not using a custom kernel where you forgot to put in module autoloading?

    I think that Mandrake sets the sound to mute by default. Run aumix from the command line and adjust the sound levels with that.

    And do all the experimenting as root to resolve any problems with permissions.
  10. Elcarion

    Elcarion TechSpot Paladin Posts: 169

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...