Spread the love! TechSpot Tech Gift Shortlist 2017

My Laptop keypad stop functioning after Virus removal - Help

By gw157 ยท 4 replies
Mar 8, 2010
  1. I have a Dell Inspiron 600m laptop with Windows XP service pack 3. It was infected with virus and Broni from Virus and Malware forum helped me removed the virus. My laptop is clean, however during the process of virus removal, laptop's keypad stopped functioning. Broni suggested I ask people here for help..

    When I goto device manager, there is a yellow circle with ! on the "Standard 101/102-key or Microsoft Natural PS/2 Keyboard.

    Click on the properties of the driver shows "This device cannot start. (Code 10)

    I go to Resources tab, and on resources setting: there is red circle with / over first two resource types:

    Resource type Setting

    I/O Range 0060-0060
    I/O Range 0064-0064
    IRQ 01

    Conflicting device list:
    Input/OUtput range 0060-0060 used by:
    Alps Touch Pad

    Input/Output range 0064-0064 used by:
    Alps Touch Pad

    IRQ is the only one that is free.

    I tried everything from deleting driver and restarting the computer. I even ran the
    sfc /scannow without help and it didn't do anything. I even try to update the driver without success.. Windows says I have the latest driver.

    This happened as I was using combofix, and it started deleting some files.. and now my keypad is dead. My mousepad works fine, as long as i don't touch the keypad.. as soon as any key is touched, mousepad freezes also.. I have to use function escape to put computer in hibernating mode and restart the computer to access my mousepad again..

    Any help would be appreciate it.. thanks..
  2. gw157

    gw157 TS Rookie Topic Starter Posts: 35

    It seem my registry got corrupted during virus removal. Anybody know how to tweak the registry to get my keypad back? Thanks..
  3. JamesP

    JamesP TS Rookie Posts: 29

    Does the keyboard work when you tap F8 on startup to go into safe mode ???
  4. gw157

    gw157 TS Rookie Topic Starter Posts: 35

    it responds to f8, but problem ersist in safe mode
  5. gw157

    gw157 TS Rookie Topic Starter Posts: 35

    Finally fixed it..

    for anybody with the same problem, so goto another computer with same OS, goto regedit, and import the registry file of HKEY LOCAL Machine - system - control - class - 4d36e96B- etc.... Export that to usb drive..

    Bring the file to affected drive, run the regedit... and import the fie...it will imbed the apporpriate file, and instant fix... took me 3 days to figure it out.. worse than a needle in a hay stack... whew..
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...