Need help, restore points are disappearing every time I reboot

By Razer ยท 6 replies
Apr 6, 2012
Post New Reply
  1. I'm using windows 7 Home Premium SP1

    There is problem, after I clean up my system from virus and malware. I found out my restore point is deleted after rebooting..
    When I create system restore point manually, it's succeed, but after reboot/restart/shutdown, when I check system restore point, there is no system restore point available.. did anyone know how to fix this? please help me..
  2. khill0930

    khill0930 TS Rookie

    What software did you use to remove the viruses/malware? Deleting restore points is something that unwanted software will often do, it sounds like, your AV didn't successfully remove the virus/malware. Try DLing and scanning with Malwarebytes and Superantispyware (both free)
  3. Razer

    Razer TS Booster Topic Starter Posts: 126   +14

    I'm removing malware from the guidance of a helper from this forum, section virus and malware removal, the helper said that my computer now free and clean from malware.. all the restore points purposely deleted using OTL to prevent me clicking restore point that still infected.. but, the person also said and sure that OTL must have make a new restore point after cleaning.
    When I tried to create it manually, it's succeed, but deleted after rebooting/restart/shutdown my pc.
    After googling, it seem that this kind of issue not only happen to me, others as well, and some said that this is also bug from windows 7 too.. I've tried several instruction from other forum, but still not work. Do you have any idea?
  4. khill0930

    khill0930 TS Rookie

    How much disk space do you have available? Windows will clear out restore points in attempt to make new ones if you're close to full. If you've got plenty of space, open up command prompt as administrator and type:

    VssAdmin list shadowstorage

    To check how much space is being allocated for backups. If you're near the max amount allocated, you can type:

    VssAdmin resize shadowstorage /On=C: /For=C: /Maxsize=20G

    (20G was just an example, use an amount that leaves plenty of space for it)
  5. Razer

    Razer TS Booster Topic Starter Posts: 126   +14

    Sorry, recently I got very busy.. I've done this before, it's not work.. after I type the command (I run cmd as administator), it said:
    "error, the shadow copy provider had an unexpected error while trying to process the specified command."
    Any idea what does it mean?
  6. Doctor John

    Doctor John TS Enthusiast Posts: 204   +15

    I would suggest that you make sure "Volume Shadow Copy" service is running (Search "services.msc", click on services, scroll down to Volume Shadow Copy, set startup type to "Automatic" and start it manually for good measure), it might have been reconfigured by malware?
  7. Razer

    Razer TS Booster Topic Starter Posts: 126   +14

    after I googled, I found one way to fix it: turn off hyberfil.sys and disable virtual memory, restart then reactivate again.. now, I can create restore point and won't disappearing after reboot/restart.. but, still when I follow khill0930's instruction, the symptom still persist..
    Then, I make sure Volume Shadow Copy startup type is set to 'automatic' and I run it manually.. (previous setting startup type is set to 'manual')
    Many thanks to both of you for giving me some instructions, for now the problem is solved but I'll watch the condition for awhile.. :)

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...