New Realtek Drivers Wont Work

By eldanio ยท 7 replies
May 14, 2007
  1. Hi, well i recently bought a new laptop. It's been working fine, no problems. But as i've just noticed recently when plugging in headphones or a lineout the sound on the laptop speakers remains on but the line out sound still works okay.
    I've tried fiddling with the sound settings but to no avail, so i tried updating the drivers realising the ones i had were really old, now i've tried all the drivers up to the latest release, 1.66 i think, and none of these work. With the new drivers the sound stops working altogether, but i do get the option to mute speakers when a line out is connected. Ive had to revert back to driver 1.40, thats the latest ive managed to get working, but this version doesn't have the option to mute the speakers so im back where i started.
    I don't see why the new drivers will not work at all.

    The onboard sound is a Realtek High Definition ALC885. And im running Windows XPSP2. The soundcard is obviously working as i am getting sound in all available programs and in windows, the problem is just when using headphones or a lineout as the speakers remain on, or when using a newer driver than 1.40 as there is no sound at all.

    Any help or clues to why the problem might be would be much appreciated. Thankyou. Danie.
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    What is the mobo and is it a name-brand comp or a u-built?
  3. eldanio

    eldanio TS Rookie Topic Starter

    im not exactly sure its one of those cheapy uknown brand laptops, the people who make the laptop are uniwill. Thats the link of my laptop though i got the laptop off some other re-seller,

    But i know it runs a intel core duo T5500 1.66 ghz and a Nvidia 7600 go, 2gb DDR, so it seems to be one of those generic specs for the unknown makes.
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

  5. eldanio

    eldanio TS Rookie Topic Starter

    I have done, the audio driver they have on their site is the same one i have on disk that i got with the laptop, the audio driver is just a realtek one and its an old driver, yes it works but its just the original problem, speakers still wont turn off etc, the driver they have for download is actually 1.28 which is very old, the one i have is 1.40 which is the latest driver ive managed to get working, but all the later drivers all support my chipset, ALC885.
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    A couple things - have you got the latest mobo chipset drivers installed?

    Have you checked for bios updates that may affect your audio?

  7. eldanio

    eldanio TS Rookie Topic Starter

    ive installed the latest chipset drivers off the site, and the moboard bios is actually newer than what they have on their website, i think they have 2.03 and the bios on this is 2.07 :suspiciou
  8. CCT

    CCT TS Evangelist Posts: 2,653   +6

    You should maybe contact them - it seems strange that you could have a newer bios than the site that provides them has, ya know!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...