New SATA Drive not detected in Windows

By Dreamworker · 30 replies
Jun 26, 2005
  1. Hello everybody, I'm am having a problem getting WindowsXP to detect my newly installed WD 250GB SATA Hard drive. I have all the latest patches/fixes/upadates and service pack 2 installed. The drive shows up in BIOS but when Windows loads up, the drive does not show up in My Computer. It's also not present in Disk Manager nor Device Manager. I have an Intel D865GBF mobo with integrated SATA controller ports with all the latest drivers installed. What could be the problem? If anyone can help I would greatly appreciate it.
  2. IronDuke

    IronDuke TS Rookie Posts: 856

    SATA needs to be enabled in the bios.
  3. Dreamworker

    Dreamworker TS Rookie Topic Starter

    It is.....
  4. Dreamworker

    Dreamworker TS Rookie Topic Starter

    Anyone else???
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You need to partition and format all new hard drives. Right click My Computer->Manager->Disk Management
  6. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Aren't you supposed to enter the SATA BIOS (even if you're not setting up a RAID array) before it is available in Windows ?
  7. Dreamworker

    Dreamworker TS Rookie Topic Starter

    Like I said in my first post, the drive doesn't even show up in Disk Manager. The drive has already been formatted to NTFS. But Windows still does not recognize it.
  8. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    How was it formated if Windows can't see it ? 3rd party utility ?
  9. Dreamworker

    Dreamworker TS Rookie Topic Starter

    Yeah I ran Windows2000 install, it recognized the SATA drive without having to do the F6 thing. I then formatted the drive to NTFS. My XP install also recognizes the SATA drive.

    So that's how I got the drive formatted. But when I have XP up and running on my PATA IDE drive, the SATA doesn't show up anywhere.
  10. djforeman

    djforeman TS Rookie

    On my ASUS P4P800-E mb, my SATA (non-RAID) appears in XP Pro Devmgr as an ATA drive. No indication of SATA anywhere. The BIOS handles it through the ICH5R Southbridge interface. The drive operates as my boot drive, **BUT** it is running at 3.5 KILObytes/sec (per SISioft Sandra Standard).

    In BIOS, I have the SATA configured as S-ATA (not P-ATA).
  11. Dreamworker

    Dreamworker TS Rookie Topic Starter

    I'm still trying to figure it out. It still hasn't began to work.

    Does anybody else here have XP running on an PATA IDE while having a second SATA hdd as a storage drive working properly??
  12. Dreamworker

    Dreamworker TS Rookie Topic Starter

  13. IronDuke

    IronDuke TS Rookie Posts: 856

    How about taking the PATA out and seeing if the SATA is recognised. Then you could install Windows on that. When this is done you should be able to put IDE back set as the boot if so desired. Then go from there with what suits you.
  14. Dreamworker

    Dreamworker TS Rookie Topic Starter

    I already tried that, the SATA drive still doesn't show up anywhere when running Windows on the PATA.
  15. IronDuke

    IronDuke TS Rookie Posts: 856

    If you've taken the PATA out Windows will not be running on it.
  16. Dreamworker

    Dreamworker TS Rookie Topic Starter

    I would like to have it so my system runs the OS from the PATA, and have the SATA as an additional storage drive.
  17. IronDuke

    IronDuke TS Rookie Posts: 856

    I see that. This is your problem it is not working. It could be some conflict between the two. Maybe motherboard or the drives. I'm suggesting you remove the PATA, it can be put back and all will be as is. I was considering getting the SATA running, this will eliminate a duff drive for one. After it is found to be working you can put the original drive back and boot from it. Then if all is well and the SATA is showing up with partitions previously created, they can be reformated and you have achieved your goal.
  18. Dreamworker

    Dreamworker TS Rookie Topic Starter

    OK well I tried all of that. The one and only thing is that when I run Windows XP Sp2 from my PATA with the SATA hooked up as well, the SATA does not show up in Windows anywhere STILL.......
  19. IronDuke

    IronDuke TS Rookie Posts: 856

    Did you load the SATA drivers even though Windows was on PATA?
  20. Dreamworker

    Dreamworker TS Rookie Topic Starter

    When I tried loading the SATA drivers that were on my MB cd, it said Windows already has newer drivers installed. I even tried the drivers from western digital's site, same thing.
  21. IronDuke

    IronDuke TS Rookie Posts: 856

    Well that is obviously not the problem. Perhaps somebody else will come up with some fresh ideas.
  22. TH AV

    TH AV TS Rookie

    look in Device Manager

    Forget the Bios, you problem is in Device Manager.
    open Device Manager you will see a big yellow ? under Other.
    Click on it
    click on reinstall driver. you will need the driver from your Motherboard's cd/floppy for the SCSI/RAID controller
    don't let windows search for the driver, direct it to your cd/floppy
    this will fix the problem
  23. delerium

    delerium TS Rookie

    Also, and this might be a silly step that you may have already done, but if you go into your control panel/administrative tools/computer management then select disk management, does it list your drive in the bottom right window? If so, it might be as simple as assigning it a drive letter. Also, if it does list it, but no drive letter, right click on it, go to properties, click volumes, then click properties I think... it will list the drives status. (or it should) I had a drive that was set up as dynamic at one point on another OS, and XP listed it as foreign, which made it unrecognizable to XP.

    EDIT: I think Disk management is only available in XP Pro. So if your using XP home then disregard all of this.
  24. boykov

    boykov TS Booster Posts: 74

    i had a similar problem. after buying SATA ... but after poking in the serial ATA RAID utility it worked fine.... have you configured your PC so that it knows it´s using more than 1 drives .....

    to create an array check at start up what buttons to press..... for me (ctrl-f)
    there is a `bios´ for configuring the serial ATA RAID utility .. after configurin that it should work...

    at least that is how i solved my problem.... :)

    PS: since your original drive is not sata .. you have to configure the sata options of the mobo ... that is not in the mobo bios ... you have to configure the SATA controler..... what is your SATA controller... (mine is Promise 378 something)

    PS2: your MB should have a user guide on the subject....
  25. drbinks

    drbinks TS Rookie

    New SATA drive

    I had the same problem, thats how I found this post. However I have managed to solve it and thought I would register and tell you how I did it.
    In the BIOS setup goto "Integrated Peripherals", select "OnChip IDE Device", now my "SATA Mode" was set to RAID, so I changed it to IDE and saved the config. Not only does windows detect it now, but Acronis Migrate Easy also does :D

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...