No Power to PC but green LED lights up on Motherboard

By rabch23 ยท 13 replies
May 27, 2008
  1. I have a PC that im am getting no power to what so ever however there is a green light on the Motherboard. I took the Powersupply out of a working PC and swapped them and got the same results. Please someone have had this before and founda cure, i really need the computer up and running.

    Thanks for any help
  2. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    If you get no response from the system at all, perhaps try reseating everything or booting with only the CPU, one RAM module in the first DIMM slot, your motherboard and the appropriate cooling apparatus.

    If you can't get a response with those four components I'd, one, is obviously defective. Since you know it isn't the PSU, given your symptoms I would bet my money on a defective motherboard (despite that green light heh).
  3. rabch23

    rabch23 TS Rookie Topic Starter

    Thanks for quick reply, i do appreciate it. ok now for a stupid question, how do i determin the motherboard type so i can search for a new 1, i know it is an intergrated 1 but thats about it
  4. Matthew

    Matthew TechSpot Staff Posts: 5,333   +101

    I wouldn't really recommend just flat out replacing the motherboard without at least reseating your components first. If you don't feel comfortable with doing that, I would find someone that is (perhaps a repair shop or a pal that knows a thing or two about PCs). If you aren't comfortable with handling the components to reseat them, odds are, you won't be comfortable with swapping out your motherboard.

    That said, post the actual PC brand and model here (Dell Dimension 3000 for instance).
  5. rabch23

    rabch23 TS Rookie Topic Starter

    It is an E-Machines 3210, Intel Celeron 2.70GHz. I am comfortable checking everything myself, well iv always shy-ed away from motherboard problems in the past when my mates have asked but now its my own so got to learn i suppose lol
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  7. sunluvindawg

    sunluvindawg TS Rookie

    hi there, i was hoping you have a solution for your problem, as i have the same problem with a customer's dell 3000, my power supply fires his machine, his power supply fires up my machine, his hard-drive is good, and i copied his files for him, he had the motherboard changed, (looks like they put the chip in wrong, when i removed it, 3 pins were bent together and touching each other, oopsss)
    so i'm guessing his cpu is shorted, and that's why i have a green mobo LED, but nothing else, aside from all that, i think his original problem was the mobo battery, but now i can't be sure, i put in a new battery just for giggles, but nothing happened, my only option now is to see if i can get him a new cpu, re-install the newest mobo, a new battery, and see if that solves the problem, but any ideas anyone might have would be a great help, ...first, because i hate to give up, second he can't afford a new 'puter, and third, he needs it to run his business.
    i hate to lose, especially over something like this.
  8. rabch23

    rabch23 TS Rookie Topic Starter

    Hi there, i have managed to solve my ploblem. In the end i replaced the full motherboard and that has solved it. i got a mate o mine who now has hos own PC repair shop to test it and that was apparently the problem. hope you manage to solv yours
  9. sunluvindawg

    sunluvindawg TS Rookie

    thanks there friend, i'll try that...

    hey buddy, thanks for the reply, i had a feeling after dell support said they'd give him a new mobo, that that was the problem, unfortunately, the guy who installed the new mobo was not "savvy", ya' dig? so he inserted the processor with the wrong orientation, and when i took it out, i noticed that 2 or 3 pins were bent together and touching, and i guess he tried to power it up, and got nothing, (frying the cpu in the process)... which is where i'm at now with the thing, but have no fear, a friend of mine has a "puter for 30 bucks, and with that, i'll piece together a new working unit in a day or two, i know his h/d is good, and his p/s, so, i'll just use those and transfer his 2 dvd w/r'ers and get him up and running before long, but i do very much want to thank you for your time, and interest in my problem, and help with the solution... i'll let you know how i made out in a day or two, ok?
    thanks again from lil' ole' east tennessee
  10. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Since this got bumped, I'm going to give a little PSA :)

    Just because the green light on the motherboard lights up, or the NIC lights up does not mean that the power supply is good (or the NIC if that is what you are troubleshooting). It is not uncommon for a PSU to be 'dead' but still deliver enough power to light up a tiny LED.
  11. sunluvindawg

    sunluvindawg TS Rookie

    thanks sngx1275, i thought it was a dead p/s, but it worked in my computer, , although you're probably right about one thing, his p/s wasn't an exact match for mine, it did fire and run my machine flawlessly, but how can i be sure it'll fire and run his machine without some unseen problem, anyway, a friend has a working unit for 30 bucks, and that'll do to solve his problem for now, i can build him a working machine out of all the spare parts...
    thanks again for your time and help....
    i'll let ya'll know how it goes....Pray4Peace...Out...Rich
  12. Covn

    Covn TS Rookie

    Sorry about resurrecting this thread, but this sounds like the exact same problem i started having last night.

    So I bought some new components the other day and everything went very well installing the stuff. Now, after days with moderate overclocking, my pc just dies. After several hours of attempting anything from a cmos reset to leaving the system unplugged for a while, i am unable to even start the thing up. The LED on the motherboard is on, bit as i understand it, the PSU is still able to deliver enough power even if its busted to light that.

    Im running the following:

    p5q motherboard
    q9300 quadcore cpu
    Corsair TWIN2X 6400C5DHX DDR2, 4096MB

    Hope someone can help. This is extremely frustrating. Im very uncertain what might hav caused this.

    Thanks in advance.
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  14. Covn

    Covn TS Rookie

    My PSU not a stock one. 550w although its about 5 years old

    Installed a new PSU, problem solved :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...