Page_Fault_In_Nonpaged_Area and BAD_POOL_CALLER

By Nateious
Jun 14, 2007
  1. Hi all,

    I'm getting 2 BSODs that I can't figure out and are driving me nuts, I get the Page_Fault_In_Nonpaged_Area most often and every once in a while i get BAD_POOL_CALLER.

    I am almost certain these are driver related as the entire thing happened after I had some issues with my soundcard (Audigy 2 ZS) drivers and reinstalled them. A bad uninstall of the soundcard drivers was causing my PC to lock up (mouse still worked but ctrl alt del didn't and the system never finished booting) every time I logged in and I had to reboot several times before I fixed the issue, I'm assuming during these multiple reboots some driver because corrupt but I can't figure out which one... I've since uninstalled, ran driver cleaner pro and reinstalled them so I don't think its the soundcard drivers anymore.

    I would have more than 2 minidumps but for some reason when I turned the machine back on today the old ones were missing. I do have the debuglogs from the old ones though. I've never actually checked these before, so I followed the instructions I found on this website.
    Hopefully those are correct so if I'm reading them correctly, the old ones point to fwdrv.sys which is part of Sunbelt Kerio Personal Firewall, I uninstalled that and the newer dumps just point to ntkrpamp.exe.

    I've already run memtest it had 11 passes with no errors when I left work this AM but someone turned it off during the day so I don't know if it eventually found any. I've already scanned for viruses and spyware, I'm pretty good (at least I think so) at keeping my system clean and I've never had any problems with either of those before. I've uninstalled and reinstalled Kerio, AVG, my nic drivers, and my sound card drivers.

    The BSODs were very predictable, they only seemed to happen when I 1) had ventrilo (a VoIP program) running, and connected to a server (any server works either on a remote machine or my own) and I try to open windows explorer (with winkey + e shortcut though I never tried launching it any other way I assume that it would yield the same results) Sometimes it would crash on the first attempt to open explorer sometimes it would take me hitting windows + E key a few times to BSOD but it was basicly 100% guaranteed to BSOD if I did this.

    After I uninstalled Kerio and still BSODd the next thing I did was google ntkrpamp.exe. I found a windows update patch for dual core procs that either changed or replaced the file with a newer version, so I grabbed it and ran it hoping to overwrite / fix any possible corruption. This seemed to work as my BSODs stopped I could open as many windows explorers as I wanted, hitting the Win + E key multiple times did nothing. I was very happy and I started to download Kerio again when it finished I clicked on open in the firefox downloader and that caused another BSOD. When I got back into windows I tried the Win + E with vent running and it crashed again so after Kerio was installed it started crashing again. Unfortunately for some reason windows decided to try to write a full dumpfile and my swap file on my primary partition isn't big enough to fit it so it was corrupt.

    About the only thing that is consistent is that Ventrilo has been open each time I've BSODed (and yes I've already uninstalled and reinstalled it, multiple times)

    I've also run chkdsk (no errors) and a defrag (only on primary drive though)

    I've uploaded the 2 minidumps I still have and 4 debuglogs (in order from newest to oldest) (the last 2 I believe are from the 2 minidumps)

    Machine Specs
    AMD 3800+ X2
    2GB Corsair RAM
    Primary Drive 300Gb SATA Seagate Drive
    XFX 7900GT
    Realtek RTL8169/8110 Gigabit Ethernet Adapter
    Creative Audigy 2 ZS

    Sorry the post is so long but I wanted to make sure I covered everything.

    Thanks for any help that can be rendered
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...