PC shut off last night and won't load past BIOs splash

By ggmypc ยท 4 replies
Dec 14, 2017
Post New Reply
  1. My mobo is a Gigabyte
    My PSU is a corsair ax850
    My GPU is a PNY Nvidia 1060 GeForce
    I'm not the best with PCs but heres what I've tried
    The start up takes me to BIOS splash page but wont go past it or even into bios.
    1. Tried to take out GPU and boot without it connecting monitor via motherboard. It booted windows just fine.
    2. Reset cmos, still doesn't load past BIOs splash with GPU.
    3. Took out extra RAM sticks, nope.
    4. I checked all the fans and everything works fine

    There is one light on my mobo that is red that is by the slots for GPU, I read it might be something to do with voltage issues but everything I read wasn't very clear on what to do.
     
  2. holdum323

    holdum323 Banned Posts: 1,725   +453

  3. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,402   +863

    If I suspect a video card, I take it out and try it in another system.
     
  4. ggmypc

    ggmypc TS Rookie Topic Starter

    Yeah, I'm gonna go try it out tomorrow and see if it works in a different PC.
     
  5. Montana

    Montana TS Enthusiast Posts: 35   +15

    If it loaded fine with the integrated graphics card the PCI version is bad.
     

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...