Problem Installing GAIM!

By young&wild ยท 12 replies
Nov 14, 2003
  1. I have just installed Red Hat 9 yesterday after almost 2 years of hesitation. I went online to download XChat in RPM package form which is pretty friendly.

    The trouble came when i decided to replace the existing version of GAIM(0.59) as it seems to be pretty old and doesn't support MSN. Did the same thing downloaded a RPM package which i m very sure is for Red Hat 9 as it contains i386-RH9 in the file name.
    Double clicked the package and the package gets extracted but the prompt telling you the size of the program to be installed did not appeared. Instead the window suddenly vanished.

    My question is do i need to install something else? Please be patient with me, I am a newbie to Linux and don't know anything about UNIX coding.

    Thanks for the help!
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Pretty GUI things for system administration are evil.

    Open command prompt and run 'rpm -q gaim'.
    It tells you what version of GAIM you have installed. If it occurs that your double-clicking the package didn't work (it reports the old vesion), go to command prompt, navigate to the directory you downloaded the package to and run 'rpm -U gaim-package-name.rpm'

    BTW, if you want to use MSN, take a look as AMSN
  3. young&wild

    young&wild TechSpot Chancellor Topic Starter Posts: 993

    Thanks for the help Nodsu. I have just tried the command you have given me. It works, but i get the following an error that the following are needed for the gaim installation package.

    Are these extra files i nd install?
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You need to install gtkspell package (well, actually you don't need it, but things will get dirty). Get it from

    I think you made a typo in the libtk file name needed, but I'd bet you need to install/upgrade the tk package. is a good place to resolve dependencies. You just type in the file name needed in the search and it returns the packages that supply it. Then you just look up the package for your Linux flavour.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You've encountered package dependencies. Now witness what everyone hates about Linux (including me!)

    Find the rpms for GTKspell and tk, I think they are called.

    You can find rpms from

    Install the two extra rpms first:

    rpm -Uvh packagename.rpm

    I don't know which one you will find you need to install first. Anyway, if they both install fine, try the above command again, this time with gaim.

    The problem is that maybe you will try to install one of the dependency rpms, only to find that that does not have its required dependencies as well. Now, you see here the potential for a kind of endless, recursive process, where basically you are screwed.

    Good ways to help these things from being a problem:

    1)Do a complete, full install of red hat from the start,

    2)Install XIMIAN GNOME, so that you get Red Carpet, which automatically handles downloading the rpms, and their depencies, installing them, keeping everything up to date, etc. Its MUCH better.

    3)Try installing things not by using RPMS but by downloading the actual source code (its a package.tar.gz file) and then extracting it, and manually compiling it. This is not as hard as it sounds.
  6. young&wild

    young&wild TechSpot Chancellor Topic Starter Posts: 993

    Thanks alot Nodsu and P66. I have managed to install the new GAIM package. I m now into configuring it.

    I have to agree too that i hate rpm package dependencies. But anyway its pretty fun as well.

    I have tried to install things from tar. But i m still leaning. Extracting isn't a problem now., it just compiling. Learning to compile is my next task.
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Heheh, compiling is easy! Getting the compile to go through without errors (damned stupid lazy programmers) and a working result (see above) is much worse :p
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    make install

    that's how you install about 95% of things from source code. In fact, if you start with the tarball, then its just:

    tar -zxvf package.tar.gz
    cd package
    make install

    There you go. No problems! (Until there IS a problem, then you need to know what you are doing....)

    You'll be fine. Stick at it. Don't give up. Keep going back to it. Post here if you are really stuck, but ideally you should try to look at problems seriously yourself first.

    That's a bit of a sweeping statement! (No offense, of course... ;) )

    OK, we should be a lot less tolerant of compile time errors than run-time ones, but compile time errors still do happen when we are trying to compile complex code on systems that differ greatly. Generally, though, compile time problems happen because of missing dependencies, problematic system settings, etc.
  9. young&wild

    young&wild TechSpot Chancellor Topic Starter Posts: 993

    GAIM is working fine with MSN for now.

    I just compiled a sourcecode, for the first time in my life yesterday. It is actually a plugin for its working flawlessly.

    I won't hesistate to ask around if its a very hard problem. Anyway i have the irc channel to bomb questions with incase of minor problems and a ebook to guide me.
  10. mhowlett

    mhowlett TS Rookie

    Problems Compiling... I think

    Hey, this is about the same thing that this thread is talking about. I'm trying to install Gaim as well and ran into the same problem as the other guy. However when I tried to install the gtkspell as a .tar.gz file... and install it using the commands that u gave later on... I ran into the following error message:

    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.

    what does it mean?
  11. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You don't have basic development tools installed. The exact package names will depend on your specific Linux distribution but you want to install thngs like gcc and gcc-c++

    And do install those using the official package management system of your distro.
  12. mhowlett

    mhowlett TS Rookie

    My distribution is Red Hat 9.0 and how exactly do I install the gcc and gcc+ etc... and other compilations have worked fine... why is it only this one that screwed up
  13. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    What compilations?

    As a simple test, try running "gcc" from command line. If you have it then it should run and complain.

    You can use the software installer thingy or set up yum or apt-get. Yum would be the best choice I guess.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...