Problem moving from IDE to SATA HDD

By billham ยท 15 replies
Mar 21, 2008
  1. Apologies as any solutions may be buried in these boards....

    Trying to move from an 80G Maxtor IDE to a 300G Seagate SATA. Tried Seagate's DiscWizard as well as PartitionMagic8 but when I try to reboot onto the new drive, I get "operating system not found". Even giving up and trying to reformat the new drive with a new install of Windows gives the same message.

    I finally found my mobo CD with the 32 bit SATA driver (I thought) and made a floppy with the disk maker application (ASUS P5NSLI mobo). After the reimage attempts, I try to load Windows setup, pressing F6 and loading the SATA driver. Attempting to repair Windows with the repair from the main menu and running FIXBOOT and FIXMBR from the Recovery Console don't work. I finally gave up and tried a reinstall of Windows, loading the SATA driver at setup. After loading that, reformatting the drive and the file copy, Windows setup an "operating system not found" message.

    The new drive is on the #1 controller. I'm missing something basic here....wrong SATA driver?......but this one's off the CD!
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Did you use Partition Magic to fully remove the partition first ? Then allow Windows setup to define its own partition size?

    I know that you used PM before that, but what about just before the new install of Windows.
    Note: Installing Windows clean, is pretty quick, if you want to try again (No Partition)

    Hear back from you in about half an hour then !!
  3. billham

    billham TS Rookie Topic Starter

    When I did the reinstall (just about an hour ago), I deleted the existing partition and emptied the drive. Then I let Windows setup make the partition and then even slow-formatted the drive. It took forever but it IS my box.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Can be the sata cable or the IDE cable in the DVD drive. Is that set for CS (Cable Select) and probably unplug the floppy or any other 2nd DVD drive or 2nd Hard Drive
  5. billham

    billham TS Rookie Topic Starter

    I'll check the setting on the DVD drive. I need that and the floppy drive connected to do the setup. Right now it says to "Press a key to boot from the CD..... (and if I don't press a key).....missing operating system"

    If it's already done the boot part of the setup, I can unplug the floppy drive and DVD drive to give it only the HDD to boot and see if it uses it....
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Oh yeah, you need the floppy. Anyway you got the point. Just unplug stuff and disable any non needed things in CMOS
  7. billham

    billham TS Rookie Topic Starter

    Now just "missing operating system"

    I'm thinking that I'm loading the wrong SATA driver(?) I'm using the mobo CD and making a disk with the "32-bit SATA RAID driver"

    It see's the drive in CMOS ok.......this driver even lets Windows setup see the drive.
  8. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    You didn't overlook the obvious did you? Make sure that drive is the first hard drive the BIOS looks for to boot the OS.
  9. billham

    billham TS Rookie Topic Starter

    Been working in the field long enough that no suggestion, no matter how basic is wrong.

    I've checked and the boot order is set to floppy, CD-ROM, the HDD. It boots to "Press a key to boot from CD", so it's reporting its attempt to boot from CD. But then I get "missing operating system" (I think) from its attempt to boot from the HDD.

    I'm wondering if my partition size isn't bootable now........
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Try a different CD drive
  11. billham

    billham TS Rookie Topic Starter

    Ok, I tried another CD drive and get the same result......

    Let me refresh what my problem is setting up WindowsXP Pro on this SATA drive.

    The drive is plugged into the SATA1 controller. I boot on the Windows CD and it runs setup. Formats the drive and then copies files. At that point it asks to reboot. After rebooting, I then get a message to "press a key to boot from CD" If I boot from CD, it runs the same setup over again and asks to reboot. It will continue to ask to boot to CD and run the same part of Windows setup if I continue to "press a key to boot from CD".
    I want it to boot from the hard drive that it's just copied Windows setup files to. If I don't "press a key to boot from CD", it just gives me a cursor and doesn't boot from the hard drive or gives a "bad or missing operating system" message.
  12. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    'Missing operating system' is ONLY caused by one thing - your motherboard cannot detect a valid boot sector on your drive.

    Since you've successfully managed to finished the first part of the XP setup, that narrows down the possibilities a whole lot. The setup was able to write files and therefore, your drive DOES have a valid boot sector. This HAS to be a hardware or configuration problem, and chances are it isn't hardware.

    Also, this cannot be a driver or Windows problem. It almost HAS to be related to the boot order, so you need to step back and take a look at it again with some fresh eyes. :)

    I know you've probably already checked about 945 times so far, but verify that 'Hard drive' is indeed the correct option. For example, it appears that your board has configuration options that allow you to configure 'Hard drive' to use certain drives in a certain order. This configuration probably does not specify your SATA drive first and this is the reason you cannot boot. Please check your manual for more information. Chapter 2-40 - PDF BIOS manual (right click and save as)

    Also, for troubleshooting purposes, you may want to try your board's boot device selection manu. You can bring up by tapping a certain key during the BIOS screen screen. F8 is used for a lot of Asus boards, but it could be F10, F12 or something else.

    This menu lets you manually select the device you'd like to boot to. If it DOES boot, then that confirms your boot order is incorrect.
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'm pretty sure CPU and/or Ram can do this. Start with Ram (!)
  14. soulkolektor

    soulkolektor TS Rookie

    i have been trying to do the same thing for about 6 months now. nothing seems to work, nobody seems to know what the problem is. i get the same messages. im just about burnt out with this and im ready to give up. my next option is to have a PC shop transfer the files from my 80GB IDE to my external HDD.
  15. soulkolektor

    soulkolektor TS Rookie

    that is if they can do it :)
  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Yes they will ghost image it. That'll work
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...