Problem with router setup

By Will40 ยท 68 replies
Dec 21, 2011
Post New Reply
  1. Guys,

    Having an issue with setting up a new router on my PC. I simply cannot get onto directly from my PC to configure the router!

    I'm running XP Pro, and I currently use the Huawei E122 dongle for internet access. I purchased the Sapido GR-1733 router which will allow me to put the dongle in the USB port & set it as the WAN access. (I still have the dongle plugged directly into the PC for Internet access at the moment.)

    I initially had issues with setting up an IP address getting the issue but have managed to sort that now via PortForward Static IP amongst other things!

    My problem is when logging onto to set up the router, it times out most of the time.

    I can ping, which is the built in Intel Pro/100 NIC, but when I ping sometimes it times out, other times it has no problems, and other times it will lose 1 packet! However, it NEVER gets me to the config area, the furthest I've gotten is to the username/password screen.

    When running ipconfig /all it currently shows up the following:

    Ethernet Adapter Local Area Connection:

    Connection-specific DNS Suffix:
    Description: Intel Pro/100 NIC
    Physical Address: (gives MAC Address)
    DHCP Enabled: No
    IP Address:
    Subnet Mask:
    Default Gateway:
    DHCP Server:
    DNS Server:

    I currently have the TCP/IP Properties manually configured, as when I had the 'Obtain IP address automatically' clicked, it would give me the 169.254 etc address which I believe is a DHCP issue, but am not 100% sure at the moment.

    However, as it is also a wireless router, I can connect to the router config screen via my iPhone, and have set the router to DHCP server but this hasn't helped at all.

    Finally, the ethernet cable is brand new and when I plug it in/out the Network Connection recognises it so I don't think the cable is the issue. (and have tried different e/net ports in case that was an issue). I've reset the router, powered on/off, disabled firewall etc all to no avail.

    At this stage I'm completely flummexed!!

    I don't have another PC to try it on in case that is suggested!

    Appreciate & and all help!

    P.S. I should add that both my 3G and NIC card IP are both Static IP's.
  2. wrt54gs7

    wrt54gs7 TS Enthusiast

    Have you tried obtaining IP automatically with your iphone? Does the phone get 192.168.1.x address? If it does, you may have a problem with your NIC.
  3. Jawshh

    Jawshh TS Enthusiast Posts: 392

    You need to enable DHCP then ipconfig/all. You will see default gateway-that's the router's address. Put that address in your browser and configure the router.

    Windows uses a address when it can't get an address from DHCP, so, if you don't get a valid address and gateway, your router is probably broken.
  4. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    Setup the port forwarding and static addresses LAST.

    Put the system back on DHCP (leave the DNS if you like) and disconnect / reconnect the cable to the router.

    use the url to access the router cfg and use the user/password to login.

    set the DHCP range to

    setup any WiFi you need

    change the login password and save the settings (which should force a login again).

    Pick a static address above the DHCP range (say for the system needing port forwarding and set that into the router.

    IF your router will support Address Reservation, take the Physical Address of the NIC (also called the MAC address),
    and set that so MAC -> reserves

    save the settings and log out

    Now disconnect and reconnect the cable to the router and you should see
    the address as and everything should run again
  5. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Thanks for the replies guys.

    Answers to Q's:
    wrt54gs7 - iPhone did get ip address of at one stage, but not sure how that's relevant to NIC issue?

    Jawshh - don't think router is broken as can get setup via iPhone. Have spent LONG time researching 169.254 issue and think I have resolved that as below. I'm familiar with ipconfig /all settings (pic below). Routers address is

    jobeard - If I put the PC back on DHCP (TCP/IP Properties>Obtain network address automatically), Network Connections tells me I've Limited or no Connectivity and it puts me on the 169.254 range when I run ipconfig /all!

    Attached are a few pics of setup
    On PC


    From iPhone:


    WAN Setup


    LAN Setup


    Appreciate the help guys!
  6. wrt54gs7

    wrt54gs7 TS Enthusiast

    So the router (dchp server is ok). Now the problem lies is within the OS, settings or drivers of your nic. Try running "sfc /scannow" in command prompt, then disable enable your lan (make sure to auto-obtain ip) or update your drivers or windows.
    You are setting up a new router right? Was your pc previously connected to a network?
  7. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Yep - new router. First time setting one up, stand-alone home PC, never connected to any network before. I've tried updating (built-in) NIC, and am being told this is latest driver.

    Currently running sfc scannow.......& will reply with results....
  8. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Have double-checked driver update on Intel site as opposed to direct from Windows & there is an update, but has made no difference after rebooting machine.

    sfc scan came up with nada also!
  9. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    The DHCP problem for 169.* is caused by
    NodeType . . . unknown (should be Hybrid)

    see this post for the fix

    @wrt54gs7: sorry-there's nothing wrong with the system; it's all in the settings for networking
  10. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Yes, NodeType....unknown jobeard, however, no key called notype in the registry (have also done a search for it, but nothing!). I can add it in as an entry but unsure of exactly what to put - also I presume the entry of 8 is decimal?

    (sorry about size of pic!)
  11. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    Dec 8 = Hex 8 so it doesn't matter. The post cited shows the registry path and yes, you need to add it Exactly as shown (upper/lower case spelling).
  12. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    OK - now set up as Hybrid!

    However, having exact same issue as other user you have been helping in your post when ipconfig /all gives reading. When set to Obtain IP address automatically, it says Limited or No Connectivity......

    NIC already set to 10Mbps Duplex...
  13. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Have accessed router via iPhone again, and disabled, then re-enabled DHCP server to see if it would do anthing helpful. It hasn't...!!

    Has now reverted back to 169.254 ip address with subnet mask as

    Does this make sense to you jobeard?
  14. wrt54gs7

    wrt54gs7 TS Enthusiast

    No need to be sorry, lol.

    @Will40 I once have this kind of problem with my old nic.This occurred while using crossover cable (pc > switch port of router), fixed by using straight thru cable.
  15. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    @wrt54gs7 - Only just bought cable - how can I tell difference in case it IS the wrong type!!?
  16. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    verify your firewall is active (which are you using).

    The FW needs to allow ports 67-68 UDP inputs
  17. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Using Comodo Internet Security. There is a sub-section 'Port Sets' under new Network Security Policies, but only lists http, pop3/smtp, and privileged ports....

    Found the rule setting (there are multiple choices for each)

    I need to choose:
    Source Address
    Destination Address
    Source Port
    Destinantion Port
  18. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    • Source Address = ANY
    • Destination Address = ANY
    • Source Port = ANY
    • Destinantion Port-RANGE 67-68
    • Type = UDP
  19. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    Definitely getting somewhere jobeard! :-D

    ipconfig /all shows router under 'Connection-specific DNS Suffix' heading, and DNS Suffix Search List, DHCP & Autoconfig both enabled, DHCP & DNS Server point to router IP address.

    However, still can't get either FF or IE to open url!!

    Edit: Actually, Login in page just surfaced, just taking very long time surprisingly
  20. Will40

    Will40 TS Rookie Topic Starter Posts: 55

    No - it's gone again. We're back to 169.254 addressing.

    I rebooted after amending the UDP rule as I hadn't got it in Global Rules, I had it in Predefined Policies. I've no idea what happened.....

    EDIT: Man this is annoying! I set up a network zone in the firewall with & as an IP4 Subnet Mask, network connected & ipconfig back as earlier. Do I need to change these settings?

    Thanks for your patience & help jobeard - really do appreciate it!
  21. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    a) Never noticed if you're on Vista or Win/7 - - Which?

    If either, google disable ipv6 and apply the Fixit for your system; disable ALL & reboot.
    If XP, ignore.​

    b) disconnection from the router (ie: pull the RJ45 out),
    disable Comodo
    enable the windows firewall
    reconnect to the router
    wait 30 secs; and rerun ipconfig /all

    now try ping
    and also ping​
    if the IP config is good AND both pings work w/o timeouts, then COMODO settings are the issue.
  22. wrt54gs7

    wrt54gs7 TS Enthusiast

    @Will40 The fix is only good for older nics and routers. To check if it is straight or crossover cable, place the two RJ45 end points of the cable side by side (where you can clearly see the copper contacts) the wires are color coded, if the first two wires (left to right) have the same colors (compare with the other RJ45) they are straight cable otherwise it is a crossover calbe.

    Have you tried disabling the firewall entirely? Can you ping the router (without timeouts) or access its web-interface without delays? Make sure internet explorer LAN settings are all unchecked. By any chance you have another device with the same IP of your router connected the same network? Try changing the IP address of your router.

    Attached Files:

  23. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    GRRR; the 192.168.x.x Class C address ALWAYS uses a mask of
    Y E S :)
  24. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    @wrt54gs7: The O.P. doesn't need ANY VPN settings and should not require manual setup either. IMO, if the DCHP option will not run, then there are reason why
    and manual settings will not circumvent the underlying problem.

    In addition, disabling all firewalls does not say the system will run without network filtering. The best choice is to run the simplest FW (ie the windows default) until the CAUSE(S) of the problem are determined - - then to learn how to configure a better FS (btw: Comodo is excellent).

    @Will40: please avoid all manual configurations until a basic network connection can be made which will perform
    • ping by address (ping
    • ping by (ping

    With your follow-up, please provide the output of ipconfig /all again (unedited). Thanks
  25. wrt54gs7

    wrt54gs7 TS Enthusiast

    Hmm. I have not made any posts about vpn neither did I suggest any manual settings. The pc gets 169.x.x.x IP because it is unable to communicate with the dhcp server (in this case the router). Disabling the fw just simply the troubleshooting steps.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...