Radeon 9600SE - "INF Error - Video driver not found"

Status
Not open for further replies.

OsLoFrEaK

TS Rookie
Being as most people who write threads about their problems tend to leave out information which could be useful for those who are trying to help out, I'll try to write a post that includes what you need and then some instead of too little..

Hardware Specs
  • ASUS CUV 4X-E, Celeron/PIII, ATX (Motherboard)
  • Intel Pentium III 1 GHz Coppermine (CPU)
  • Radeon 9600SE (Graphics Card) - Not sure of the "mark" of this one..PowerColor or ASUS

Background Story
Well, about 3 months ago, I exchanged my old and outdated GeForce 2 GTS Graphics Card with the new and better (I thought) Radeon. Being the CS-gamer I was back then, I did this in hope of increasing my FPS-count (not a lot, just a little), but was fairly disappointed when I experienced an all-time record low FPS of 5-10 (no matter what was going on).. Also, being lazy, I decided to take this as a chance to lay off the CS-scene for some time, perhaps focusing on some other aspects of gaming and general usage of the computer.. It was just now, today, that I got the craving for fragging again…

After doing some reading, I realized that I was not the only one with problems regarding Counter-Strike 1.6, ATI and FPS. After some more reading, I decided to downgrade to Catalyst 3.6. Since I'm not the most experienced person when it comes to messing around with drivers, hardware-settings, software-this and that, I read around some more and went with the information given in this thread. I followed the advice written by BrownPaper, using DriverCleaner to remove any remains of the ATI drivers after uninstalling them.

How the problem came to exist
When downgrading to Catalyst 3.6, I followed the “readme.txt” that came with DriverCleaner on how to proceed:

ATI:
1. Unplug nic card or modem from net or disconnect
2. Remove ATI driver from add/remove programs then remove the control panel from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. On reboot into safe mode WinXP SP1/SP2 will auto detect and install drivers. Just let it do its thing. If you can cancel out of the auto install hardware wizard then skip the rest and run Driver Cleaner! If you can NOT cancel out of auto detect wizard then...
5. Navigate to device mgr->display adapter->uninstall and/or remove ATI display adapter but do not reboot
6. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
7. Run Cab Cleaner (not needed, but recommended)
8. Run Driver Cleaner
9. Empty recycle bin and reboot
10. Install the new drivers and control panel
What I think I did wrong, is that when I ran “DriverCleaner” and cleaned out everything connected to “ATI”, I cleaned out “3Dfx” as well. I’m not quite sure why I did this, don’t have the wildest clue what I was thinking, but I believe this is what went wrong.

Exactly what is the problem?
Well, when I tried to install the Catalyst 3.6 drivers (step “10” in “DriverCleaner readme”), I got two error messages:
  1. INF error. Video driver not found.
  2. Setup was unable to complete the installation. Try to setup your display adapter with a standard VGA driver before running setup.
    [/list=1]

    Picture 1Picture 2

    Since the old Catalyst drivers are uninstalled and new can’t be installed, I find myself in a rather unpleasant situation…
    I have tried installing both in normal and safe-mode.

    A friend of mine, whom tried to help, asked me to go to “Control Panel --> Display --> Settings --> Advanced --> Adapter” and tell him what was there (or something), but the problem is, there’s nothing there. When I used DriverCleaner, I remember to INF-files being removed when I used “3Dfx”.

    Picture of empty Display Properties

    What I’ve tried to fix this
    I have:
    • Installed this driver HotFix from ATI for Radeon7000/7200 series where the same error message has appeared. I figured I’d install this, hoping the “Standard VGA Graphics Adapter” would tag along with it, uninstall it and install the Catalyst-drivers. I successfully installed this HotFix, but Catalyst could still not be installed (neither prior or after I uninstalled the HotFix).
    • Installed the latest VIA Hyperion drivers, which was recommended to me by a friend as my motherboard is a VIA-chipset (what he said, I don’t know…)
    • All sorts of little things I “know of”, but who apparently does not work… :)

    Final notes
    Well, obviously, I would love some help with this as it has driven me and my friend mad. I would just like to play some Counter-Strike again, and use my graphics-card to it’s fullest (well, I know I can’t with the CPU and all the other things I have backing it up, but with this setup) without spending hours to do so… If anyone knows what to do, I’d appreciate some help. Also, I tried searching for the “Standard VGA Graphics Adapter” so I could download the driver. I was unable to find a download-location, so if your tip is to download this one, I’ve tried it and can’t find it so I need someone to upload/send it to me.

    All help is more than welcome.
    I’ll be going to bed now, tired and a tad pissed off (mainly at myself).
    In advance, thanks!
 

carltao

TS Rookie
One hint: Check whether IT IS Radeon MOBILITY!

I just met the same problem and tried many ways and can not solve it.
Later when I happened to check the product specification from its vendor page, I found out that it is a Mobility Radeon display card.
There are two ways to get mobility radeon to work on PC:
1. download official mobility radeon driver, eg, 4.12
2. get the latest ati catalyst, and use a very cute little tool to make it work for mobility radeon. The tool's name is ati dhmod. you can search google for download or contact patje@driverheaven.com.
 

BobFrank

TS Rookie
Similar problem with me, except my video card *does* show up...

I have the same inf error, then the "Setup was unable to complete installation. Try to setup your display adapter with a stan...".
 

Joawro

TS Rookie
OsLoFrEaK said:
Being as most people who write threads about their problems tend to leave out information which could be useful for those who are trying to help out, I'll try to write a post that includes what you need and then some instead of too little..

Hardware Specs
  • ASUS CUV 4X-E, Celeron/PIII, ATX (Motherboard)
  • Intel Pentium III 1 GHz Coppermine (CPU)
  • Radeon 9600SE (Graphics Card) - Not sure of the "mark" of this one..PowerColor or ASUS

Background Story
Well, about 3 months ago, I exchanged my old and outdated GeForce 2 GTS Graphics Card with the new and better (I thought) Radeon. Being the CS-gamer I was back then, I did this in hope of increasing my FPS-count (not a lot, just a little), but was fairly disappointed when I experienced an all-time record low FPS of 5-10 (no matter what was going on).. Also, being lazy, I decided to take this as a chance to lay off the CS-scene for some time, perhaps focusing on some other aspects of gaming and general usage of the computer.. It was just now, today, that I got the craving for fragging again…

After doing some reading, I realized that I was not the only one with problems regarding Counter-Strike 1.6, ATI and FPS. After some more reading, I decided to downgrade to Catalyst 3.6. Since I'm not the most experienced person when it comes to messing around with drivers, hardware-settings, software-this and that, I read around some more and went with the information given in this thread. I followed the advice written by BrownPaper, using DriverCleaner to remove any remains of the ATI drivers after uninstalling them.

How the problem came to exist
When downgrading to Catalyst 3.6, I followed the “readme.txt” that came with DriverCleaner on how to proceed:



What I think I did wrong, is that when I ran “DriverCleaner” and cleaned out everything connected to “ATI”, I cleaned out “3Dfx” as well. I’m not quite sure why I did this, don’t have the wildest clue what I was thinking, but I believe this is what went wrong.

Exactly what is the problem?
Well, when I tried to install the Catalyst 3.6 drivers (step “10” in “DriverCleaner readme”), I got two error messages:
  1. INF error. Video driver not found.
  2. Setup was unable to complete the installation. Try to setup your display adapter with a standard VGA driver before running setup.

Picture 1Picture 2

Since the old Catalyst drivers are uninstalled and new can’t be installed, I find myself in a rather unpleasant situation…
I have tried installing both in normal and safe-mode.

A friend of mine, whom tried to help, asked me to go to “Control Panel --> Display --> Settings --> Advanced --> Adapter” and tell him what was there (or something), but the problem is, there’s nothing there. When I used DriverCleaner, I remember to INF-files being removed when I used “3Dfx”.

Picture of empty Display Properties

What I’ve tried to fix this
I have:
  • Installed this driver HotFix from ATI for Radeon7000/7200 series where the same error message has appeared. I figured I’d install this, hoping the “Standard VGA Graphics Adapter” would tag along with it, uninstall it and install the Catalyst-drivers. I successfully installed this HotFix, but Catalyst could still not be installed (neither prior or after I uninstalled the HotFix).
  • Installed the latest VIA Hyperion drivers, which was recommended to me by a friend as my motherboard is a VIA-chipset (what he said, I don’t know…)
  • All sorts of little things I “know of”, but who apparently does not work… :)

Final notes
Well, obviously, I would love some help with this as it has driven me and my friend mad. I would just like to play some Counter-Strike again, and use my graphics-card to it’s fullest (well, I know I can’t with the CPU and all the other things I have backing it up, but with this setup) without spending hours to do so… If anyone knows what to do, I’d appreciate some help. Also, I tried searching for the “Standard VGA Graphics Adapter” so I could download the driver. I was unable to find a download-location, so if your tip is to download this one, I’ve tried it and can’t find it so I need someone to upload/send it to me.

All help is more than welcome.
I’ll be going to bed now, tired and a tad pissed off (mainly at myself).
In advance, thanks!
Just to le you know, Radeon 9600 SE is NOT ment for gaming. I recommend getting Pro or XT. Those are ment for gaming. XT can be around $60 while Pro can be around $45-$50
 

jgoldma

TS Rookie
In case you are running on a Dell and still looking for a solution, this worked for me:

-- Get the driver from Dell support site. E.g. for my ATI Mobility Radeon X600:

http://support.dell.com/support/downloads/type.aspx?c=us&l=en&s=gen&SystemID=Latitude D810&os=WW1&osl=en&deviceid=6478&libid=6

-- removing all other video drivers

-- install the Dell driver

NOTE: I believe this is, in effect, a roll-back from the latest driver on the ATI web site, but at least it got me back up and running ATI's driver, instead of the lowly built in VGA driver.

-Jon
 

jgoldma

TS Rookie
After installing the Dell ATI driver, I was able to get past the "INF Error", and install the latest driver from the ATI web site. Basically the solution was to first run the 'broken' driver install from ATI. Then after it fails, ask windows to manually find the driver (which was sitting on disk from the previous step)

The long and involved steps went like this for me:

-- Download latest driver from ATI site, e.g. the 6-9_xp-2k_dd_35774

-- Run driver/install

-- After fails, right click on desktop, and select Properties

-- Goto Settings, then Advanced

-- Click on Adapter tab, you should see your Adapter type (e.g. RADEON X600 Series)

-- Click on Properties button

-- Click on Driver tab

-- Click on Update Driver... button

-- Click on "No, not this time" radio button (to bypass Hardware Wizard searching the web)

-- Click Next

-- Click on "Install from a list or specific location (Advanced)" radio button

-- Click Next

-- Click on "Don't search. I will choose the driver to install" radio button

-- Click Next

-- Click on Have Disk...

-- Click Browse...

-- Navigate to the location where ATI installed the driver files. For example, for me they reside in C:\ATI\SUPPORT\6-9_xp-2k_dd_35774\2KXP_INF

-- Select the .inf file. There were two inf files on my disk, not sure but I tried both, e.g. X2-35774.inf

-- Click Open

-- Click Ok

(The next part is a little confusing, but seemed to work for me)

A dialog comes up with a huge list of drivers. I Navigated until I found the one closest to RADEON X600. It was confusing because there seemed to be several close choices. I think i selected "RADEON X600 Series"

-- Click Next

At this point a driver warning dialog popped up that recommended against installing the driver because Windows could not verify it, but I threw caution to the wind and installed it anyway

-- Click Finish

* * * Whew * * * that was painful.


Now Windows wanted to reboot the computer. I eventually did and it all came up... but I still have not done the critical test of running a game or two to see if stuff still works, or hey, works even better.

-Jon
 

miked98

TS Rookie
thanks a ton jgoldma -- that worked for me. (i have a Dell Latitude laptop that had a Mobility Radeon 7500 -- and i chose the 'Radeon 7500 Series').
 

sith_lord

TS Rookie
plz help NEEDED!!

a few months ago i successfully installed new drivers with catalyst for my radeon 9000 pro. First thing that always confuses me is that my system recognizes my video display as SAPPHIRE RADEON ATLANTIS... (?) (I dont know the number it writed then but...). But that's not what actually bothers me: i got new omega drivers which "should" boost my card to maximal performance, but when i installed it, first thing Omega wanted me to do, was to remove my older ati control panel. i did it and followed instructions. when setup finished, i tried to play LEGO Star Wars 2 but, instead of a game i got blue screen and my system rebooted... :( Then, i tried anything - but nothing helped. Then i regreted installing Omega drivers and wanted to get back my old drivers 'cause they were really ok... My friend came to me and tried to fix the problem and install new drivers with newest catalyst but i always get message SEVERE:inf error... the same as problem from above. then i came to this page and tried jgoldma's advice and i successfully installed new drivers (don't know if i chose right model(?)), but when i try to fully install from beginnig catalyst drivers - 0 points... I get the same message over and over... when i try to play again the same game i get another message: "Sorry, but your machine is unable to run this game. It requires a graphics card which supports Pixel Shaders v1.1...": Can you guys just explain HOW TO INSTALL AGAIN THOSE DRIVERS FROM CATALYST WITHOUT ANY PROBLEMS AND ERROR MESSAGES...?
 

sith_lord

TS Rookie
tnx

I've already fixed problem by myself. It was pain in my ... but I managed (somehow) to make it perfectly work. THANKS!!! anyway... :)
 

TC Machine

TS Rookie
I had a problem installing the Catalyst driver for my Radeon 9800 card with Windows booting up in VGAsave mode, the ATI program stopped installing saying I must be in VGA mode to complete the install. I then chose Microsoft Radeon drivers from the disabled Radeon drivers in Device Manager and used the "Update Driver" command by right-clicking the device. After a reboot the ATI Catalyst program allowed the full install and everything worked perfectly.
 
Status
Not open for further replies.