Raid 0 Failure

By Dalmighty ยท 4 replies
May 3, 2010
  1. I recently ran into a bit of trouble involving my Raid 0 Drives. I have three hard-drives with 2 500GB drives in a Raid 0 array. However after a restart, the computer showed this during start-up.

    Controller Bus#00, Device1F, Function#02: 06 Ports, 04 Devices
    Port-00: Hard Disk -------------------------
    <Drive is controlled by the RAID BIOS>
    Port-01: Hard Disk -------------------------
    <Drive is controlled by the RAID BIOS>
    Port-02: No Device Detected
    Port-03: CDROM, PIONEER DVD-RW DVR-216
    Port-04: No Device Detected
    Port-05: No Device Detected

    Under the Intel Matrix Storage Manager, It listed my RAID 0 array as failed:
    Name Level Strip Size Status Bootable
    Volume0 RAID0(Stripe) 120KB 931.5GB Failed No

    and only listed two of my hard drives with green text. You can see it does detect my missing drive, but doesn't recognise it on Port-02. I checked the wiring and everyone works, except for the missing drive.

    After that, either the window logo loads OR it gets to the safe mode selection, resulting in a BSOD (0x0000007B - 0xF789E324,0xc0000034 -------------)

    I tried going around in the BIOS and tweaking the settings and I only managed to startup with my backup drive on IDE. However it still crashes on RAID mode even when I disconnected the other two drives.

    Whilst I know that a Raid 0 failure usually means all the data is unsalvageable, but this happened after someone tried to wreck my desktop by uninstalling a few drivers. This fits with the BSOD error code. I was considering deleting and recreating my Raid 0 array but it wouldn't solve the missing disk problem.

    I want to ask if the Raid 0 failure is due to one of the hard drives failing or corrupted or the result of the drivers being uninstalled. If so, is it possible to fix this?

    Luckily I use my laptop when I go around so most of my data is backed up. But it would be nice if I could get my hard drives working again.

    Thanks alot if you can help.
  2. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    The issue is likely a corrupt partition table(PT) in the missing drive.

    RAID-x creates its own PT and when corrupted, the drive is not accessible.

    The first thing you will need to do is to reinstall the OS, which means reformatting.
    Be sure to NOT USE the quick format method -- you need the entire disk to be low-level
    formatting -- might as well do ALL the drives as you don't want to do this very often (or ever again).

    Load the RAID drivers, but do not use RAID for the boot volume, just for the two data drives.

    Now reinstall the OS and then deal with the initialization of the two other drives and recovering your data.
  3. Dalmighty

    Dalmighty TS Rookie Topic Starter

    Thanks for the response,

    For now I'm using my backup disk as the boot volume whilst I backup the data to somewhere safer.

    I might try installing the intel matrix storage drivers onto the disk before reformatting on the small chance it might solve my problems. It'll fix my BSOD when starting up on AHCI/RAID mode at least, but it probably won't fix my hard drive error.

    BTW is it a bad idea to run CHKDSK or an equivalent utility on the working half of my raid 0 array? How about trying to run it under IDE/AHCI mode? Would I lose my data and wreck my HDD? Can't help to ask..
  4. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    backup on a broken raid-0 is futile; it will never restore correctly, so don't waste your time and media
    that will only make things worse - - load new raid drivers ONLY immediately before the RAID configuration and formatting
    all the data is already GONE, unless you have a backup prior to disk3 failure.

    This config is all-or-nothing. As soon as any hd fails, the only recovery that will work is
    1. replace the failed HD
    2. reconfigure the raid-0
    3. perform a restore from backup media
    which is why raid-0 is not for the faint of heart OR the home user.

    Sorry to hear of your plight :sad:
  5. Dalmighty

    Dalmighty TS Rookie Topic Starter

    Aw damn, was worth a try anyway.

    Oh and I meant the data in my working backup drive, not the Raid 0 array.

    It's probably a good time to upgrade to windows 7 too. Heh
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...