Realtek HD Audio not working at all

By Peripheralz ยท 15 replies
Dec 17, 2013
Post New Reply
  1. So I just did a clean install of windows 7 64bit onto my new motherboard, its a asus M5A99FX PRO R2.0 and ive installed all of windows updates, and drivers, ive installed all the drivers that came with my mobos disc, and the realtek hd audio driver isnt showing up as an audio device, its neither in my device manager or control panel, ive tried uninstalling and reinstalling many times and tried updating the driver and it still isnt working, I made sure the on board audio is enabled through my bios to, but nothing ive tried has worked, I went into dev manager and viewed through "connections" and I think its showing up as HD audio controller but thats it, I tried updating, uninstalling it but its not working, even updating my bios to the latest version, im running sli gtx 460's if that helps, please get back to me its very frustrating, both the front and rear jacks arent working.

    Not in devmgr but its installed?

    Or in control panel

    Trying to give everything I can that might help

    Attached Files:

    Last edited by a moderator: Dec 17, 2013
  2. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +974

    There could be many issues here. First of all, you have way too many audio drivers installed. This could be causing conflicts. If I were you, I would uninstall Razer Surround especially. Personally, I didnt really like the experience I got after installing it, and frankly, a lot of Razer software is pretty bad. So that would be my first guess as to why the driver isnt showing. Secondly, why do you have so many nVidia HD Audio drivers installed?

    Ok, so here are some possible fixes:
    1) Create a system restore (if you need help, refer to this)
    2) Uninstall Razer Surround.
    3) Uninstall nVidia Virtual Audio.
    4) Go back to Device Manager and uninstall any remaining nVidia HD Audio or Razer Surround drivers by right clicking and pressing uninstall.
    5) Restart your PC.
    6) Download and install the latest Realtek HD audio driver from here.

    Tell me if this solves the issue. If it does not, report back.
    Last edited: Dec 17, 2013
  3. Peripheralz

    Peripheralz TS Rookie Topic Starter

    I dont really know why I have so many nvidia drivers haha, im running sli gtx 460, could that be doing it? and as for razer ill give those suggestions a shot
  4. Peripheralz

    Peripheralz TS Rookie Topic Starter

    Sadly it did not work, and also windows keeps adding ALL of the nvidia drivers back
  5. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +974

    Hmm. Maybe go to the device manager and right click on each separately and check the box that states, "delete driver software" after the prompt comes up asking whether you want to uninstall or not.

    If this doesnt work, I have another solution, but I really dont get why the nVidia audio driver is installing multiple times.

    This is the other solution: run this tool. It should automatically fix your "no sound" issues. Unfortunately, it will not fix the audio driver clutter.
  6. Peripheralz

    Peripheralz TS Rookie Topic Starter

    Yea I did that on one of them and it got rid of all of them, but when I reboot it reinstalls ALL of them haha im going to run that tool
  7. Peripheralz

    Peripheralz TS Rookie Topic Starter

    It didnt detect any problems :/
  8. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +974

    Oh man. I cannot seem to find a solution. Maybe someone else can shed light on this issue.

    Maybe try uninstalling and disabling your internet connection and restarting so it cannot retrieve new drivers. And then install the Realtek driver.
  9. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    This is a long shot to. I have all the nvidia hd sound drives in my computer. With my realtek. drivers. With no problems at all. If it were me I would try disabling the razor sound driver. Then try installing Realtek driver. Just to rule out by chance It is not canceling the realtek driver out as the main sound controller. Just a thought. Hope it helps.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Uninstalling an audio controller then reboot, causes it to reinstall and then try re-detect all of its downstream devices. So we'll try re-installing the controller for the downstream Realtek audio device.

    You said you already know how to View by Connection in DevMgr? A
    > View by connection
    > Expand ACPI catetories untill you get to PCI
    > You should now see TWO HD Audio Controllers.
    ... One's for downstream nVidia. You'll see all nVdia connected to it
    ... The other controller, is for downstream Realtek. Problem, in your case, no devices appear downstream.

    Right click the controller without any downstream devices. (that's the realtek controller) Select Uninstall. Reboot. Now look again, any downstream devices this time on both controllers?
    Last edited: Dec 18, 2013
  11. Peripheralz

    Peripheralz TS Rookie Topic Starter

    Ive done that but after reboot windows just installs its own hd audio driver

    I believe it should be this one

    Attached Files:

    Last edited by a moderator: Dec 18, 2013
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Looks to me like you've done every thing right. (I'd guess you even read many old threads in the forum as you posted just about all the diagnostic data in your very first post! :) (y)

    IMO The additonal info from the last two posts (#10 and #11) make me believe the Realtek audio chip failed. You said the board is new? Is it still under warranty? Work on getting ASUS to RMA the board

    /* EDIT */
    p.s. That's also correct. Just about every HD audio controller I've seen in these forums (except for one) use the Microsoft generic driver for the controller. The vendors just supply their own hardware specific drivers for their sound cards (which sit downstream from the controller)
    Last edited: Dec 18, 2013
    Peripheralz likes this.
  13. Peripheralz

    Peripheralz TS Rookie Topic Starter

    Yea I was reading an older post about the same thing and was following some of the steps someone was talking about so someone could read them and diagnose my problem haha but ok
    mannnnnnnnn I guess ill have to do that then :p thanks for all the helps guys :)
  14. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +974

    Glad to help.
  15. Brais

    Brais TS Rookie

    Sorry, I know this is an old topic but I've been driven to near madness over this same issue. It could potentially be a hardware failure but I'm long out of RMA window and don't have the money to get a new mobo. I find it way too coincidental that our problems are nearly exact. My Realtek suddenly ceased working when I went from a single GTX470 to an SLI with the GTX470. Running a single 470 allowed the two drivers to coexist without issue. I've uninstalled, reinstalled, disabled, enabled both the NVIDIA drivers and the Realtek driver. I've had this issue for years now but I use the HDMI output from my monitor so it's something I could ignore.

    I've been down to one 470 for a while now since I gave up my SLI to gift a 470 to a friend but I've tried many times to fix this to no avail. I also remember initially being upset because the volume was drastically reduce when I had to go away from the on-board audio and go through my monitor's audio output to the same set of speakers.

    I apologize for reviving an old thread but this confirms what I already knew, that the SLI caused this strange issue. I unfortunately am not familiar with DevMgr as the OP was but I'll provide any information I can and will create a new thread if needed. I registered hoping someone can help me with this.

    Mobo: Intel DX58SO
    GPU: EVGA GTX 470

    Edit: Forgot to mention, Realtek no longer shows up under device manager. Only the four NVIDIA HD Audio drivers. However the Realtek driver is listed under programs and the Realtek HD Audio manager is enabled at boot when checking MS config but I haven't been able to access the Realtek control panel in years. Tonight I made another attempt with Display Driver uninstaller hoping for a clean break/start from the NVIDIA drivers but it didn't fix it. Thanks for the help.

    IMBACORE TS Rookie

    I've gotten Razer Surround to cooperate with Realtek HD:

    So sorry for the necro BUT I tried googling for a fix and didn't' find any. Luckily after weeks of being clueless I stumbled on this fix about how to make the Sound Effects tab of Realtek HD work with Razer Surround by my lonesome. Razer should roll out a proper patch for this. I'm fairly sure it's not Realtek's fault as everything works fine and dandy without Surround.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...