Router / DSL, one of the PCs can't access Internet :(

By DigitAlex ยท 4 replies
Apr 5, 2004
  1. Hello all

    I have a very nasty problem with my home LAN and I thought I solved it many times, but it always comes back, so now I'm out of ideas ...

    The setup of my home LAN is very simple :

    DSL Internet > DSL Modem / Router (ASUS AAM6000EV) > Ethernet hub > 2 PCs

    Both PCs are set to static IPs (because they both run servers) even if the modem/router has a DHCP server.

    The other thing to know is that normally my ISP does not allow more than one PC / contract, so I really have no clue about that, but I don't think they can find a way to block a second PC accessing the Internet from behind a router with NAT.

    So, the problem is the main PC has full Internet access, but the second one does not. Well it's actually partial. I can ping any web server and I get a normal response without any packet loss, but when I try to reach the same website with my browser, it never works. The common IMs don't work either.

    I already tried to disconnect my PCs from the router and connect only the second one. It sometimes makes it work, sometimes not. Sometimes it works for a while and then stops working again. Another thing to consider is that I had another machine before at the same place with the same settings, and the problem was about the same ...

    As ping works and browsing does not, either it's my ISP who found a way to block that (doubtfully), either I have some kind of problem with the network layers....

    As I said, I'm really out of ideas :( Please help, mighty NAs :D
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Is the DSL connection created by the router or one of the PCs? If it is the former then it may as well be your ISP blocking things.

    Have you actually disabled the DHCP server? The less stuff you have running on your router the more stable it will be. Any chance that the DHCP IP pool overlaps with your static IPs?

    A cable/port/hub problem is a possibility also. Short ping packets may go through but bulkier traffic may not. Have you tried a long ping with more than 100 packets?

    Do you have any firewall rules defined on the router? Port forwardings? Try removing those and see if the problem persists. Buggy firmware can do most wonderful things with your network traffic.
  3. DigitAlex

    DigitAlex TechSpot Paladin Topic Starter Posts: 536

    ok, thanks for the hinds nods !
    dhcp disabled
    no firewall rules, i tried diabling NAT, still the same

    as i wrote, 2 dif machines had the same problem

    another thing weird is that my second PC sometimes dissapears from the router ARP table, the first never does

    and restoring it to the arp table manually is not giving it access to the internet
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    A few basic setups when networking:

    Router-setup WAN:
    Protocol: Fixed IP
    IP-address, Subnetmask and default Gateway: as per ISP-information
    DNS-servers: as per ISP-information
    Enable NAT

    Router-setup LAN:
    IP-address: set to e.g. (or use default)
    DHCP-server: disable

    Router: Some System-settings (depending on your router)
    Optional SNTP (time): e.g. for UK/Ireland (GMT)
    uPnP: disable
    Dynamic routing: disable
    Remote config: disable
    Dynamic DNS: disable
    Firewall: Block hacker attack: enable
    Firewall: Block WAN request: enable
    VPN: disable all settings unless you need it

    Internet Protocol (TCP/IP)
    Use the following IP address: (102, 103 etc.)
    Default Gateway: (IP-address from your Router)
    Use DNS Server address: (IP-address from your Router)
    Second DNS: leave blank or put in first DNS-server from WAN-part in Router

    Enable File/Printer sharing if you wish (works only within local network)
    Check individual printer(s) that they are shared as well (in printer-settings)

    And make sure all your PCs are in the same WORKGROUP.

    If software firewall installed, enable the other PCs IP-address(es)
  5. DigitAlex

    DigitAlex TechSpot Paladin Topic Starter Posts: 536

    Okay, I changed the network card and it works fine now. Either it will continue working and then it means it was just the NIC that was mucked up (weird, because pings were passing through, and 100MBPS LAN was working perfectly), either it will stop working after a while, either it means that ne new card (which is an old 10 MBPS one does not support MTU units over 1492 by default, which solves the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...