1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

S-ATA HD = BIG MISTAKE! BIOS doesn't recognize it!

By biopsy ยท 10 replies
Jun 24, 2005
  1. Ok, i've been beating myself over this for the past 6 hours. My damn Western Digital Caviar SE 250GB S-ATA Hard Drive isn't recognized by BIOS. However, when i power up it says that it is connected to the mobo.
    What i've done so far:
    1 - Flashed Bios. Got a newer version. No change.
    2 - Changed jumper position on the HD. I know it won't change much, but i was desperate to try anything.
    3 - Changed the SATA and POWER cables. Still nothing.
    4 - Did the Low Level Format. Absolutely no change.
    5 - Changed the boot mode to: 1) floppy, 2) cd, 3) hdd.
    Then changed it to 1) Floppy, 2) CD, 3) SCSI. Nope, nothing...

    I don't know what else to try. I can feel HD spinning but it won't do anything. I tried to install XP Pro but the installation stops because it is unable to find the HD.

    Here is my setup:
    Asus A7N8X-E Deluxe Motherboard
    AMD Athlon XP (Barton) 3200+ processor
    Speeze Socket A CPU cooler
    Kingston ValueRAM 512MG x 2 Ram
    Western Digital Caviar SE Serial ATA 250 GBs Hard Drive
    ATX 450W Power Supply
    POWERCOLOR R96A-C3N Radeon 9600PRO 128MB DDR AGP 4X/8X Video Card
  2. patio

    patio TS Guru Posts: 482

    When you are running XP setup you will see aprompt early on that says to press F6 if you need to install any other drivers such as RAID etc...
    Hit F6 and it will then prompt you for the driver disk.

    patio. :cool:
  3. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Changed the boot mode to: 1) floppy, 2) cd, 3) hdd.
    Then changed it to 1) Floppy, 2) CD, 3) SCSI. Nope, nothing...

    3) hdd is maybe IDE pata harddrive?
    Is SATA listed as a boot options?
  4. mailpup

    mailpup TS Special Forces Posts: 7,102   +419

    Have you tried installing and using Western Digital's Data Lifeguard Tools 11? It comes with retail versions but if yours is OEM, you can download it from Western Digital's website. You can use it to partition and format your WD HD.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    As a rule of thumb, most motherboard BIOS do not recognize SATA as an option and drivers must be installed consequently. This is why windows defaults to IDE. I never recommend installing SATA as a primary hard drive. There are just too many quirks when dealing with the core system.

    When SATA is developed as a BIOS option, that's when I'll get a SATA drive. I had one before and it was just too much of a pain in the ***. IDE is plenty fast. Yes SATA is faster, but the average joe won't really notice the difference.
  6. alphnumeric

    alphnumeric TS Rookie Posts: 173

    I just bought a GA-7N400 Pro2 motherboard, haven't put it in service yet.
    It has a "SCSI/RAID Cntlr Boot Order" BIOS option that is before and separate from the "First Boot Device", "Second Boot Device", etc BIOS options. The book says "This feature allows you to select the boot order Serial ATA, Raid or SCSI device". Biopsy, does your motherboard have any BIOS options like that?
  7. biopsy

    biopsy TS Rookie Topic Starter

    UPDATE: I tried installing Win XP with SATA drivers on a diskette. Everything went fine until Setup started copying files. I got a blue screen with IRQL_NOT_LESS_OR_EQUAL stop error. This could mean a thousand of different things. CPU overheating, bad RAM ( I don't think this is it). I think my hard drive is bad. I tried the same process yesterday and got ntfs.sys stop error.
  8. biopsy

    biopsy TS Rookie Topic Starter

    i have RAID/SCSI in Advanced options. However, changing it didn't help.
  9. MrDJ009

    MrDJ009 TS Rookie

    Sounds like a BIOS issue

    I've recently encountered a few SATA/ASUS MB issues similar to yours. My board is an A7V600 and there is nothing visible in my BIOS that indicates that the SATA drive has been recognized. Two places within the BIOS needed to change before the drive was usable. One was to enable my "onboard SATA Boot ROM" on the Advanced I/O Device Config menu and the other was to specify that the SCSI came before my IDE drive on the BIOS Boot menu.

    You might want to check out FAQ's on both the Western Digital and ASUS web sites. There have been MoBo/drive compatibility problems reported for some SATA drives.

    My usual approach to adding a new drive is to install it as a slave in a machine with an already working drive. I then use Partition Magic to copy a bootable primary partition to the new drive and then make the new drive my boot disk. Before this switch is made it's important to set the partition on the SATA to "active". This usually works every time.

    For either a clean install, or an upgrade, Win2000Pro or WinXP must have the ASUS SATA drivers loaded at the beginning of SETUP. As previously mentioned by PATIO this is done via a prompt (the F6 key). In my instance I had to do this by copying the drivers from the MB CD to a floppy as suggested in a FAQ on the ASUS web site. Everything went smoothly after that. Good Luck. :)
  10. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    Some ASUS boards don't like SATA, a work around is get a PCI controller card.
  11. biopsy

    biopsy TS Rookie Topic Starter

    This is just an update.
    Everything's working perfect! I finally got the system to run 2 days ago. Well, everything was fine up to the point where windows installation was copying files to the HD. I ended up getting a stop error. First one i got was HD related. So, i decided to do the low format and try again. Did that, got another stop error. Did some research on google and turned out that the cause of the stop error i was getting could be related to 10 different things including bad HD, bad memory, overheating CPU and etc. So i pulled the HD out of the case and shipped it back for a replacement. I also took one RAM memory stick out of the slot. When the new HD arrived, i plugged it back in and did the installation. Copied all the necessary files from ASUS CD to the floopy. Ran the floopy and everything went perfect! System works great. The only thing that i find weird is that bios still doesn't recognize it, however XP does.
    But just out of curiousity, i put the RAM memory stick back in the slot and started up the system and ended up getting the same stop error i got before. So i guess my memory went bad.

    Another issue i was having is that ASUS SATA drivers didn't pass the Windows LOGO test during the installation. So their latest drivers aren't compatible, unless i'm missing something.
    Thanks for the help guys!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...